[RFE] Automatically update the Ubuntu version string in ubuntu-release-upgrader

Bug #1727472 reported by AsciiWolf on 2017-10-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
ubuntu-release-upgrader (Ubuntu)
Medium
Unassigned
Eoan
Medium
Unassigned

Bug Description

Every time there is a new Ubuntu release, one string needs to be manually translated although the only thing that is changing is the Ubuntu version. Please, consider updating this string automatically based on a translated template. It would help many translators.

This string is:
<b><big>Upgrading Ubuntu to version xx.yy</big></b>

Related branches

AsciiWolf (asciiwolf) on 2018-04-11
summary: - [RFE] Automatically update the Ubuntu version string
+ [RFE] Automatically update the Ubuntu version string in ubuntu-release-
+ upgrader
AsciiWolf (asciiwolf) wrote :

Any news about this?

Brian Murray (brian-murray) wrote :

Is there an example of how to do this that you could point me at? Thanks!

tags: added: rls-ee-incoming
AsciiWolf (asciiwolf) wrote :

Well, I didn't have time to look into the source code, but the problem is that instead of having something like "<b><big>Upgrading Ubuntu to version %s</big></b>", there is a hardcoded version that is changed every time a ubuntu-release-upgrader is released for a new Ubuntu version.

Steve Langasek (vorlon) on 2019-05-09
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Medium
Changed in ubuntu-release-upgrader (Ubuntu Eoan):
status: New → Triaged
AsciiWolf (asciiwolf) wrote :
AsciiWolf (asciiwolf) wrote :

Would it be possible to triage that bug report as well?

Adolfo Jayme (fitojb) on 2019-05-10
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
no longer affects: ubuntu-release-upgrader (Ubuntu Eoan)
tags: added: id-5cd4485a41c1b840a60923d4
Gunnar Hjalmarsson (gunnarhj) wrote :

Thoughts:

DistUpgradeViewKDE.py includes a line which replaces "Ubuntu" with "Ubuntu xx.xx":

self.window_main.label_title.setText(self.window_main.label_title.text().replace("Ubuntu", name))

So if the title would be changed to "Upgrading Ubuntu to version %s", I suppose that "%s" could be replaced with the new version in a similar way in DistUpgradeViewGtk3.py respective DistUpgradeViewKDE.py. In that case the new version must be made available in those files somehow. (I don't think it is at the moment.)

tags: removed: rls-ee-incoming
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:19.10.8

---------------
ubuntu-release-upgrader (1:19.10.8) eoan; urgency=medium

  [ Steve Langasek ]
  * Factor the release version out of the to-be-translated strings, so
    that translators don't have to chase updating this for every release.
    LP: #1727472.
  * Update the pot file in the source, evidently not done for the past 3
    years.

 -- Brian Murray <email address hidden> Tue, 18 Jun 2019 08:59:08 -0700

Changed in ubuntu-release-upgrader (Ubuntu Eoan):
status: Triaged → Fix Released
Changed in ubuntu-translations:
status: Triaged → Fix Released
AsciiWolf (asciiwolf) wrote :

Great work, thanks! Would it be possible to also fix the similar issue in python-apt (see my comment #4 in this issue)?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers