Generic instructions for dealing with full partitions don't help much

Bug #1721882 reported by Brian Murray on 2017-10-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Brian Murray
Xenial
Medium
Brian Murray
Zesty
Medium
Brian Murray
Artful
High
Brian Murray

Bug Description

This a parallel to bug 1477455 regarding update-manager and a full /boot partition.

[Impact]
ubuntu-release-upgrader provides generic instructions if a system being upgrade is calculated to not have enough free space for the upgrade to succeed. The instructions include using apt clean and emptying trash. This message won't help if you have a separate boot partition that is low on free space though.

[Test Case]
1) Create a file to be used as a /boot partition (dd if=/dev/zero of=fake-boot bs=1024 count=204800)
2) mkfs -t ext3 fake-boot
3) copy your real /boot somewhere
4) sudo mount -t ext3 fake-boot /boot
5) copy the files from step 3 to /boot
6) fill up /boot so there is less 30MB free space
7) run 'do-release-upgrade -p' (-p is for proposed)

With the current version of ubuntu-release-upgrader you'll see an error message with instructions to "empty your trash and remove temporary packages." With the version of ubuntu-release-upgrader in -proposed you'll receive a message regarding using "sudo apt autoremove".

[Regression Potential]
We are just changing the strings used in the error message, which will introduce untranslated strings but that is better than leaving people with systems that cannot update.

Related branches

Changed in ubuntu-release-upgrader (Ubuntu Artful):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress
importance: Undecided → High
Changed in ubuntu-release-upgrader (Ubuntu Zesty):
status: New → Triaged
importance: Undecided → Medium
Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
tags: added: artful xenial zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:17.10.7

---------------
ubuntu-release-upgrader (1:17.10.7) artful; urgency=medium

  * DistUpgrade/DistUpgradeController.py: Provide better instructions when an
    upgrade is aborted due to a lack of free space in a partition.
    (LP: #1721882)
  * update demoted.cfg, demoted.cfg.xenial, mirrors.cfg

 -- Brian Murray <email address hidden> Fri, 06 Oct 2017 15:16:34 -0700

Changed in ubuntu-release-upgrader (Ubuntu Artful):
status: In Progress → Fix Released
Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: Triaged → In Progress
Changed in ubuntu-release-upgrader (Ubuntu Zesty):
status: Triaged → In Progress
Changed in ubuntu-release-upgrader (Ubuntu Xenial):
assignee: nobody → Brian Murray (brian-murray)
Changed in ubuntu-release-upgrader (Ubuntu Zesty):
assignee: nobody → Brian Murray (brian-murray)
tags: added: id-5982561eb1d9aa0d07be953f
Łukasz Zemczak (sil2100) wrote :

I'd prefer if you included a changelog entry for the updated mirrors.cfg, but that's enough low priority for me to just accept as it is.

Changed in ubuntu-release-upgrader (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-zesty

Hello Brian, or anyone else affected,

Accepted ubuntu-release-upgrader into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:17.04.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello Brian, or anyone else affected,

Accepted ubuntu-release-upgrader into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:16.04.23 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of ubuntu-release-upgrader from zesty-proposed was performed and bug 1727777 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1727777 (not this bug). Thanks!

tags: added: verification-failed
tags: removed: verification-failed
Brian Murray (brian-murray) wrote :

I tested this on an Ubuntu 16.04 using the instructions from the bug description. After filling up my boot partition and using 'do-release-upgrade -p' I received instructions about removing old kernels. Setting to v-done for zesty since that is what Ubuntu 16.04 will upgrade to.

tags: added: verification-done-zesty
removed: verification-needed-zesty
Brian Murray (brian-murray) wrote :

I also tested this on an Ubuntu 14.04 system using the instructions from the bug description. After filling up my /boot partition and using 'do-release-upgrade -p' I received instructions about using 'sudo apt autoremove' to remove old kernels.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:17.04.10

---------------
ubuntu-release-upgrader (1:17.04.10) zesty; urgency=medium

  * DistUpgrade/DistUpgradeController.py: Provide better instructions when an
    upgrade is aborted due to a lack of free space in a partition.
    (LP: #1721882)

 -- Brian Murray <email address hidden> Fri, 13 Oct 2017 11:40:57 -0700

Changed in ubuntu-release-upgrader (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:16.04.23

---------------
ubuntu-release-upgrader (1:16.04.23) xenial; urgency=medium

  * DistUpgrade/DistUpgradeController.py: Provide better instructions when an
    upgrade is aborted due to a lack of free space in a partition.
    (LP: #1721882)

 -- Brian Murray <email address hidden> Fri, 13 Oct 2017 11:55:09 -0700

Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers