No init after do-release-upgrade from 14.04 to 16.04 (kernel panic)

Bug #1652462 reported by Skippy le Grand Gourou on 2016-12-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Unassigned

Bug Description

I tried to upgrade from an up-to-date and working Ubuntu 14.04 to 16.04 using do-release-upgrade. The process seemed to complete successfully except for a couple of errors regarding fcitx packages, which I choose to ignore and fix later.

I then proceeded to reboot, but the system hanged during the shutdown so I decided to hard reboot.

However, I was greeted by a kernel panic preceded by straightforward error messages :

run-init: /sbin/init: No such file or directory
Target filesystem doesn't have requested /sbin/init.
run-init: /sbin/init: No such file or directory
run-init: /etc/init: Permission denied
run-init: /bin/init: No such file or directory
/bin/sh: 0: Can't open splash
Kernel panic — not syncing: Attempted to kill init! exitcode=0x00007f00
etc. (last two lines mentioned for SEO purposes)

Indeed, these files don't exist. It seems /var/log/apt/history.log doesn't log "do-release-upgrade", so I have no clue about what went wrong during the upgrade.

FWIW, I can keep the laptop in this state for a couple of days and check or try whatever is proposed (though I'd rather avoid involving a live CD or similar).

Just found there might be some information in /var/log/dpkg.log and /var/log/dist-upgrade/, I'll dig there when I find some time.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1652462/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → ubuntu-release-upgrader (Ubuntu)
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High

I'm glad to see some activity on this report, however I'm afraid it will be difficult to investigate further, because I installed a fresh 16.04 since then.

All I can say is I chrooted on the root partition from a live CD and tried to upgrade with apt, and figured the installation was completely broken with unsolvable conflicts. Not only fcitx, but dozens of dependencies.

Sorry I can't give more insight, I didn't have much time to investigate further and it didn't occur to me to keep logs.

Graeme Bragg (g-bragg) wrote :

I have just been recovering a system that failed to upgrade from 14.04 to 16.04 with the same error as the OP. The solution was to chroot in from a liveCD following the Update Failure instructions.

After an apt-get update, apt-get upgrade, apt-get dist-upgrade and apt-get -f install the system could be booted normally, albeit without a working X-environment and package dependancy issues.

The package dependancy issues (mostly in Latex-related packages, with it trying to both upgrade and install tex-common as part of an "apt-get -f install", and libboost) were resolved by removing the offending packages and their dependancies with "dpkg --remove --force-remove-reinstreq <packagename>".

apt-get update and upgrade then worked and the system booted with a working X-Environment.

hill (hill.flame1er) wrote :

First thing to do is:
1- boot your linux distribution on USB or CD
2- live boot your system on the USB or CD key
3- in command line type: **mount /dev/sda1**(or your dist partition) **/mnt**
4- **chroot /mnt5- nano /etc/resolv.conf** (in this file, put this line: **nameserver 8.8.8.8**)
6- **apt-get install init**

after reboot your system. It will work fine. Enjoy

Hudson Santos (hudsantos) wrote :

+1 to hill!!

This worked for me (note that I had a 7th step to update initramfs just in case):

1. boot your droplet with a Recovery ISO - Like TigerShark from DigitalOcean
2. Network must be configured, either manually or via TigerShark script.
3. $ mount -rw -o remount /dev/vda1 /mnt
4. $ chroot /mnt
5. $ unlink /etc/resolv.conf && echo "nameserver 8.8.8.8" > /etc/resolv.conf
6. $ apt-get install init
7. $ update-initramfs -u

After reboot your system. It will work fine. Enjoy! ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers