ubuntu-release-upgrader crashed with AttributeError: 'ReleaseNotesViewerWebkit' object has no attribute '_on_navigation_policy_decision_requested'

Bug #1635155 reported by errors.ubuntu.com bug bridge on 2016-10-20
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Brian Murray
Xenial
High
Brian Murray
Yakkety
High
Brian Murray

Bug Description

Test Case
---------
The function was improperly indented so was not callable given that the fix is straightforward we should just confirm that the new version of the package does not appear in the Errors Bucket.

Regression Potential
--------------------
It's possible there's a coding error in the function, but this wouldn't be a regression since we weren't calling it all.

The Ubuntu Error Tracker has been receiving reports about a problem regarding ubuntu-release-upgrader. This problem was most recently seen with package version 1:16.04.17, the problem page at https://errors.ubuntu.com/problem/39e90bcbbf46994181fc6eaccce46d5df8d990a2 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker you can request it at http://forms.canonical.com/reports/.

Brian Murray (brian-murray) wrote :

Here's the Traceback:

Traceback (most recent call last):
  File "/usr/bin/do-release-upgrade", line 165, in <module>
    fetcher.run()
  File "/usr/lib/python3/dist-packages/DistUpgrade/DistUpgradeFetcherCore.py", line 275, in run
    if not self.showReleaseNotes():
  File "/usr/lib/python3/dist-packages/DistUpgrade/DistUpgradeFetcher.py", line 62, in showReleaseNotes
    res = self._try_show_release_notes_webkit()
  File "/usr/lib/python3/dist-packages/DistUpgrade/DistUpgradeFetcher.py", line 74, in _try_show_release_notes_webkit
    self.new_dist.releaseNotesHtmlUri)
  File "/usr/lib/python3/dist-packages/DistUpgrade/ReleaseNotesViewerWebkit.py", line 48, in __init__
    self._on_navigation_policy_decision_requested)
AttributeError: 'ReleaseNotesViewerWebkit' object has no attribute '_on_navigation_policy_decision_requested'

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
Brian Murray (brian-murray) wrote :

It looks like def _on_navigation_policy_decision_requested is improperly indented in DistUpgrade/ReleaseNotesViewerWebkit.py.

Changed in ubuntu-release-upgrader (Ubuntu Yakkety):
importance: Undecided → High
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → In Progress
Changed in ubuntu-release-upgrader (Ubuntu Yakkety):
status: New → Triaged
Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:17.04.2

---------------
ubuntu-release-upgrader (1:17.04.2) zesty; urgency=medium

  * DistUpgrade/ReleaseNotesViewerWebkit.py: fix indentation of function
    _on_navigation_policy_decision_requested. (LP: #1635155)

 -- Brian Murray <email address hidden> Fri, 21 Oct 2016 00:55:46 -0700

Changed in ubuntu-release-upgrader (Ubuntu):
status: In Progress → Fix Released
Brian Murray (brian-murray) wrote :

This actually needs fixing in Xenial since viewing of the Release Notes is done before downloading / using the release upgrader tarball.

description: updated
Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
Changed in ubuntu-release-upgrader (Ubuntu Yakkety):
status: Triaged → In Progress
assignee: nobody → Brian Murray (brian-murray)
Changed in ubuntu-release-upgrader (Ubuntu Xenial):
assignee: nobody → Brian Murray (brian-murray)
status: Triaged → In Progress

Hello errors.ubuntu.com, or anyone else affected,

Accepted ubuntu-release-upgrader into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:16.10.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-release-upgrader (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of ubuntu-release-upgrader from yakkety-proposed was performed and bug 1637032 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1637032 (not this bug). Thanks!

tags: added: verification-failed
tags: removed: verification-failed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:16.10.8

---------------
ubuntu-release-upgrader (1:16.10.8) yakkety-proposed; urgency=medium

  * data/DistUpgradeQuirks.py: configure the quirk which installs the linux
    metapackage to run for every release upgrade. (LP: #1633903)
  * data/DistUpgrade.cfg: add ubuntkylin-desktop to the list of supported
    metapkgs. (LP: #1632665)
  * DistUpgrade/ReleaseNotesViewerWebkit.py: fix indentation of function
    _on_navigation_policy_decision_requested. (LP: #1635155)

 -- Brian Murray <email address hidden> Tue, 25 Oct 2016 12:13:12 -0700

Changed in ubuntu-release-upgrader (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Andy Whitcroft (apw) wrote :

@bdmurray -- am I expecting this update to the mirrors list in the xenial update here?

Brian Murray (brian-murray) wrote :

The list of official mirrors changes regularly and ubuntu-release-upgrader will switch a user to their country's mirror if the mirror they are using is no longer an official one. Updating the official mirrors is something that should definitely happen for LTS releases.

Hello errors.ubuntu.com, or anyone else affected,

Accepted ubuntu-release-upgrader into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:16.04.18 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

16.04.18 does not appear in the bucket at the Error Tracker.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:16.04.18

---------------
ubuntu-release-upgrader (1:16.04.18) xenial; urgency=medium

  * DistUpgrade/ReleaseNotesViewerWebkit.py: fix indentation of function
    _on_navigation_policy_decision_requested. (LP: #1635155)
  * DistUpgradeViewNonInteractive.py: Instead of tripping over errors when
    writing progress to stdout just ignore them so that the upgrade can
    continue. (LP: #1614576)

 -- Brian Murray <email address hidden> Tue, 08 Nov 2016 09:55:26 -0800

Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers