release-upgrader shows that Xenial is still in development & doesn't mention it's LTS

Bug #1603576 reported by ventrical on 2016-07-15
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Medium
Unassigned
Xenial
Medium
Brian Murray

Bug Description

[Test Case]
1) Look at http://archive.ubuntu.com/ubuntu/dists/xenial-updates/main/dist-upgrader-all/current/ReleaseAnnouncement and notice that it doesn't have "16.04 LTS".

When the new version of dist-upgrader is built replace -updates w/ -proposed and observe "16.04 LTS".

----------------------------------------------------------------------

while testing an upgrade from Lubuntu 14.04.4 to xenial using update-manager -d -c it notifys that xenial is still in development and not an LTS version. - see screenshot at link.

https://ubuntuforums.org/showthread.php?t=2330857&p=13517778#post13517778

ProblemType: BugDistroRelease: Ubuntu 16.04
Package: update-manager 1:16.04.3
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Aptdaemon:

Architecture: amd64
CurrentDesktop: LXDE
Date: Fri Jul 15 18:28:53 2016
GsettingsChanges:
 b'com.ubuntu.update-manager' b'first-run' b'false'
 b'com.ubuntu.update-manager' b'launch-time' b'1468616417'
InstallationDate: Installed on 2016-07-11 (4 days ago)
InstallationMedia: Lubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
PackageArchitecture: allSourcePackage: update-manager
UpgradeStatus: Upgraded to xenial on 2016-07-15 (0 days ago)

ventrical (dale-f-beaudoin) wrote :
summary: - update manager does not notify that xenial is LTS
+ update manager (release-upgrader) shows that Xenial is still in
+ development & doesn't mention it's LTS

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Erick Brunzell (lbsolost) wrote :

I'm not sure we need to mention Xenial is LTS in the upgrade notification, but since Xenial has been out since April the warning about Xenial still being in development should be changed.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1603576

tags: added: iso-testing
ventrical (dale-f-beaudoin) wrote :

This is a serious instructional development bug with a main component of the ubuntu LTS notification process reporting inaccurate information during a sensitive upgrade session. Although it is not a critical bug in the overall upgrade, it affects user space is that the end_users have to assume it is an f/p.

Brian Murray (brian-murray) wrote :

We don't recommend users upgrade from one LTS to another until the LTS to which they are upgrading has seen its first point release. This has just happened and we will be making the change next week.

summary: - update manager (release-upgrader) shows that Xenial is still in
- development & doesn't mention it's LTS
+ release-upgrader shows that Xenial is still in development & doesn't
+ mention it's LTS
affects: update-manager (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Triaged
Brian Murray (brian-murray) wrote :

It would have been nice to add the screenshot to the bug report since one has to log in to the forums to view the picture there.

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Medium
Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Brian Murray (brian-murray)
Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → Invalid
description: updated
ventrical (dale-f-beaudoin) wrote :

quoting brian murray
"It would have been nice to add the screenshot to the bug report since one has to log in to the forums to view the picture there."

my bad.

Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: Triaged → In Progress

Hello ventrical, or anyone else affected,

Accepted ubuntu-release-upgrader into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:16.04.15 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Erick Brunzell (lbsolost) wrote :

This looks just fine. There was no need to even run update-manager -d -c, just booted Trusty, checked for updates, and after applying all available updates I was notified of Xenial being available. Next screen shows nothing about being in development. We don't mention that Xenial is LTS but we never have and I don't think that's needed.

tags: added: verification-done
removed: verification-needed
ventrical (dale-f-beaudoin) wrote :

Yes... the notification will come up correctly after 14.04.1 is installed from .ISO and upgrade after updating to 14.04.4 is complete. This verification done on ubuntu-desktop and lubuntu-desktop.

Regards..

ventrical

Brian Murray (brian-murray) wrote :

http://archive.ubuntu.com/ubuntu/dists/xenial-proposed/main/dist-upgrader-all/current/ReleaseAnnouncement

The new ReleaseAnnouncement does contains the words LTS so the bug really is verified, contrary to comment #10.

ventrical (dale-f-beaudoin) wrote :

There are actually two announcements. One just after boot up and one during the upgrade. The second announcements provides more details and links.

 Thank you for your attention to this instructional development bug.

Regards,
Team Captain, Ubuntu Development Version Testing.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:16.04.15

---------------
ubuntu-release-upgrader (1:16.04.15) xenial; urgency=medium

  * Add the letters LTS to the Release Announcement. (LP: #1603576)
  * tests/test_country_mirror.py: modify how the LANG environment variable was
    being modified there by fixing a test failure in test_sources_list.py.

 -- Brian Murray <email address hidden> Fri, 22 Jul 2016 09:42:28 -0700

Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers