Failing do-release-upgrade due to unsupported packages are matching removal black list pattern

Bug #1573998 reported by Maxime on 2016-04-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned

Bug Description

do-release-upgrade fails to upgrade to Ubuntu 16.04 from 15.10 because the packages
postgresql-plpython-9.4 and postgresql-plperl-9.4 are not available on 16.04 but they are matching removal black list pattern ^postgresql-.*[0-9]\.[0-9].*

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: ubuntu-release-upgrader-core 1:15.10.14.4
ProcVersionSignature: Ubuntu 4.2.0-35.40-generic 4.2.8-ckt5
Uname: Linux 4.2.0-35-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CrashDB: ubuntu
Date: Sat Apr 23 22:52:25 2016
InstallationDate: Installed on 2015-10-17 (189 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20151016)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_AU:en
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to wily on 2016-04-23 (0 days ago)

Maxime (dp-maxime) wrote :
Maxime (dp-maxime) wrote :

I was able to proceed with upgrade after manually removing the following packages:
postgresql-plpython-9.4
postgresql-plperl-9.4
It looks like these packages are not available on 16.04 however they are matching the removal black list pattern ^postgresql-.*[0-9]\.[0-9].*

summary: - Failing do-release-upgrade to 16.04 on ASUS Transformer Book T300 Chi
+ Failing do-release-upgrade due to unsupported packages are matching
+ removal black list pattern
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers