Ubuntu GNOME fails to boot after Trusty -> Xenial upgrade

Bug #1571939 reported by Erick Brunzell on 2016-04-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned

Bug Description

Not sure what's gone wrong. After what appeared to be successful completion of the release upgrade I'm unable to boot. In recovery mode it seems that networking can't be enabled and I get an error about no resolv.conf. When trying to boot either the new kernel or the older Trusty (Wily HWE) kernel the screen fills rapidly with errors about UID 1000 followed by a screen with only a blinking tty1 login, but I've never been able to get it to accept my login. I did copy the dist-upgrade logs so I'll attach them.

Erick Brunzell (lbsolost) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1571939

tags: added: iso-testing
tags: added: ubuntu-gnome
Erick Brunzell (lbsolost) wrote :

I see what seems like a lot of "Broken" references somewhat early on in the apt.log.

Erick Brunzell (lbsolost) wrote :

BTW that had been a fresh install from earlier today, then fully updated, and otherwise unmolested. I'm getting a late start on upgrade tests because I had a major hardware failure.

Erick Brunzell (lbsolost) wrote :

Just tried and a fresh install of Ubuntu GNOME Xenial works fine on that hardware.

Erick Brunzell (lbsolost) wrote :

I just tried an Ubuntu Trusty w/Wily HWE -> Xenial upgrade and all went well, so I suspect this is limited to Ubuntu GNOME. The only notable difference is that during the Ubuntu GNOME upgrade I got the "restart services during upgrade w/o asking" message in Ubuntu GNOME but not during the Ubuntu upgrade.

I had planned on asking about an anomaly regarding that, possibly filing a bug report, because the terminal window extends past the bottom of the screen initially when that message appears so unless the user is aware that you need to move the window upwards by clicking on the titlebar and dragging they'd never be aware of the warning at all.

After dragging that window upward you can see the default is no. I typically use the tab key to select yes and then press enter because I'm usually multi-tasking and don't want to be bothered with further notifications but this time I accepted the default "no" because (a) it's possible a user might not even see the warning since it extends past the bottom of the screen and they may try just pressing enter or esc if the process seems frozen, and (b) simply because "no" is the default.

I'm attaching screenshots of that warning behavior and I'm doing a fresh install of Ubuntu GNOME 14.04.4 so I can repeat this test but this time selecting "yes" when that warning appears.

Brian Murray (brian-murray) wrote :

To be clear you said "no" to restarting services in the upgrade scenario of Ubuntu GNOME which failed?

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
Erick Brunzell (lbsolost) wrote :

I just performed another Trusty w/Wily HWE Ubuntu GNOME -> Xenial upgrade, this time selecting yes when asked how to handle restarting services and it still fails to boot after appearing to complete successfully. I grabbed a pic of what the screen looks like on boot. It's not possible to log into tty1 because it just keeps blinking.

Erick Brunzell (lbsolost) wrote :

I've now tried Ubuntu GNOME Trusty w/Wily HWE -> Xenial twice, selecting no the first time, and yes the second time when asked about restarting services. Both failed in the same manner. I'm now going to try Ubuntu GNOME Trusty w/Trusty HWE -> Xenial, and Trusty w/Utopic HWE -> Xenial to see if the same thing happens.

Erick Brunzell (lbsolost) wrote :

Trusty w/Utopic HWE -> Xenial fails to even begin upgrade so I filed bug 1572298.

Erick Brunzell (lbsolost) wrote :

I wonder if this could be an anomaly caused by bug 1571677? I think it's worth repeating after Timo's fix lands.

Erick Brunzell (lbsolost) wrote :

I just tested Ubuntu GNOME Trusty w/Vivid HWE -> Xenial again and it "calculated" the upgrade and seemed to complete successfully but fails to boot afterwards similar to this. I did notice though that on ubuntu-release the upgrade of xorg-lts-transitional resulted in a lot of component mismatches. So, long story short, Trusty -> Xenial upgrades still seem to be broken if Trusty is running anything other than the original Trusty HWE.

Tim Lunn (darkxst) wrote :

it shouldnt matter for Ubuntu GNOME if the transitional package is in universe

Erick Brunzell (lbsolost) wrote :

Just completed a Trusty w/Wily HWE -> Xenial i386 upgrade with the same results, so that rules out being arch specific. I've also now experienced this on three different sets of hardware:

(1) AMD Sempron Processor LE-1250 @ 2.2 GHz
nVidia C61 [GeForce 7025 / nForce 630a] (rev a2)
nVidia MCP61 High Definition Audio (rev a2)
nVidia MCP61 Ethernet (rev a2)
2GB DDR2 RAM

(2) Intel Atom CPU 230 @ 1.60GHz
Intel 82945G/GZ Integrated Graphics Controller (rev 02)
Intel N10/ICH 7 Family High Definition Audio Controller (rev 01)
Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
2GB DDR2 RAM

(3) Intel Motherboard: DB43LD
Intel Pentium Dual-Core CPU E5300 @ 2.60GHz
Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
Intel Corporation 82801JD/DO (ICH10 Family) HD Audio Controller (rev 02)
00:19.0 Ethernet controller: Intel Corporation 82567LM-3 Gigabit Network Connection (rev 02)
3GB DDR2 RAM

What additional info is needed to move this off of incomplete?

Brian Murray (brian-murray) wrote :

I think a less confusing bug report would help. You've tested a lot of different things and it isn't easy to read through all the comments and create a mental table of what has and hasn't worked.

I've performed the following upgrades with no issue:

Ubuntu 14.04 w/ vivid-lts xorg and kernel packages
Ubuntu 14.04 w/ vivid-lts and wily-lts xorg and kernel packages

Additionally, for upgrade testing, it'd really help if you were to include apt-clone_system_stage.tar.gz which exists in /var/log/dist-upgrade/ as that contains information about the packages which the system had installed before upgrade and can restored to another system so I could test the same thing you are.

Erick Brunzell (lbsolost) wrote :

I'm doing the best I can here. As I said in comment #6, "I just tried an Ubuntu Trusty w/Wily HWE -> Xenial upgrade and all went well, so I suspect this is limited to Ubuntu GNOME."

Since i can't boot into the freshly upgraded OS's I can't use ubuntu-bug to collect info so this was the only other way I knew to do this. When I try to copy the dist-upgrade logs using a lateral install it complains that apt-clone_system_stage.tar.gz can't be copied due to lack of permissions (see attached screenshot), that's why the collected logs are missing that.

I've now repeated this with a mixture of amd64 and i386 Ubuntu GNOME fresh (and fully updated) installs of 14.04.2, 14.04.3, and 14.04.4. I'm currently replacing most of these failed upgrades to prepare for further testing but I do have one failed amd64 Trusty w/Vivid HWE -> Xenial upgrade next to the working Trusty install I'm using to post this, and I have another i386 Trusty w/Wily HWE -> Xenial failed upgrade on different hardware. So I could copy additional info from either one or both of those if i know what and how.

I'm currently suffering the after effects of propofol anesthesia from a minor procedure earlier in the day so don't expect me to be even remotely fast or even particularly coherent.

Brian Murray (brian-murray) wrote :

The apt-clone files is created early in the upgrade process so you might be able to get it before agreeing to the upgrade or somewhere else early in the process.

Tim Lunn (darkxst) wrote :

So I ran an upgrade Ubuntu GNOME 14.04.4 -> 16.04, it fails to boot also

This is weird
Apr 20 23:22:12 ubuntu gnome-session[1018]: gnome-shell: error while loading shared libraries: libgbm.so.1: cannot open shared object file: No such file or directory
Apr 20 23:22:12 ubuntu gnome-session[1018]: gnome-session-binary[1018]: WARNING: App 'gnome-shell-wayland.desktop' exited with code 127
Apr 20 23:22:12 ubuntu gnome-session-binary[1018]: WARNING: App 'gnome-shell-wayland.desktop' exited with code 127

$dpkg -L libgbm1
/usr
/usr/lib
/usr/lib/x86_64-linux-gnu
/usr/lib/x86_64-linux-gnu/libgbm.so.1.0.0
diverted by libgbm1-lts-wily to: /usr/lib/x86_64-linux-gnu/old.libgbm.so.1.0.0

Now the wayland session is not available by default, but why are there diverted libraries after upgrade?

Tim Lunn (darkxst) wrote :
Tim Lunn (darkxst) wrote :

I have file bug 1572855 for the diverts above, and can confirm removing them fixes boot

Tim Lunn (darkxst) wrote :

Lance, if the above bug doesnt help once fixed, can you start fresh with new bugs, as Brian said there is way to much going on in this bug to really make sense of it all!

Erick Brunzell (lbsolost) wrote :

"there is way to much going on in this bug to really make sense of it all"

Well I took it on myself to rule out a number of things:

(1) Did it matter if I selected yes or no when asked about restarting services?
(2) Did it also affect Ubuntu or only Ubuntu GNOME?
(3) Which HWE stacks were involved?
(4) Was it arch specific?

Trust me, I wasn't having fun repeating so many upgrade tests ;^)

Regardless I repeated Trusty -> Xenial upgrade tests today after the fix for bug 1572855 was released and they all passed whether starting with fresh installs of 14.04.1, 14.04.2, 14.04.3, or 14.04.4 so we're good.

I did file bug 1573250 about the restart services notification spilling off the screen.

Thanks for testing and for putting together the fix for this, it's truly appreciated.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers