xserver lts-vivid packages not removed after upgrade

Bug #1566540 reported by Brian Murray
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned

Bug Description

I upgraded from Trusty to Xenial and X would not start. After manually removing a bunch of -lts-vivid packages I had a desktop again.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-release-upgrader-core 1:16.04.8
ProcVersionSignature: User Name 4.4.0-16.32-generic 4.4.6
Uname: Linux 4.4.0-16-generic x86_64
ApportVersion: 2.20.1-0ubuntu1
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
Date: Tue Apr 5 14:13:15 2016
InstallationDate: Installed on 2015-10-16 (172 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: Upgraded to xenial on 2016-04-04 (1 days ago)
VarLogDistupgradeTermlog:

Revision history for this message
Brian Murray (brian-murray) wrote :
Revision history for this message
Brian Murray (brian-murray) wrote :

Here's what I did according to my apt/history.log file to resolve the issue:

Start-Date: 2016-04-04 13:13:12
Commandline: apt-get dist-upgrade
Requested-By: bdmurray (1000)
Install: xserver-xorg-video-qxl:amd64 (0.1.4-3ubuntu3, automatic), xserver-xorg-video-vesa:amd64 (1:2.3.4-1build2, automatic), xserver-xorg-video-nouveau:amd64 (1:1.0.12-1build2, automatic), xserver-xorg-core:amd64 (2:1.18.1-1ubuntu4, automatic), libcgi-fast-perl:amd64 (1:2.10-1, automatic), xserver-xorg-video-fbdev:amd64 (1:0.4.4-1build5, automatic), libfcgi-perl:amd64 (0.77-1build1, automatic), libcgi-pm-perl:amd64 (4.26-1, automatic), libxatracker2:amd64 (11.1.2-1ubuntu2, automatic), libllvm3.8:amd64 (1:3.8-2ubuntu1, automatic), xserver-xorg-video-intel:amd64 (2:2.99.917+git20160218-1ubuntu3, automatic), xserver-xorg-video-vmware:amd64 (1:13.1.0-2ubuntu3, automatic), xserver-xorg-video-ati:amd64 (1:7.6.1-1ubuntu2, automatic), xserver-xorg-video-radeon:amd64 (1:7.6.1-1ubuntu2, automatic)
Upgrade: libparse-debianchangelog-perl:amd64 (1.2.0-1ubuntu1, 1.2.0-8)
Remove: xserver-xorg-lts-vivid:amd64 (1:7.7+7ubuntu3~trusty1), xserver-xorg-input-evdev-lts-vivid:amd64 (1:2.9.0-1ubuntu2~trusty1), ubuntu-desktop:amd64 (1.355), xserver-xorg-core-lts-vivid:amd64 (2:1.17.1-0ubuntu3.1~trusty1), xorg:amd64 (1:7.7+1ubuntu8.1)
End-Date: 2016-04-04 13:13:17

Start-Date: 2016-04-04 13:13:38
Commandline: apt-get install ubuntu-desktop
Requested-By: bdmurray (1000)
Install: xserver-xorg-input-all:amd64 (1:7.7+13ubuntu3, automatic), xserver-xorg-input-synaptics:amd64 (1.8.2-1ubuntu3, automatic), xserver-xorg:amd64 (1:7.7+13ubuntu3, automatic), ubuntu-desktop:amd64 (1.355), xserver-xorg-input-wacom:amd64 (1:0.32.0-0ubuntu3, automatic), xserver-xorg-input-vmmouse:amd64 (1:13.1.0-1ubuntu2, automatic), xserver-xorg-input-evdev:amd64 (1:2.10.1-1ubuntu2, automatic), xorg:amd64 (1:7.7+13ubuntu3, automatic)
End-Date: 2016-04-04 13:13:39

Start-Date: 2016-04-04 13:15:25
Commandline: apt-get install libgbm1
Requested-By: bdmurray (1000)
Install: libglapi-mesa:amd64 (11.1.2-1ubuntu2, automatic), libegl1-mesa:amd64 (11.1.2-1ubuntu2, automatic), libdrm-amdgpu1:amd64 (2.4.67-1, automatic), libwayland-egl1-mesa:amd64 (11.1.2-1ubuntu2, automatic), libgl1-mesa-dri:amd64 (11.1.2-1ubuntu2, automatic), libgl1-mesa-glx:amd64 (11.1.2-1ubuntu2, automatic)
Upgrade: libgbm1:amd64 (10.1.3-0ubuntu0.6, 11.1.2-1ubuntu2)
Remove: libegl1-mesa-lts-vivid:amd64 (10.5.9-2ubuntu1~trusty2), libwayland-egl1-mesa-lts-vivid:amd64 (10.5.9-2ubuntu1~trusty2), libgl1-mesa-glx-lts-vivid:amd64 (10.5.9-2ubuntu1~trusty2), libgbm1-lts-vivid:amd64 (10.5.9-2ubuntu1~trusty2), libglapi-mesa-lts-vivid:amd64 (10.5.9-2ubuntu1~trusty2), libgl1-mesa-dri-lts-vivid:amd64 (10.5.9-2ubuntu1~trusty2)
End-Date: 2016-04-04 13:15:30

Start-Date: 2016-04-04 13:15:45
Commandline: apt-get autoremove
Requested-By: bdmurray (1000)
Remove: libllvm3.6:amd64 (1:3.6-2ubuntu1~trusty1)
End-Date: 2016-04-04 13:15:45

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Revision history for this message
malbo (pique-sel) wrote :

I did upgrade tests from 14.04 to 16.04 with VMware Player and found the same problem in the case of an upgrade from Ubuntu 14.04.2 (lts-utopic packages), 14.04.3 (lts-vivid packages) or 14.04.4 (lts-wily packages) : after upgrade, there remain lts-xxxx files that prevent the functioning of X.
I suggest to consider the importance "High" instead of "Undecided"

Revision history for this message
malbo (pique-sel) wrote :

I redid several new testing today and I can not find the problems of the comment #4. It remains undesirable lts-xxxx packages after the upgrade but these packages can be purged without worries. I think the upgrade is operating normally now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers