Kubuntu release upgrade crash when trying to show debconf dialog

Bug #1561786 reported by Philip Muškovac on 2016-03-24
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned

Bug Description

It looks like the KDE ui crashed when trying to show the differences for a config file

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-release-upgrader-core 1:16.04.8
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CrashDB: ubuntu
Date: Fri Mar 25 00:39:20 2016
InstallationDate: Installed on 2015-11-22 (123 days ago)
InstallationMedia: Kubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: Upgraded to xenial on 2016-03-24 (0 days ago)

Philip Muškovac (yofel) wrote :
Philip Muškovac (yofel) on 2016-03-24
Changed in ubuntu-release-upgrader (Ubuntu):
milestone: none → ubuntu-16.04
tags: added: kubuntu
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1561786

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Mike (mike-petersen-web) wrote :

I had the same issue during update from 15.10. I needed to kill the dpkg progress and continue the upgrade manually.

Ferry Toth (ftoth) wrote :

@Mike I had that too on multiple machines. Not sure if it is the same bug though. I believe the problem was that sane.conf needed confirmation to replace or keep, but the dialog box didn't appear, causing the upgrade to stall and no way to continue. The solution was to kill, manually continue. And then of course manually clean up, sigh.

I had that less than one month ago upgrading our main server to 15.10 and hoping that it had been fixed, but no.

Xavier Aragon (xarax-lp) wrote :

This might be a duplicate of bug #1509655. If /var/log/dist-upgrade/main.log ends with a python backtrace pointing to DistUpgradeViewKDE.py line 339, it is the same problem.

Brian Murray (brian-murray) wrote :

It is a duplicate, the traceback can be found in VarLogDistupgradeMainlog.txt.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers