dependency problem on upgrade from trusty to xenial

Bug #1511903 reported by Rolf Leggewie on 2015-10-31

This bug report will be marked for expiration in 37 days if no further activity occurs. (find out why)

14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Unassigned

Bug Description

I get stuck with the following error when upgrading to xenial from trusty.

dpkg: dependency problems prevent configuration of console-setup:
 console-setup depends on lsb-base (>= 4.1+Debian11ubuntu7); however:
  Version of lsb-base on system is 4.1+Debian11ubuntu6.

dpkg: error processing package console-setup (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of keyboard-configuration:
 keyboard-configuration depends on lsb-base (>= 4.1+Debian11ubuntu7); however:
  Version of lsb-base on system is 4.1+Debian11ubuntu6.

dpkg: error processing package keyboard-configuration (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ureadahead:
 ureadahead depends on init-system-helpers (>= 1.18~); however:
  Version of init-system-helpers on system is 1.14.

dpkg: error processing package ureadahead (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cryptsetup:
 cryptsetup depends on lsb-base (>= 4.1+Debian11ubuntu7); however:
  Version of lsb-base on system is 4.1+Debian11ubuntu6.

dpkg: error processing package cryptsetup (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cups:
 cups depends on cups-core-drivers (>= 2.1.0-5); however:
  Version of cups-core-drivers on system is 1.7.2-0ubuntu1.1.
 cups depends on cups-daemon (>= 2.1.0-5); however:
  Version of cups-daemon on system is 1.7.2-0ubuntu1.1.
 cups depends on cups-common (>= 2.1.0-5); however:
  Version of cups-common on system is 1.7.2-0ubuntu1.1.
 cups depends on cups-server-common (>= 2.1.0-5); however:
  Version of cups-server-common on system is 1.7.2-0ubuntu1.1.
 cups depends on cups-client (>= 2.1.0-5); however:
  Version of cups-client on system is 1.7.2-0ubuntu1.1.

dpkg: error processing package cups (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of dbus:
 dbus depends on lsb-base (>= 4.1+Debian11ubuntu7); however:
  Version of lsb-base on system is 4.1+Debian11ubuntu6.

dpkg: error processing package dbus (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of console-setup-linux:
 console-setup-linux depends on keyboard-configuration (= 1.108ubuntu9); however:
  Package keyboard-configuration is not configured yet.
 console-setup-linux depends on lsb-base (>= 4.1+Debian11ubuntu7); however:
  Version of lsb-base on system is 4.1+Debian11ubuntu6.

dpkg: error processing package console-setup-linux (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cron:
 cron depends on init-system-helpers (>= 1.18~); however:
  Version of init-system-helpers on system is 1.14.
 cron depends on lsb-base (>= 4.1+Debian11ubuntu7); however:
  Version of lsb-base on system is 4.1+Debian11ubuntu6.

dpkg: error processing package cron (--configure):
 dependency problems - leaving unconfigured
Setting up fontconfig (2.11.1-0ubuntu6) ...
Regenerating fonts cache... failed.
See /var/log/fontconfig.log for more information.
dpkg: error processing package fontconfig (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 console-setup
 keyboard-configuration
 ureadahead
 cryptsetup
 cups
 dbus
 console-setup-linux
 cron
 fontconfig
Press Return to continue.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1511903/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Brian Murray (brian-murray) wrote :

I'm going to move this to ubuntu-release-upgrader, so we don't lose track of this bug.

tags: added: rls-x-incoming
summary: - dependency problem on upgrade
+ dependency problem on upgrade from trusty to xenial
Paul White (paulw2u) wrote :

Moving to ubuntu-release-upgrader as this wasn't done previously.

affects: ubuntu → ubuntu-release-upgrader (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
affects: ubuntu-release-upgrader (Ubuntu) → console-setup (Ubuntu)
affects: console-setup (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Critical
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Jennifer WIlkerson (jenniferleann)
Rolf Leggewie (r0lf) wrote :

@jenniferleann, this ticket is marke fix released for about 18 months. Has the fix been released?

Changed in ubuntu-release-upgrader (Ubuntu):
status: Fix Committed → Incomplete
Paul White (paulw2u) wrote :

After looking at the Launchpad profiles of jenniferleann and parthabaksi I am reverting the changes made by those users. Anyone making such changes on the day or day after they join Launchpad should be treated with suspicion.

Changed in ubuntu-release-upgrader (Ubuntu):
assignee: Jennifer WIlkerson (jenniferleann) → nobody
status: Incomplete → Confirmed
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Critical → High
Brian Murray (brian-murray) wrote :

When reviewing rls-x bug reports today we came across this bug and noticed that it was reported from before Ubuntu 16.04 was released. Are you aware of any systems on which this happened with the final version of Ubuntu 16.04? Thanks in advance.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Incomplete
Rolf Leggewie (r0lf) wrote :

I experienced it back then, reported it, fixed it somehow and moved on.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers