upgrade to 15.10 failed due to fontconfig

Bug #1511533 reported by paul on 2015-10-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Unassigned

Bug Description

Just not sure with this as it failed upgrading from 15.04 to 15.10 through the updater. Not sure how to build a report that's useful?

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: ubuntu-release-upgrader-core 1:15.10.14.1
ProcVersionSignature: Ubuntu 3.19.0-31.36-generic 3.19.8-ckt7
Uname: Linux 3.19.0-31-generic x86_64
ApportVersion: 2.19.1-0ubuntu4
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: GNOME
Date: Thu Oct 29 21:02:23 2015
InstallationDate: Installed on 2013-09-29 (760 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to wily on 2015-10-29 (0 days ago)
VarLogDistupgradeAptclonesystemstate.tar.gz: Error: command ['pkexec', 'cat', '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'] failed with exit code 126: Error executing command as another user: Request dismissed
VarLogDistupgradeTermlog:

paul (pstilwell) wrote :
Brian Murray (brian-murray) wrote :

From VarLogDistupgradeApttermlog.txt we can the following error occurs first:

Processing triggers for man-db (2.7.0.2-5) ...^M
dpkg: cycle found while processing triggers:^M
 chain of packages whose triggers are or may be responsible:^M
  desktop-file-utils -> mime-support^M
 packages' pending triggers which are or may be unresolvable:^M
  fontconfig: /usr/share/fonts: /usr/share/ghostscript/fonts^M
  shared-mime-info: /usr/share/mime/packages^M
  desktop-file-utils: /usr/share/applications^M
  ureadahead: /etc/init.d: /etc/init^M
  mime-support: /usr/share/applications^M
  ufw: /etc/ufw/applications.d^M
dpkg: error processing package fontconfig (--remove):^M
 triggers looping, abandoned^M
Processing triggers for mime-support (3.58ubuntu1) ...^M
Errors were encountered while processing:^M
 fontconfig^M

summary: - upgrade to 15.10 failed
+ upgrade to 15.10 failed due to fontconfig
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
tags: added: vivid2wily
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers