KernelRemoval information not updated for 15.10

Bug #1508539 reported by Brian Murray on 2015-10-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Brian Murray
Wily
High
Brian Murray

Bug Description

data/DistUpgrade.cfg contains information about kernel versions to remove which is used by DistUpgradeCache.py in identifyObsoleteKernels(). This was not updated during the Ubuntu 15.10 development cycle and should be so that obsolete kernels will be removed.

Related branches

Changed in ubuntu-release-upgrader (Ubuntu Wily):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)
tags: added: wily
summary: - KernelRemoval information not updated for wily
+ KernelRemoval information not updated for 15.10
Brian Murray (brian-murray) wrote :

I've tested the upgrade using the release upgrader tarball from wily proposed and the obsolete kernel detection / removal process looks better.

2015-10-21 15:59:51,435 DEBUG identifyObsoleteKernels()
2015-10-21 15:59:54,727 DEBUG removing obsolete kernel 'linux-headers-3.19.0-15-generic'
2015-10-21 15:59:54,727 DEBUG skipping running kernel linux-headers-3.19.0-30-generic
2015-10-21 15:59:54,728 DEBUG removing obsolete kernel 'linux-image-3.19.0-15-generic'
2015-10-21 15:59:54,728 DEBUG skipping running kernel linux-image-3.19.0-30-generic
2015-10-21 15:59:54,729 DEBUG removing obsolete kernel 'linux-image-extra-3.19.0-15-generic'
2015-10-21 15:59:54,729 DEBUG skipping running kernel linux-image-extra-3.19.0-30-generic
2015-10-21 15:59:56,525 DEBUG identifyObsoleteKernels found '{'linux-image-extra-3.19.0-15-generic', 'linux-image-3.19.0-15-generic', 'linux-headers-3.19.0-15-generic'}'

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:15.10.14

---------------
ubuntu-release-upgrader (1:15.10.14) wily; urgency=medium

  [ Brian Murray ]
  * data/DistUpgrade.cfg: Update kernel version and types that will be
    considered for removal. (LP: #1508539)

  [ Martin Pitt ]
  * DistUpgrade/imported/invoke-rc.d: Import current version with systemd
    support, to fix upgrade failures of packages which only ship upstart and
    systemd units, but no SysV init script (like lxc, ofono, or nfs-common).
    (LP: #1504897)

 -- Martin Pitt <email address hidden> Wed, 21 Oct 2015 23:40:22 +0200

Changed in ubuntu-release-upgrader (Ubuntu Wily):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers