DistUpgradeFetcherKDE always errors on 403 releasenotes

Bug #1507887 reported by Harald Sitter on 2015-10-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Critical
Unassigned

Bug Description

# Impact
DistUpgradeFetcherKDE uses the HTML URI for release notes to get the html version and render it in a qtextview. The fetching however is handled through urllib and apparently there is server-side settings in place preventing the html to be fetched via urllib resulting in 403 errors no matter what. The errors in turn result in critical errors from which the present fetcher code doesn't let you proceed to the upgrade itself rendering upgrades impossible.

# Test Case
- `kdesudo -- do-release-upgrade -m desktop -f DistUpgradeViewKDE`
- Upgrade nodes should be displayed without error

# Regression Potential
This technically degrades visual behavior of the fetcher, practically it doesn't since it appears to me that the HTML URI didn't work with live servers due to them apparently having always thrown 403s

# Other Info
Ideally IMO the server side restriction ought to be removed. History suggests this wouldn't get done quicker than this behavior change though.

Related branches

Changed in ubuntu-release-upgrader (Ubuntu Vivid):
status: New → Triaged
importance: Undecided → Critical
Harald Sitter (apachelogger) wrote :

This happens with apt-cacher set up as proxy making the requets go through the cacher and breaking the request....

no longer affects: ubuntu-release-upgrader (Ubuntu Vivid)
Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → Invalid
Brian Murray (brian-murray) wrote :

If this is not getting changed in wily, could the fix get backed out of the ubuntu-release-upgrader branch?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:15.10.13

---------------
ubuntu-release-upgrader (1:15.10.13) wily; urgency=medium

  * Revert change from 15.10.11, already rejected from wily-proposed

 -- Jonathan Riddell <email address hidden> Tue, 20 Oct 2015 16:56:06 +0100

Changed in ubuntu-release-upgrader (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers