"Upgrading Ubuntu to version " not translated

Bug #1502529 reported by Josef Andersson on 2015-10-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Brian Murray

Bug Description

When starting an upgrade to a new Ubuntu version (i tried from 15.04 to 15.10), there's a string that isn't translated, even though the translation states update-manager is 100% percent translated (in Swedish) for the affected versions. The string is the header "Upgrading Ubuntu to version ", see picture attached.

Related branches

Josef Andersson (northar) wrote :
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

This is actually in ubuntu-release-upgrader, so I've moved the bug to that package.
I've found the following by looking in the source code:
* The title is marked as translatable in the UI:
<property name="label" translatable="yes">&lt;b&gt;&lt;big&gt;Upgrading Ubuntu to version 15.10&lt;/big&gt;&lt;/b&gt;</property>
(http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/wily/ubuntu-release-upgrader/wily/view/head:/data/gtkbuilder/DistUpgrade.ui#L1158)
* The po file seem to be outdated, since it has a translation which attempts to match the previous version number:
msgid "<b><big>Upgrading Ubuntu to version 15.04</big></b>"
msgstr "<b><big>Uppgradera Ubuntu till version 15.04</big></b>"
(http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/wily/ubuntu-release-upgrader/wily/view/head:/po/sv.po#L1712)

So I'm fairly certain this would start working if the package pulled in the latest translations from LP. While writing this it occured to me that I was looking up the source code for the latest version, i.e. Wily. Presumably this needs a fix in 15.04 which will actually display the title with 15.10. I'm not familiar with the workflow for these packages, so I don't know if it is customary to release a new version of this package with updated translations right before the next Ubuntu release becomes available.

affects: update-manager (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
tags: added: vivid
tags: added: i18n
Brian Murray (brian-murray) wrote :

The release upgrade process downloads a tarball of the release upgrader for the next release of Ubuntu, so the statement:

"Presumably this needs a fix in 15.04 which will actually display the title with 15.10."

Is incorrect, this only needs to be fixed in the Wily version of the package which creates the tarball used to upgrade from Vivid to Wily.

tags: added: wily
removed: vivid
Brian Murray (brian-murray) wrote :

Also if we look at the date the PO file was generated we can see that it was quite recent, 2015-09-29

https://bazaar.launchpad.net/~ubuntu-branches/ubuntu/wily/ubuntu-release-upgrader/wily/view/head:/po/sv.po#L20

Brian Murray (brian-murray) wrote :
summary: - Non translateable header "Upgrading Ubuntu to version "
+ "Upgrading Ubuntu to version " not translated
Brian Murray (brian-murray) wrote :

In comment #4 I actually meant the following bzr branch which is receiving the imports.

https://bazaar.launchpad.net/~ubuntu-core-dev/ubuntu-release-upgrader/trunk/view/head:/po/sv.po

Brian Murray (brian-murray) wrote :

This may be because Launchpad is showing the translation focus as Vivid.

https://translations.launchpad.net/ubuntu

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
Hans Joachim Desserud (hjd) wrote :

Thanks for looking into this, Brian. :)

>The release upgrade process downloads a tarball of the release upgrader for the next release of Ubuntu

Oh, I didn't know that. It makes sense though.

Btw, I found bug 1300760 which seems to be the same issue, so maybe this should be marked as a duplicate?

Colin Watson (cjwatson) wrote :

The translation focus in fact isn't relevant; that was my mistake. Sorry.

The problem is that po/ubuntu-release-upgrader.pot in the upstream trunk branch needs to be regenerated against data/gtkbuilder/DistUpgrade.ui in that same branch. See:

  http://bazaar.launchpad.net/~ubuntu-core-dev/ubuntu-release-upgrader/trunk/view/head:/po/ubuntu-release-upgrader.pot

Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:15.10.9

---------------
ubuntu-release-upgrader (1:15.10.9) wily; urgency=medium

  * po/update-manager.pot:
    - updated (LP: #1502529)

 -- Brian Murray <email address hidden> Wed, 07 Oct 2015 16:20:08 -0700

Changed in ubuntu-release-upgrader (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers