demoted.cfg is a broken symlink in the upgrader tarball

Bug #1498193 reported by Brian Murray on 2015-09-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Brian Murray
Trusty
High
Brian Murray
Vivid
High
Brian Murray

Bug Description

TEST CASE
---------
Try upgrading from Precise to Trusty and Utopic to Vivid using the proposed version of ubuntu-release-upgrader (with the -p switch). Either ensure that demoted.cfg is not a broken symlink in /tmp/ubuntu-release-upgrader-TMPDIR or complete the upgrade and confirm that "DEBUG demoted" appears in /var/log/dist-upgrade/main.log.

I tried to upgrade to wily using do-release-upgrade -d and then noticed the following:

bdmurray@blacklightning:/tmp/ubuntu-release-upgrader-4hk6xb9f$ file demoted.cfg
demoted.cfg: broken symbolic link to `./demoted.cfg'

That's not good and needs fixing.

Related branches

tags: added: wily
Brian Murray (brian-murray) wrote :

This appears to be broken since the split off of ubuntu-release-upgrader and update-manager i.e. since Trusty.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:15.10.6

---------------
ubuntu-release-upgrader (1:15.10.6) wily; urgency=medium

  * DistUpgrade/build-tarball.sh: Copy the contents of demoted.cfg so it is
    not a broken symlink. (LP: #1498193)

 -- Brian Murray <email address hidden> Mon, 21 Sep 2015 14:58:41 -0700

Changed in ubuntu-release-upgrader (Ubuntu):
status: In Progress → Fix Released
Brian Murray (brian-murray) wrote :

I upgraded from Vivid to Wily today and again see "DEBUG demoted" information in my /var/log/dist-upgrade/main.log file. This can also be seen in bug 1499421 and bug 1499847. This information has been missing from dist-upgrade log files for quite some time.

Changed in ubuntu-release-upgrader (Ubuntu Trusty):
importance: Undecided → High
status: New → Triaged
Changed in ubuntu-release-upgrader (Ubuntu Vivid):
status: New → Triaged
importance: Undecided → High
Brian Murray (brian-murray) wrote :

I've uploaded this to the Vivid queue for review by the SRU team.

Changed in ubuntu-release-upgrader (Ubuntu Vivid):
assignee: nobody → Brian Murray (brian-murray)
status: Triaged → In Progress
Changed in ubuntu-release-upgrader (Ubuntu Trusty):
status: Triaged → In Progress
assignee: nobody → Brian Murray (brian-murray)
description: updated

Hello Brian, or anyone else affected,

Accepted ubuntu-release-upgrader into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:0.220.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-release-upgrader (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in ubuntu-release-upgrader (Ubuntu Vivid):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello Brian, or anyone else affected,

Accepted ubuntu-release-upgrader into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:15.04.14.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
tags: added: verification-done-vivid
Brian Murray (brian-murray) wrote :

I've verified this both on Precise and Trusty and confirm that demoted.cfg is no longer a broken symlink in the release upgrader tarball.

tags: added: verification-done-trusty
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:15.04.14.2

---------------
ubuntu-release-upgrader (1:15.04.14.2) vivid-proposed; urgency=medium

  * Support upgrading from Trusty to Vivid directly since Utopic is End of
    Life. (LP: #1497024)
  * DistUpgrade/build-tarball.sh: Copy the contents of demoted.cfg so it is
    not a broken symlink. (LP: #1498193)

 -- Brian Murray <email address hidden> Mon, 21 Sep 2015 13:05:19 -0700

Changed in ubuntu-release-upgrader (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:0.220.8

---------------
ubuntu-release-upgrader (1:0.220.8) trusty-proposed; urgency=medium

  * DistUpgrade/build-tarball.sh: Copy the contents of demoted.cfg so it is
    not a broken symlink. (LP: #1498193)

 -- Brian Murray <email address hidden> Tue, 29 Sep 2015 12:56:26 -0700

Changed in ubuntu-release-upgrader (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers