SRU: upgrader kde frontend fails to start

Bug #1488843 reported by Jonathan Riddell on 2015-08-26
22
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Critical
Jonathan Riddell
Vivid
Critical
Jonathan Riddell
Wily
Critical
Jonathan Riddell

Bug Description

The execv() line in DistUpgradeFetcherKDE.py needs changed so self.run_options is added to the list, not as part of the list

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: ubuntu-release-upgrader-core 1:15.10.1
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
ApportVersion: 2.18-0ubuntu7
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: KDE
Date: Wed Aug 26 09:53:49 2015
InstallationDate: Installed on 2015-08-25 (0 days ago)
InstallationMedia: Kubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: Upgraded to wily on 2015-08-25 (0 days ago)

Related branches

Jonathan Riddell (jr) wrote :
Changed in ubuntu-release-upgrader (Ubuntu Wily):
assignee: nobody → Jonathan Riddell (jr)
Changed in ubuntu-release-upgrader (Ubuntu Vivid):
assignee: nobody → Jonathan Riddell (jr)
Changed in ubuntu-release-upgrader (Ubuntu Wily):
importance: Undecided → Critical
Changed in ubuntu-release-upgrader (Ubuntu Vivid):
importance: Undecided → Critical
Changed in ubuntu-release-upgrader (Ubuntu Wily):
milestone: none → ubuntu-15.10
Changed in ubuntu-release-upgrader (Ubuntu Vivid):
milestone: none → vivid-updates
Jonathan Riddell (jr) wrote :

Uploaded 15.10.2 to wily with fix

Uploaded 15.04.14.1 to vivid-proposed with fix, awaiting approved by ~ubuntu-sru

TEST CASE:
from vivid run kubuntu-devel-release-upgrade
if release-upgrader runs then you're good

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu Vivid):
status: New → Confirmed
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Jonathan Riddell (jr) on 2015-08-26
summary: - upgrader kde frontend fails to start
+ SRU: upgrader kde frontend fails to start

That's good work, as usual.

Changed in ubuntu-release-upgrader (Ubuntu Vivid):
status: Confirmed → Triaged
Changed in ubuntu-release-upgrader (Ubuntu Wily):
status: Confirmed → Triaged
Changed in ubuntu-release-upgrader (Ubuntu Vivid):
status: Triaged → Fix Committed
Changed in ubuntu-release-upgrader (Ubuntu Wily):
status: Triaged → Fix Committed
status: Fix Committed → Fix Released
Jonathan Riddell (jr) wrote :

reuploaded to vivid-proposed following rejection for pep8 failure, awaiting approval by ~ubuntu-sru

Hello Jonathan, or anyone else affected,

Accepted into vivid-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Jonathan Riddell (jr) wrote :

I installed vivid and set it to use vivid-proposed

I then ran kubuntu-devel-release-upgrade and it successfully downloaded and ran the upgrader

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:15.04.14.1

---------------
ubuntu-release-upgrader (1:15.04.14.1) vivid; urgency=medium

  * Fix upgrader kde frontend fails to start LP: #1488843

 -- Jonathan Riddell <email address hidden> Wed, 26 Aug 2015 13:14:23 +0100

Changed in ubuntu-release-upgrader (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers