baloo is not replaced by baloo-kf5 on dist upgrade breaking release-upgrade

Bug #1426132 reported by Philip Muškovac on 2015-02-26
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Critical
Unassigned
ubuntu-release-upgrader (Ubuntu)
Critical
Unassigned
Nominated for Vivid by Alberto Salvia Novella

Bug Description

Release upgrade from utopic to vivid aborts with

dpkg: dependency problems prevent configuration of kubuntu-desktop:
 kubuntu-desktop depends on baloo-kf5; however:
  Package baloo-kf5 is not installed.

=== If you have a failed upgrade:

- Open konsole and run (most likely removes kubuntu-desktop):
sudo apt install -f

- Force baloo-kf5 upgrade (removes baloo baloo4):
sudo apt install kubuntu-desktop baloo-kf5

===

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: ubuntu-release-upgrader-core 1:15.04.10
ProcVersionSignature: Ubuntu 3.16.0-31.41-generic 3.16.7-ckt5
Uname: Linux 3.16.0-31-generic x86_64
ApportVersion: 2.16.1-0ubuntu2
Architecture: amd64
CrashDB: ubuntu
Date: Thu Feb 26 22:37:27 2015
InstallationDate: Installed on 2014-11-21 (97 days ago)
InstallationMedia: Kubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: Upgraded to vivid on 2015-02-26 (0 days ago)

Philip Muškovac (yofel) wrote :
affects: ubuntu-release-upgrader (Ubuntu) → baloo-kf5 (Ubuntu)
Changed in baloo-kf5 (Ubuntu):
milestone: none → ubuntu-15.04
tags: added: kubuntu
Philip Muškovac (yofel) on 2015-02-26
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in baloo-kf5 (Ubuntu):
status: New → Confirmed
Changed in baloo-kf5 (Ubuntu):
importance: Undecided → Critical
no longer affects: baloo
Changed in baloo-kf5 (Ubuntu):
status: Confirmed → Triaged
Rgpublic (rgpublic) wrote :

Just for the record: I recently upgraded 3 completely different Kubuntu systems to 15.04 beta 1. This problem occured on all 3 of them.

Marco Parillo (marco-parillo) wrote :

it still occurs with Beta2 RC1.

Marco Parillo (marco-parillo) wrote :

Adding screen-shot.

Jonathan Riddell (jr) on 2015-03-26
summary: - baloo is not replaced by baloo-kf5 on dist upgrade
+ baloo is not replaced by baloo-kf5 on dist upgrade breaking release-
+ upgrade
Jonathan Riddell (jr) wrote :

I wants to install kubuntu-desktop, then it wants to install baloo4 which makes not install baloo-kf5 and kubuntu-desktop gets confused. I've no idea why it is so keen to install baloo4, nothing depends on it.

Jonathan Riddell (jr) wrote :

(and I even uploaded a transitional baloo package with the version number munging to allow it to exist which depends on baloo-kf5)

Michael Vogt (mvo) on 2015-03-30
affects: baloo-kf5 (Ubuntu) → apt (Ubuntu)
affects: apt (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:15.04.13

---------------
ubuntu-release-upgrader (1:15.04.13) vivid; urgency=low

  * add workaround for kubuntu upgrade issue with baloo-kf5
    (LP: #1426132)
 -- Michael Vogt <email address hidden> Tue, 31 Mar 2015 21:04:51 +0200

Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → Fix Released
Jonathan Riddell (jr) wrote :

Lovely works, thanks :)

Ornthalas (l-ubuntuone-p) wrote :

This still happens!
I just tried to upgrade my kubuntu to 15.4, and I got the same error!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed

@ Michael Vogt

Could you explain why to decline nomination for this bug?

Changed in apt (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Critical
no longer affects: apt (Ubuntu)
Changed in ubuntu-release-upgrader (Ubuntu):
status: Fix Released → Triaged
Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Critical
Brian Murray (brian-murray) wrote :

@Ornthalas - Could you provide log files of your upgrade experience so we can try and sort out what went wrong? You can find them in /var/log/dist-upgrade. Thanks in advance.

@Alberto - It is rather premature to make this a Critical bug without any evidence indicating that it is not in fact fixed. It would have helped if you were to start investigating this...

Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → Incomplete
Brian Murray (brian-murray) wrote :

There was no response from the person who said it still happened and everything indicates that this was Fixed, so setting the status back.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Incomplete → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers