Unable to open Software Updater after it automatically checked for updates

Bug #1399993 reported by Lizhou Sha on 2014-12-06
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Software Updater
New
Undecided
Unassigned
ubuntu-release-upgrader (Ubuntu)
High
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Software Updater checks for new updates daily, and when it has found updates, it displays an icon on the launcher. Clicking on the launcher should open Software Updater, whereupon the user is prompted to select and install updates.

However, after I upgraded to 14.10, when software updater's icon appers in the launcher, it is unresponsive to clicking. While the icon is still there, attempting to launch a fresh copy of Software Updater from the Dash will not work, as there is an instance of update-manager already running (it's actually sleeping). It is only when I manually quit the update-manager (right clicking on the icon and then click "Quit" will do) that I can relaunch Software Updater.

Curiously, after relaunching Software Updater in this case, it will forget about its previous window size, and default to the tiny version instead.

This problem happens every time for me, so I'm not sure of the exact circumstances under which it's replicable.

More info:

Description: Ubuntu 14.10
Release: 14.10

ubuntu-release-upgrader-core:
  Installed: 1:14.10.9
  Candidate: 1:14.10.9
  Version table:
 *** 1:14.10.9 0
        500 http://mirrors.mit.edu/ubuntu/ utopic/main amd64 Packages
        100 /var/lib/dpkg/status
ubuntu-release-upgrader-qt:
  Installed: (none)
  Candidate: 1:14.10.9
  Version table:
     1:14.10.9 0
        500 http://mirrors.mit.edu/ubuntu/ utopic/universe amd64 Packages
ubuntu-release-upgrader-gtk:
  Installed: 1:14.10.9
  Candidate: 1:14.10.9
  Version table:
 *** 1:14.10.9 0
        500 http://mirrors.mit.edu/ubuntu/ utopic/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ubuntu-release-upgrader-core 1:14.10.9
ProcVersionSignature: Ubuntu 3.16.0-25.33-generic 3.16.7
Uname: Linux 3.16.0-25-generic x86_64
NonfreeKernelModules: openafs
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
Date: Sat Dec 6 16:20:24 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-04-20 (230 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: Upgraded to utopic on 2014-11-11 (25 days ago)
VarLogDistupgradeTermlog:
---
ApportVersion: 2.14.7-0ubuntu8
Aptdaemon:

Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.10
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-04-20 (273 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
NonfreeKernelModules: openafs
Package: update-manager 1:14.10.6
PackageArchitecture: all
ProcVersionSignature: Ubuntu 3.16.0-29.39-generic 3.16.7-ckt2
Tags: utopic dist-upgrade utopic
Uname: Linux 3.16.0-29-generic x86_64
UpgradeStatus: Upgraded to utopic on 2014-11-11 (68 days ago)
UserGroups: adm bumblebee cdrom debian-tor dip lpadmin plugdev sambashare sudo vboxusers
VarLogDistupgradeTermlog:

_MarkForUpload: True

Lizhou Sha (vulpicastor) wrote :
Lizhou Sha (vulpicastor) on 2014-12-07
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Lizhou Sha (vulpicastor) wrote :

It seems that this bug has been resolved by the latest kernel update (or something that went along with it).

Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Invalid

I've been experiencing exactly this bug ever since updating to Utopic at the end of December.

Lizhou Sha (vulpicastor) wrote :

I am reopening this bug because it appears that it never actually went away. It is possible that this bug happens only when Software Updater was left waiting for long enough.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Invalid → New
status: New → Confirmed
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Lizhou Sha (vulpicastor) wrote :

I think the bug actually resides in update-manager, as it is /usr/bin/update-manager that seems to be affected.

Brian Murray (brian-murray) wrote :

Can you take a picture of the icon on the launcher to which you are referring?

Lizhou Sha (vulpicastor) wrote :

Will do -- but since this only happens when it's auto-updating, I will have to wait until the next daily update to grab a screenshot.

peterstan (stasnel) on 2015-08-22
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-release-upgrader (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.