No IPv6 address for changelogs.ubuntu.com

Bug #1376088 reported by MegaBrutal
54
This bug affects 16 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Medium
Unassigned
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Release upgrade with do-release-upgrade is impossible on IPv6-only hosts, as changelogs.ubuntu.com has no IPv6 address.

# do-release-upgrade
Checking for a new Ubuntu release
No new release found

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

$ cat /etc/update-manager/meta-release
# default location for the meta-release file

[METARELEASE]
URI = http://changelogs.ubuntu.com/meta-release
URI_LTS = http://changelogs.ubuntu.com/meta-release-lts
URI_UNSTABLE_POSTFIX = -development
URI_PROPOSED_POSTFIX = -proposed

$ ping6 -c 5 changelogs.ubuntu.com
unknown host

$ host changelogs.ubuntu.com
changelogs.ubuntu.com has address 91.189.95.36

This could probably be worked around by setting a suitable mirror in /etc/update-manager/meta-release, but I think there is a reason why the release upgrader doesn't use the repo mirrors in the first place.

I have no idea who's in authority for this, but it would be best if Canonical would add an IPv6 address to changelogs.ubuntu.com.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Revision history for this message
Brian Murray (brian-murray) wrote :

I've submitted an RT ticket with Canonical's IS department regarding this, the number is 75640.

Revision history for this message
MegaBrutal (qbu6to) wrote :

Just out of curiosity, is there a way to track that ticket you mentioned at Canonical, or is that tracking system private?

By the way, I've found a duplicate of this report here:
https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/776038

Changed in update-manager (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Revision history for this message
Ryan Finnie (fo0bar) wrote :

changelogs.ubuntu.com is now reachable via IPv6.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → Fix Released
Changed in update-manager (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers