unable to upgrade gnome 3 system to 14.04 due to missing package ubuntu-desktop or meta-pkg entry

Bug #1356554 reported by Vitaly Bondar on 2014-08-13
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Medium
Unassigned

Bug Description

Automatic process of upgrade to 14.04 always fails

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubuntu-release-upgrader-core 1:0.205.6
ProcVersionSignature: Ubuntu 3.11.0-26.45-generic 3.11.10.12
Uname: Linux 3.11.0-26-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
CrashDB: ubuntu
Date: Wed Aug 13 22:40:27 2014
MarkForUpload: True
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to saucy on 2014-08-13 (0 days ago)
VarLogDistupgradeTermlog:

Vitaly Bondar (johngull) wrote :
Brian Murray (brian-murray) wrote :

From VarLogDistupgradeMainlog.txt:

2014-08-13 22:39:59,896 DEBUG plugins for condition 'from_saucyPostDistUpgradeCache' are '[]'
2014-08-13 22:39:59,896 DEBUG none of the '['ubuntu-desktop', 'kubuntu-desktop', 'xubuntu-desktop', 'ubuntustudio-desktop', 'mythbuntu-desktop', 'kubuntu-netbook', 'lubuntu-desktop']' meta-pkgs installed
2014-08-13 22:39:59,897 DEBUG guessing 'ubuntu-desktop' as missing meta-pkg
2014-08-13 22:40:00,593 ERROR failed to mark 'ubuntu-desktop' for install (E:Unable to correct problems, you have held broken packages.)

Brian Murray (brian-murray) wrote :

It looks like this is an edubuntu-desktop:

2014-08-13 22:39:59,895 DEBUG Upgrading 'brasero' (Distro PostUpgradeUpgrade rule)
2014-08-13 22:39:59,895 DEBUG Upgrading 'edubuntu-desktop' (Distro PostUpgradeUpgrade rule)

Brian Murray (brian-murray) wrote :

Its odd that ubuntu-desktop isn't installed given that edubuntu-desktop depends on it.

 $ apt-cache show edubuntu-desktop
Package: edubuntu-desktop
Priority: optional
Section: universe/metapackages
Installed-Size: 45
Maintainer: Edubuntu Developers <email address hidden>
Architecture: amd64
Source: edubuntu-meta
Version: 14.03.2
Depends: ubuntu-desktop, gnome-session-fallback
...

summary: - unable automatically upggade to 14.04
+ unable automatically upgrade edubuntu-desktop to 14.04 due to missing
+ package ubuntu-desktop

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

Gah, actually this system is using the Ubuntu Gnome Desktop, which wasn't part of the list of meta packages in the release upgrader until recently.

summary: - unable automatically upgrade edubuntu-desktop to 14.04 due to missing
- package ubuntu-desktop
+ unable to upgrade gnome 3 system to 14.04 due to missing package ubuntu-
+ desktop or meta-pkg entry
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers