release upgrades from an LTS with normal set should offer next LTS if next normal release is EoL

Bug #1354825 reported by Sam Stoelinga on 2014-08-10
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Medium
Unassigned
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

The update-manager tries to update from 12.04 to 12.10 but this seems to fail, because it's no longer supported, instead it should update to 14.04.

Steps to reproduce:
1. Buy a dell laptop with ubuntu 12.04 pre-installed
2. Run sudo do-release-upgrade or update manager gui

Current result:
 sudo do-release-upgrade
Checking for a new Ubuntu release
Err Upgrade tool signature
  404 Not Found [IP: 91.189.92.201 80]
Err Upgrade tool
  404 Not Found [IP: 91.189.92.201 80]
Fetched 0 B in 0s (0 B/s)
WARNING:root:file 'quantal.tar.gz.gpg' missing
Failed to fetch
Fetching the upgrade failed. There may be a network problem.

Expected result:
Ability to upgrade to either 12.10 -> 13.04 -> 14.04
or upgrade directly from 12.04 -> 14.04 a direct upgrade path seems better.

Additonal information of affected system:
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.5 LTS
Release: 12.04
Codename: precise

Also I am not the only one having this bug, see the following stackoverflow question: http://askubuntu.com/questions/504846/upgrading-from-12-04-3-lts-to-14-04-1-lts-failure this question wasn't posted by me, so this isn't only me.

description: updated
description: updated
Brian Murray (brian-murray) wrote :

Please include the output of the following command run in a terminal - "cat /etc/update-manager/release-upgrades". Thanks in advance.

Changed in update-manager (Ubuntu):
status: New → Incomplete
Sam Stoelinga (sammiestoel) wrote :

sudo cat /etc/update-manager/release-upgrades
[sudo] password for ld:
# Default behavior for the release upgrader.

[DEFAULT]
# Default prompting behavior, valid options:
#
# never - Never check for a new release.
# normal - Check to see if a new release is available. If more than one new
# release is found, the release upgrader will attempt to upgrade to
# the release that immediately succeeds the currently-running
# release.
# lts - Check to see if a new LTS release is available. The upgrader
# will attempt to upgrade to the first LTS release available after
# the currently-running one. Note that this option should not be
# used if the currently-running release is not itself an LTS
# release, since in that case the upgrader won't be able to
# determine if a newer release is available.
prompt=normal

Brian Murray (brian-murray) wrote :

You need to change prompt so that it is lts e.g. "prompt=lts".

Sam Stoelinga (sammiestoel) wrote :

I already did, but still it should be able to automatically detect that the next release is 14.04 LTS if using normal. Or at least show some information that user has to manually change the /etc/update-manager/release-upgrades file to prompt=lts.

This is bad for usability! And I am sure many other Dell laptop users encounter exactly the same problem. This bug was found on my Gf's laptop, I am no longer an Ubuntu user myself, mainly because upgrading nearly always broke my system. Switched to Arch because of rolling release.

So instead of having people experience the bug and having to google what the hell is happening, please handle the problem automatically or show a user notification what the user has to do.

summary: - Upgrade from 12.04 to 14.04 fails
+ release upgrades from an LTS with normal set should offer next LTS if
+ next release is EoL
Changed in update-manager (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
summary: release upgrades from an LTS with normal set should offer next LTS if
- next release is EoL
+ next normal release is EoL
Chris Perry (perrych2) wrote :

I had the same problem, it was NOT related to the prompt value. The only way that I managed to fix it was to uninstall and purge update-manager-core (which will remove update-notifier-common) and then reinstall it. After that upgrade proceeded normally. (I did manually delete the /var/lib/update-manager and /var/lib/update-notifier directories as the purge command refused to).

miguelquiros (mquiros) wrote :

I experienced the same problem and, in my case, it seemed to be provoked by a bogus /var/lib/update-manager/meta-release-lts file. It contained what seemed to me an error report page generated by a server (the file looked like a html file with something like "page not available, contact the webmaster").
I think that, at some stage, ubuntu has tried to grab from the web the information that should be placed in this file and the connection failed by any reason, only garbage was retrieved and garbage was written to the file.
After deleting the file, "do-release-upgrade" worked as expected (and wrote a correct meta-release-lts file). Anyway, I aborted for the moment the upgrade (I will perform it when I have time to face any possible problem: these upgrades always rise some issue to be addressed :-) ).

Good luck.

miguelquiros (mquiros) wrote :

Addition to my previous post. There is another file in the home directory, namely ~/.cache/update-manager-core/meta-release-lts that suffered the same problem that the file in /var/lib mentioned in my previous post.
It was neccesary to delete also this file so that the update is offered not only in text mode (do-release-upgrade) but also in the graphical interface of update-manager.

Setting prompt=lts and deleting the contents of /var/lib/update-manager got my laptop on 14.04. But yes, I agree it shouldn't be trying to upgrade to an EoL release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers