Trusty -> Utopic release upgrade reportedly fails

Bug #1350416 reported by Erick Brunzell on 2014-07-30
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned

Bug Description

I repeated this twice, the last time beginning with a totally out-of-box Ubuntu GNOME 14.04.1 installation, fully updated, then ran the upgrade via "update-manager -d -c".

The failure begins with a window saying:

Could not install 'cgmanager'

The upgrade will continue but the 'cgmanager' package may not be in a working state. Please consider submitting a bug report about it.

subprocess installed post-installation script returned error exit status 1

After clicking on the close button in that window just a minute or two later a new window appears that says:

Could not install the upgrades

The upgrade has aborted. Your system could be in an unusable state. A recovery will run now (dpkg --configure -a).

Then after a substantial amount of time (30 to 45 minutes) a window appears that says:

Upgrade complete

The upgrade has completed but there were errors during the upgrade process.

Time to reboot and see what I have.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ubuntu-release-upgrader-core 1:14.10.5
ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic i686
ApportVersion: 2.14.5-0ubuntu1
Architecture: i386
CrashDB: ubuntu
CurrentDesktop: GNOME
Date: Wed Jul 30 10:26:27 2014
InstallationDate: Installed on 2014-07-30 (0 days ago)
InstallationMedia: Ubuntu-GNOME 14.04.1 LTS "Trusty Tahr" - Release i386 (20140722.2)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: Upgraded to utopic on 2014-07-30 (0 days ago)
VarLogDistupgradeTermlog:

Erick Brunzell (lbsolost) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1350416

tags: added: iso-testing
Erick Brunzell (lbsolost) wrote :

It does boot, but apt-get -f install really got busy:

lance@lance-desktop:~$ uname -r
3.16.0-6-generic
lance@lance-desktop:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Utopic Unicorn (development branch)
Release: 14.10
Codename: utopic
lance@lance-desktop:~$ sudo apt-get -f install
[sudo] password for lance:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libavcodec54 libavformat54 libavutil52 liboil0.3 libopenjpeg2
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
23 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up cgmanager (0.27-0ubuntu8) ...
cgproxy stop/pre-start, process 2504
Setting up systemd-shim (6-4bzr1) ...
Installing new version of config file /etc/dbus-1/system.d/org.freedesktop.systemd-shim.conf ...
Setting up libpam-systemd:i386 (204-14ubuntu2) ...
Removing obsolete conffile /etc/init/systemd-logind.conf ...
Setting up udisks2 (2.1.3-2git1ubuntu1) ...
Setting up gvfs-daemons (1.20.2-1ubuntu1) ...
Setting up gvfs:i386 (1.20.2-1ubuntu1) ...
Setting up brasero (3.10.0-1ubuntu1) ...
Setting up gvfs-backends (1.20.2-1ubuntu1) ...
Setting up deja-dup-backend-gvfs (30.0-0ubuntu7) ...
Setting up gdm (3.10.0.1-0ubuntu6) ...
Setting up gnome-shell-extensions (3.12.2-0ubuntu1) ...
Setting up gvfs-backends-goa (1.20.2-1ubuntu1) ...
Setting up gvfs-fuse (1.20.2-1ubuntu1) ...
Setting up pulseaudio (1:4.0-0ubuntu17) ...
Installing new version of config file /etc/pulse/default.pa ...
update-rc.d: warning: stop runlevel arguments (1) do not match pulseaudio Default-Stop values (0 1 6)
Setting up libcanberra-pulse:i386 (0.30-2ubuntu1) ...
Setting up nautilus (1:3.10.1-0ubuntu12) ...
Setting up nautilus-sendto (3.8.1-1ubuntu1) ...
Setting up pulseaudio-module-x11 (1:4.0-0ubuntu17) ...
Setting up gnome-sushi (3.12.0-2) ...
Setting up ubuntu-gnome-desktop (0.33) ...
Setting up usb-creator-common (0.2.60) ...
Setting up usb-creator-gtk (0.2.60) ...
Setting up pulseaudio-module-bluetooth (1:4.0-0ubuntu17) ...
Processing triggers for libc-bin (2.19-4ubuntu1) ...
lance@lance-desktop:~$

Tim (darkxst) wrote :

dpkg: error processing package systemd (--configure):
 dependency problems - leaving unconfigured
Setting up cgmanager (0.27-0ubuntu8) ...
insserv: Service mountkernfs has to be enabled to start service cgmanager
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package cgmanager (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of systemd-shim:
 systemd-shim depends on cgmanager; however:
  Package cgmanager is not configured yet.

Erick Brunzell (lbsolost) wrote :

This does effect Ubuntu also.

summary: - Ubuntu GNOME Trusty -> Utopic release upgrade reportedly fails
+ Trusty -> Utopic release upgrade reportedly fails
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Erick Brunzell (lbsolost) wrote :

I performed both i386 and amd64 Ubuntu GNOME Utopic upgrades yesterday and both worked flawlessly, so I thought this may now be fixed.

tags: added: ubuntu-gnome
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Fix Released
Grizzly (sven-witterstein) wrote :

Just to say that today I wanted to convert my trusty to utopic and it was a total desaster. In addition to what was mentioned above, there was no initrd for kernel 3.16 created, which led to a nice kernel panic when rebooting. BTRFS saved me, so I could roll back to the state before the update, sudo update-grub and will stay on trusty a while, probably checking the release upgrade first in a vm drawn from my current installation.

Erick Brunzell (lbsolost) wrote :

@ Grizzly, you really should have filed a new bug report as this particular bug was fixed some time ago. There are many things that can go wrong in the upgrade process, in your case it's possible that the use of btrfs is not yet fully supported.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers