GTK offers dist-upgrade while do-release-upgrade is running

Bug #1313012 reported by Andreas Altaïr Redmer on 2014-04-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Medium
Unassigned

Bug Description

About the update from 13.10 to 14.04. After the commandline tool do-release-upgrade was already running for around 15 minutes, the GTK applet informed me about a new version and offered me to update. I see this as a small usability bug.

Screenshot attached.

Related branches

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Triaged
importance: Undecided → Medium

Proposing a fix. bzr branch linked.

Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Andreas Altaïr Redmer (altair-ibn-la-ahad)
status: Triaged → In Progress

I'm unsubscribing from this, since I'm not really a python developer.

I saw the bug, reported it, fixed it, because it was easy to fix. My fix in the proposed branch used a shell.exec call, which was reportedly 'a bad way'.

So since this is expected to be solved in 'pure python', I'll leave it for someone else.

Changed in ubuntu-release-upgrader (Ubuntu):
assignee: Andreas Altaïr Redmer (altair-ibn-la-ahad) → nobody
status: In Progress → Confirmed
tags: removed: upgrade-software-version
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments