dist-upgrade from 12.04 -> 14.04 axes /etc/X11/xorg.conf

Bug #1307546 reported by Mario Limonciello on 2014-04-14
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Mythbuntu
Undecided
Unassigned
ubuntu-drivers-common (Ubuntu)
High
Alberto Milone
Trusty
High
Alberto Milone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]
 * Upon upgrading to Ubuntu 14.04 from an earlier LTS release the user's xorg.conf is renamed. Any custom settings they've made will be removed.

 * Specifically for Mythbuntu 12.04 LTS users with NVIDIA graphics, they have a custom DPI setting that gets removed upon upgrade to 14.04.

 * This has been fixed in utopic by testing if it's the first time that ubuntu-drivers has ran. If so, it sets a first boot flag so that no settings are removed.

[Test Case]

 * This can be reproduced by installing a 12.04 based release, creating an xorg.conf and upgrading to 14.04. If the xorg.conf is renamed then the bug is hit.

 * This can also be reproduced directly on 14.04 by removing /var/lib/ubuntu-drivers-common/last_gfx_boot, creating an xorg.conf and rebooting. This would simulate the same behavior.

[Regression Potential]

 * Part of the intention of ubuntu-drivers-common is to prevent problems on people who have upgraded and now have hybrid graphics supported cards. This won't make their situation any worse than previously it would have been before ubuntu-driver-common existed.

 * Any functional users in the field should still remain functional. This only affects the first boot scenario.

Mario Limonciello (superm1) wrote :
Changed in mythbuntu:
status: New → Confirmed
Brian Murray (brian-murray) wrote :

I'm not certain the release upgrader made this change. xorg_fix_proprietary.py does look at xorg.conf but it doesn't back it up and it doesn't look like it ran during your upgrade.

2014-04-14 08:45:36,097 DEBUG Running PostInstallScript: './xorg_fix_proprietary.py'
2014-04-14 08:45:36,134 ERROR got error from PostInstallScript ./xorg_fix_proprietary.py (Failed to execute child process "./xorg_fix_proprietary.py" (No such file or directory))

Mario Limonciello (superm1) wrote :

Hmm, both myself and rhpot1991 were affected by this on two separate boxes after upgrade process. Wonder if it's some postinst that's doing it then.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
rhpot1991 (rhpot1991) wrote :

I upgraded two boxes from 12.04 to 13.04. On both boxes xorg.conf was renamed. This caused a DPI issue on one box, and removed several vdpau fixes on both boxes.

rhpot1991 (rhpot1991) wrote :

Correction 14.04 not 13.04, sorry.

Mario Limonciello (superm1) wrote :

I think it's likely the nvidia prime postrm script that did it.

snippet:

case "$1" in
    purge|remove|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
        # Remove the xorg.conf
        if [ -f $xorg_conf ]; then
            mv $xorg_conf $xorg_conf.$now
        fi

Mario Limonciello (superm1) wrote :

Actually - nvidia-prime seems less likely now that I read gpu-manager code. It's a "new" tool for upgrades, and consequently would run it's enable_nvidia routine the first boot.

It checks how many cards are in the system, and if it only finds 1, removes the old xorg.conf without making a new one.

    /* See if enabling the driver failed */
    if (status) {
        /* If xorg.conf exists, make sure it contains
         * the right BusId and NO NOUVEAU or FGLRX. If it doesn't, create a
         * xorg.conf from scratch */
        if (!check_vendor_bus_id_xorg_conf(devices, cards_n,
                                           vendor_id, "nvidia")) {
            fprintf(log_handle, "Check failed\n");

            /* Remove xorg.conf */
            remove_xorg_conf();

            /* Only useful if more than one card is available */
            if (cards_n > 1) {
                /* Write xorg.conf */
                write_to_xorg_conf(devices, cards_n, vendor_id);
            }
        }
        else {
            fprintf(log_handle, "No need to modify xorg.conf. Path: %s\n", xorg_conf_file);
        }
    }

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-drivers-common (Ubuntu):
status: New → Confirmed
affects: nvidia-prime (Ubuntu) → ubuntu-drivers-common (Ubuntu)
summary: - DPI really messed up after upgrade
+ dist-upgrade from 12.04 -> 14.04 axes /etc/X11/xorg.conf
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Invalid
rhpot1991 (rhpot1991) wrote :

Attaching gpu-manager log that shows xorg.conf being removed.

Changed in ubuntu-drivers-common (Ubuntu):
status: New → Confirmed
milestone: none → ubuntu-14.04.1
Mario Limonciello (superm1) wrote :

I've come up with a patch for this and submitted a pull request.

https://github.com/tseliot/ubuntu-drivers-common/pull/8

Changed in ubuntu-drivers-common (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
tags: added: patch
Changed in ubuntu-drivers-common (Ubuntu):
status: Confirmed → Triaged
Changed in ubuntu-drivers-common (Ubuntu):
status: Triaged → In Progress
Changed in ubuntu-drivers-common (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Changed in ubuntu-release-upgrader (Ubuntu Trusty):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.2.92.2

---------------
ubuntu-drivers-common (1:0.2.92.2) utopic; urgency=medium

  * gpu-manager.c:
    - Revert switch to the intel driver from modesetting until
      some issues are fixed.
 -- Alberto Milone <email address hidden> Mon, 28 Apr 2014 18:37:02 +0200

Changed in ubuntu-drivers-common (Ubuntu):
status: In Progress → Fix Released
Michael Lueck (mlueck) wrote :

Based on #13, should I attempt another LTS upgrade to 14.04 with a system having Nvidia graphics to see if the xorg.conf no longer gets deleted? Just let me know, I have additional systems ready to test with and would be happy to validate the fix.

Mario Limonciello (superm1) wrote :

Unfortunately that only means it was fixed in 14.10. It still needs to be SRU'ed into 14.04.

description: updated

Hello Mario, or anyone else affected,

Accepted ubuntu-drivers-common into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.2.91.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-drivers-common (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Michael Lueck (mlueck) wrote :

Based on #16, I submit the same question as I asked in #14... "Ready for me to test another 12.04 --> 14.04 LTS upgrade at this point?" Please confirm and I will kick one off.

Since it says "Please test proposed package" in #16, is there any special steps I need to perform when doing the LTS upgrade to insure I actually test the proposed package?

Before you reboot after doing the dist upgrade you should fetch that
package specifically from the proposed repository and install it. It will
run the first time you reboot after the upgrade.
On May 26, 2014 8:25 PM, "Michael Lueck" <email address hidden> wrote:

> Based on #16, I submit the same question as I asked in #14... "Ready for
> me to test another 12.04 --> 14.04 LTS upgrade at this point?" Please
> confirm and I will kick one off.
>
> Since it says "Please test proposed package" in #16, is there any
> special steps I need to perform when doing the LTS upgrade to insure I
> actually test the proposed package?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1307546
>
> Title:
> dist-upgrade from 12.04 -> 14.04 axes /etc/X11/xorg.conf
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mythbuntu/+bug/1307546/+subscriptions
>

Michael Lueck (mlueck) wrote :

I apologize, I find I have drained my supply of test systems with custom xorg.conf files. The rest of them are simple machines directly attached to their display, thus get by just fine without any xorg.conf file at all. The more complex configurations are at my desk where I make use of a KVM switch, thus require xorg.conf files as the system can not directly communicate with my display - the KVM switch blocks direct access.

Someone else will need to test this.

Mario Limonciello (superm1) wrote :

Michael,

You can make an xorg.conf that doesn't functionally change anything for example: http://askubuntu.com/questions/217758/how-to-make-an-xorg-conf-file

After you make the xorg.conf and put it in place, reboot to make sure the system still boots with it.

If it does, do the dist-upgrade, install the proposed package and then reboot.

If the xorg.conf remains in place then this bug is fixed. If it gets renamed, then you have hit the bug again.

Thomas Mashos (tgm4883) wrote :

I've verified that this is fixed on an upgrade from Mythbuntu 12.04.4 to Mythbuntu 14.04. I tested this inside an Virtualbox VM, by creating a default xorg.conf file. The xorg.conf file remains in it's location (/etc/X11/xorg.conf) and is untouched after the upgrade.

Attached is the xorg.conf file I used in my testing

tags: added: verification-done
removed: verification-needed
Thomas Mashos (tgm4883) wrote :

I set the tag back to verification-needed after consulting the wiki, it appears the SRU team is supposed to handle that. My testing was still successful.

tags: added: verification-needed
removed: verification-done
Michael Lueck (mlueck) wrote :

I confirmed the proposed update in #16 on an Xubuntu i386 12.04 to 14.04 LTS upgrade just now. Works flawlessly. Thank you so much! :-)

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.2.91.5

---------------
ubuntu-drivers-common (1:0.2.91.5) trusty-proposed; urgency=medium

  * During first boot, don't remove existing xorg.conf. (LP: #1307546)
 -- Mario Limonciello <email address hidden> Fri, 18 Apr 2014 11:35:27 -0500

Changed in ubuntu-drivers-common (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-drivers-common has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Thomas Mashos (tgm4883) on 2015-01-12
tags: added: downstream
To post a comment you must log in.