Precise to Trusty - all of main - fails: Broken transition from libwayland0 to libwayland-client0

Bug #1304365 reported by Jean-Baptiste Lallement
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Invalid
High
Unassigned
Trusty
Invalid
High
Unassigned
wayland (Ubuntu)
Fix Released
High
Unassigned
Trusty
Fix Released
High
Unassigned

Bug Description

Precise to Trusty amd64 + all of main fails with:

2014-04-08 11:54:33,251 DEBUG blacklist expr 'gnome-session$' matches 'gnome-session'
2014-04-08 11:54:33,251 DEBUG The package 'gnome-session' is marked for removal but it's in the removal blacklist
2014-04-08 11:54:33,274 ERROR Dist-upgrade failed: 'The package 'gnome-session' is marked for removal but it is in the removal blacklist.'

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

From apt.log

Investigating (0) libcanberra-gtk3-0 [ amd64 ] < 0.28-3ubuntu3 -> 0.30-0ubuntu3 > ( libs )
Broken libcanberra-gtk3-0:amd64 Depends on libgtk-3-0 [ amd64 ] < 3.4.2-0ubuntu0.7 -> 3.10.8-0ubuntu1 > ( libs ) (>= 3.0.0)
  Considering libgtk-3-0:amd64 806 as a solution to libcanberra-gtk3-0:amd64 76
  Removing libcanberra-gtk3-0:amd64 rather than change libgtk-3-0:amd64
[...]
Investigating (0) unity-settings-daemon [ amd64 ] < none -> 14.04.0+14.04.20140407-0ubuntu1 > ( gnome )
Broken unity-settings-daemon:amd64 Depends on libcanberra-gtk3-0 [ amd64 ] < 0.28-3ubuntu3 -> 0.30-0ubuntu3 > ( libs ) (>= 0.25)
  Considering libcanberra-gtk3-0:amd64 76 as a solution to unity-settings-daemon:amd64 14
  Holding Back unity-settings-daemon:amd64 rather than change libcanberra-gtk3-0:amd64
[...]
Investigating (0) gnome-settings-daemon [ amd64 ] < 3.4.2-0ubuntu0.6.5 -> 3.8.6.1-0ubuntu10 > ( gnome )
Broken gnome-settings-daemon:amd64 Depends on libcanberra-gtk3-0 [ amd64 ] < 0.28-3ubuntu3 -> 0.30-0ubuntu3 > ( libs ) (>= 0.25)
  Considering libcanberra-gtk3-0:amd64 76 as a solution to gnome-settings-daemon:amd64 13
[...]
Investigating (0) gnome-session [ amd64 ] < 3.2.1-0ubuntu8 -> 3.9.90-0ubuntu12 > ( gnome )
Broken gnome-session:amd64 Depends on gnome-settings-daemon [ amd64 ] < 3.4.2-0ubuntu0.6.5 -> 3.8.6.1-0ubuntu10 > ( gnome ) (>= 3.0)
  Considering gnome-settings-daemon:amd64 13 as a solution to gnome-session:amd64 5
  Removing gnome-session:amd64 rather than change gnome-settings-daemon:amd64

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

and in another part of the log:

Investigating (1) libegl1-mesa [ amd64 ] < 8.0.4-0ubuntu0.7 -> 10.1.0-4ubuntu1 > ( libs )
Broken libegl1-mesa:amd64 Depends on libwayland0 [ amd64 ] < 0.85.0-1ubuntu2 > ( libs )
  Considering libwayland0:amd64 2 as a solution to libegl1-mesa:amd64 60
  Added libwayland0:amd64 to the remove list
  Fixing libegl1-mesa:amd64 via keep of libwayland0:amd64
 Try to Re-Instate (1) libgbm1:amd64
 Try to Re-Instate (1) libwayland-dev:amd64
[...]
Broken libwayland-client0:amd64 Conflicts on libwayland0 [ amd64 ] < 0.85.0-1ubuntu2 > ( libs ) (< 1.1.0-1)
  Considering libwayland0:amd64 52 as a solution to libwayland-client0:amd64 8
  Holding Back libwayland-client0:amd64 rather than change libwayland0:amd64

summary: - Precise to Trusty - all of main - fails: The package 'gnome-session' is
- marked for removal but it's in the removal blacklist
+ Precise to Trusty - all of main - fails: Broken transition from
+ libwayland0 to libwayland-client0
Changed in wayland (Ubuntu):
importance: Undecided → High
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

removing libwayland-dev makes the upgrader proceed further in the calculation.

Revision history for this message
Michael Vogt (mvo) wrote :

The wayland0 packages that has no newer version but some conflicts on the old version confuses libapt when it tries to resolve the dependencies. A simple dummay package for the transition does the trick - the transitional package gets removed during the upgrade as well and it can get removed immediately after trusty is released.

Changed in wayland (Ubuntu):
status: New → In Progress
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → In Progress
Changed in wayland (Ubuntu Trusty):
milestone: none → ubuntu-14.04
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wayland - 1.4.0-1ubuntu1

---------------
wayland (1.4.0-1ubuntu1) trusty; urgency=low

  * debian/control:
    - provide a transitional libwayland0 package to help apt calculate the
      upgrade (LP: #1304365)
 -- Michael Vogt <email address hidden> Tue, 08 Apr 2014 17:14:12 +0200

Changed in wayland (Ubuntu Trusty):
status: In Progress → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote :

Given that this was fixed in wayland, I believe the u-r-u task is Invalid.

Changed in ubuntu-release-upgrader (Ubuntu Trusty):
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers