do-release-upgrade crashed with SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)

Bug #1292996 reported by jarault on 2014-03-15
198
This bug affects 37 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Medium
Unassigned

Bug Description

i don't know more about it

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: ubuntu-release-upgrader-core 1:0.216.1
ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
Uname: Linux 3.13.0-17-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CrashDB: ubuntu
Date: Fri Mar 14 08:03:26 2014
DuplicateSignature: SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
ExecutablePath: /usr/bin/do-release-upgrade
InstallationDate: Installed on 2014-01-01 (73 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 "Trusty Tahr" - Alpha amd64 (20131219)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/lib/ubuntu-release-upgrader/do-partial-upgrade --frontend=DistUpgradeViewGtk3
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_FR.UTF-8
 PATH=(custom, no user)
PythonArgs: ['/usr/bin/do-release-upgrade', '--frontend=DistUpgradeViewGtk3']
SourcePackage: ubuntu-release-upgrader
Title: do-release-upgrade crashed with SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
Traceback: SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

jarault (jarault-gmail) wrote :
tags: removed: need-duplicate-check
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Medium
Brian Murray (brian-murray) wrote :

It looks like a package became corrupt on disk:

Preparing to replace libxine1-misc-plugins 1.1.21-2 (using .../libxine1-misc-plugins_1.1.21-2ubuntu1_amd64.deb) ...
Unpacking replacement libxine1-misc-plugins ...
dpkg-deb (subprocess): cannot copy archive member from '/var/cache/apt/archives/libxine1-misc-plugins_1.1.21-2ubuntu1_amd64.deb' to decompressor pipe: failed to read (Input/output error)
dpkg-deb (subprocess): decompressing archive member: internal bzip2 read error: 'UNEXPECTED_EOF'
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing /var/cache/apt/archives/libxine1-misc-plugins_1.1.21-2ubuntu1_amd64.deb (--unpack):
 subprocess dpkg-deb --fsys-tarfile returned error exit status 2

information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
John (yugonibblit) on 2014-03-24
Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → John (yugonibblit)
Changed in ubuntu-release-upgrader (Ubuntu):
assignee: John (yugonibblit) → nobody
tags: added: utopic
tags: added: vivid
tags: added: xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers