do-partial-upgrade assert failure: python3: ../../src/xcb_io.c:274: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.

Bug #1292213 reported by Stephen on 2014-03-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Medium
Shafi Ur Rehman

Bug Description

Doing a partial upgrade

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: ubuntu-release-upgrader-core 1:0.216.1
ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
Uname: Linux 3.13.0-17-generic i686
ApportVersion: 2.13.3-0ubuntu1
Architecture: i386
AssertionMessage: python3: ../../src/xcb_io.c:274: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
CrashDB: ubuntu
Date: Thu Mar 13 16:43:15 2014
ExecutablePath: /usr/lib/ubuntu-release-upgrader/do-partial-upgrade
InstallationDate: Installed on 2014-02-14 (27 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140201)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/lib/ubuntu-release-upgrader/do-partial-upgrade --frontend=DistUpgradeViewGtk3
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_CA.UTF-8
 LANGUAGE=en_CA:en
 TERM=xterm
 PATH=(custom, no user)
Signal: 6
SourcePackage: ubuntu-release-upgrader
StacktraceTop:
 __assert_fail_base (fmt=0xb7697ff4 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0xb6284a68 "!xcb_xlib_threads_sequence_lost", file=file@entry=0xb62848db "../../src/xcb_io.c", line=line@entry=274, function=function@entry=0xb6284cf2 "poll_for_event") at assert.c:92
 __GI___assert_fail (assertion=0xb6284a68 "!xcb_xlib_threads_sequence_lost", file=0xb62848db "../../src/xcb_io.c", line=274, function=0xb6284cf2 "poll_for_event") at assert.c:101
 ?? () from /usr/lib/i386-linux-gnu/libX11.so.6
 ?? () from /usr/lib/i386-linux-gnu/libX11.so.6
 _XEventsQueued () from /usr/lib/i386-linux-gnu/libX11.so.6
Title: do-partial-upgrade assert failure: python3: ../../src/xcb_io.c:274: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Stephen (moondoggy2) wrote :

StacktraceTop:
 __assert_fail_base (fmt=0xb7697ff4 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0xb6284a68 "!xcb_xlib_threads_sequence_lost", file=file@entry=0xb62848db "../../src/xcb_io.c", line=line@entry=274, function=function@entry=0xb6284cf2 <__PRETTY_FUNCTION__.14003> "poll_for_event") at assert.c:92
 __GI___assert_fail (assertion=assertion@entry=0xb6284a68 "!xcb_xlib_threads_sequence_lost", file=file@entry=0xb62848db "../../src/xcb_io.c", line=line@entry=274, function=function@entry=0xb6284cf2 <__PRETTY_FUNCTION__.14003> "poll_for_event") at assert.c:101
 poll_for_event (dpy=dpy@entry=0x941a388) at ../../src/xcb_io.c:271
 poll_for_response (dpy=dpy@entry=0x941a388) at ../../src/xcb_io.c:289
 _XEventsQueued (dpy=dpy@entry=0x941a388, mode=mode@entry=2) at ../../src/xcb_io.c:363

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Thanks for taking the time to report this bug and helping to make Ubuntu better. We appreciate the difficulties you are facing, but this appears to be a "regular" (non-security) bug. I have unmarked it as a security issue since this bug does not show evidence of allowing attackers to cross privilege boundaries nor directly cause loss of data/privacy. Please feel free to report any other bugs you may find.

information type: Private Security → Public
Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Shafi Ur Rehman (shafi-khattak66)
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers