do-release-upgrade crashed with SIGSEGV in debVersioningSystem::CheckDep()

Bug #1292187 reported by Jackson Doak on 2014-03-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Medium
Unassigned

Bug Description

This appeared while apt-get update was running. The update completed anyway

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: ubuntu-release-upgrader-core 1:0.216
ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
Uname: Linux 3.13.0-17-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CrashDB: ubuntu
Date: Fri Mar 14 06:24:08 2014
ExecutablePath: /usr/bin/do-release-upgrade
InstallationDate: Installed on 2013-12-17 (85 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131217)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/lib/ubuntu-release-upgrader/check-new-release -q
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SegvAnalysis:
 Segfault happened at: 0x7fdb05ada7d2 <_ZN19debVersioningSystem8CheckDepEPKciS1_+34>: cmpb $0x0,(%rsi)
 PC (0x7fdb05ada7d2) ok
 source "$0x0" ok
 destination "(%rsi)" (0x7fdbffffffff) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: ubuntu-release-upgrader
StacktraceTop:
 debVersioningSystem::CheckDep(char const*, int, char const*) () from /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12
 pkgDepCache::CheckDep(pkgCache::DepIterator, int, pkgCache::PkgIterator&) () from /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12
 pkgDepCache::DependencyState(pkgCache::DepIterator&) () from /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12
 pkgDepCache::Update(OpProgress*) () from /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12
 pkgDepCache::Init(OpProgress*) () from /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12
Title: do-release-upgrade crashed with SIGSEGV in debVersioningSystem::CheckDep()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Jackson Doak (noskcaj) wrote :

StacktraceTop:
 debVersioningSystem::CheckDep (this=0x7fff82ceee50, PkgVer=0x7fdbffffffff <Address 0x7fdbffffffff out of bounds>, Op=2, DepVer=0x7fdb02a9f4f9 <Address 0x7fdb02a9f4f9 out of bounds>) at deb/debversion.cc:216
 pkgDepCache::CheckDep (this=this@entry=0x1e2a640, Dep=..., Type=Type@entry=0, Res=...) at depcache.cc:362
 CheckDep (Type=0, Dep=..., this=0x1e2a640) at ../build/include/apt-pkg/depcache.h:321
 pkgDepCache::DependencyState (this=this@entry=0x1e2a640, D=...) at depcache.cc:607
 pkgDepCache::Update (this=this@entry=0x1e2a640, Prog=Prog@entry=0x7fff82ceefe0) at depcache.cc:680

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers