Lack of "extras" repo causes Saucy -> Trusty upgrade to fail

Bug #1261588 reported by Erick Brunzell on 2013-12-17
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned

Bug Description

I'm testing for the Ubuntu GNOME Trusty Alpha 1 candidate and I ran "update-manager -d -c" in an existing Saucy i386. The upgrade aborted due to the lack of a Trusty "extras" repo. I'll attach a screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubuntu-release-upgrader-core 1:0.205.2
ProcVersionSignature: Ubuntu 3.11.0-14.21-generic 3.11.7
Uname: Linux 3.11.0-14-generic i686
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: i386
CrashDB: ubuntu
Date: Mon Dec 16 18:11:10 2013
InstallationDate: Installed on 2013-12-14 (2 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Release i386 (20131015)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: Upgraded to saucy on 2013-12-17 (0 days ago)
VarLogDistupgradeAptlog:
 Log time: 2013-12-16 18:01:37.466613
 Log time: 2013-12-16 18:01:52.915393
 Log time: 2013-12-16 18:07:07.871636
VarLogDistupgradeTermlog:

Erick Brunzell (lbsolost) wrote :
Erick Brunzell (lbsolost) wrote :

Here's the promised screenshot.

Erick Brunzell (lbsolost) wrote :

This also has a lesser effect on fresh installs ;^)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1261588

tags: added: iso-testing
amjjawad  (amjjawad) wrote :

This happened with me when I was trying to force upgrade Xubuntu 13.10 to Trusty few days ago and I think this will affect all the other flavours as well.

Thanks for reporting, Erick Brunzell (lbsolost) :)

amjjawad  (amjjawad) wrote :

I am sorry, I forgot to mention that my test was on Real Hardware - http://phillw.net/hardware/BnA9pw11 - it was NOT on a Virtual Machine :)

Thank you!

Erick Brunzell (lbsolost) wrote :

Based on results after the 17th this may now be fixed but I'll follow up later.

amjjawad  (amjjawad) wrote :

I confirm this has been fixed.

Just forced upgrade Xubuntu 13.10 to Xubuntu Trusty and everything is super fine now :)

Thank you!

Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers