Release upgrade aborts if obexd-server is installed

Bug #1241487 reported by Jens Herrmann on 2013-10-18
8
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Medium
Unassigned

Bug Description

The upgrade to 13.10 fails with the following message:

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug using the command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: ubuntu-release-upgrader-core 1:0.192.13
ProcVersionSignature: Ubuntu 3.8.0-31.46-generic 3.8.13.8
Uname: Linux 3.8.0-31-generic x86_64
ApportVersion: 2.9.2-0ubuntu8.3
Architecture: amd64
CrashDB: ubuntu
Date: Fri Oct 18 12:24:44 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-08-13 (430 days ago)
InstallationMedia: Xubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to raring on 2013-10-18 (0 days ago)
VarLogDistupgradeTermlog:

Jens Herrmann (bugs-u) wrote :
Brian Murray (brian-murray) wrote :

From VarLogDistUpgradeAptlog.txt we end up in a loop of this:

Investigating (1) libgdm [ amd64 ] < none -> 3.8.4-0ubuntu2 > ( universe/libs )
Broken libgdm:amd64 Breaks on gdm [ amd64 ] < 3.6.1-0ubuntu4 -> 3.8.4-0ubuntu2 > ( universe/gnome ) (< 3.8.3-3~)
  Considering gdm:amd64 0 as a solution to libgdm:amd64 1
  Upgrading gdm:amd64 due to Breaks field in libgdm:amd64
Investigating (1) gdm [ amd64 ] < 3.6.1-0ubuntu4 -> 3.8.4-0ubuntu2 > ( universe/gnome )
Broken gdm:amd64 Depends on gnome-shell [ amd64 ] < none -> 3.8.4-0ubuntu5 > ( universe/gnome )
  Considering gnome-shell:amd64 0 as a solution to gdm:amd64 0
  Holding Back gdm:amd64 rather than change gnome-shell:amd64

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

The issue here is that the obexd-server package is installed which conflicts with obex-data-server which is recommended by gnome-bluetooth.

Steve Langasek (vorlon) wrote :

Jens, we are working on identifying a correct fix for this issue. In the meantime, you can work around the problem by uninstalling the obexd-server package from your system before upgrading.

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Steve Langasek (vorlon) wrote :

Note that gnome-bluetooth depends on obex-data-server rather than recommending it. apt should do a better job here of removing obexd-server since it's only a recommends, the only possible upgrade solution is to install obex-data-server and remove obexd-server. We just need to help apt be more clever about it.

summary: - Release upgrade aborts with error message
+ Release upgrade aborts if obexd-server is installed
Jesusfreak (launchpad-bikelab) wrote :

Thanks Steve, uninstalling the obexd-server package solved it for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers