do-release-upgrade incorrectly reports no upgrade available

Bug #1221691 reported by rew on 2013-09-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Medium
Unassigned

Bug Description

I just created a "chroot" oneiric. I then ran do-release-upgrade to go to precise. Next I changed "Prompt=ltr" back to "Prompt=normal" (in update-manager/release-upgrades).

Then when I ran do-release-upgrade again, to try to upgrade to quantal I got "no upgrade available", while we're up to rascal already.

It turns out that my resolv.conf had become invalid during the upgrade to precise. That's not the problem. The problem is that do-release-upgrade apparently encounters an error (host cannot be resolved), and instead of reporting on the error reports a "valid output" for the program.

I recognize that people might be offline and therefore get resolver errors. But the good thing about Linux is that you get error messages that help you solve the problem. So in this case a:

no upgrade available because: can't resolve hostname upgrade.ubuntu.com

- maintains the "business part" that no upgrade is currently possible,
- but in case that is an error that can/needs to be solved, provides a hint as to what is wrong.

This was when upgrading from Precise to Quantal. It's a bug that needs "fixing" in an older release first, because for the current release the message "no release available" is the proper one. (hmmm. well if you just change the error message that should be testable).....

tags: added: precise
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Medium
Tv (tv42) wrote :

This just bit me upgrading 13.10 -> 14.04.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers