do-release-upgrade aborts due to unresolvable "broken" packages

Bug #1101708 reported by Darian Ryder

This bug report was converted into a question: question #224878: do-release-upgrade aborts due to unresolvable "broken" packages.

28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

doing 'do-release-upgrade' results in "An unresolvable problem occurred while calculating the upgrade:
E:Unable to correct problems, you have held broken packages."

root@3xc3l717ud3:/var/log/dist-upgrade# lsb_release -rd
Description: Ubuntu 12.04.1 LTS
Release: 12.04

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: update-manager 1:0.156.14.11
ProcVersionSignature: Ubuntu 3.2.0-36.57-generic 3.2.35
Uname: Linux 3.2.0-36-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
Date: Sat Jan 19 10:40:57 2013
GsettingsChanges:
 com.ubuntu.update-manager first-run false
 com.ubuntu.update-manager launch-time 1350814951
 com.ubuntu.update-manager window-height 500
 com.ubuntu.update-manager window-width 600
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: update-manager
Symptom: ubuntu-release-upgrader-core
UpgradeStatus: Upgraded to precise on 2013-01-19 (0 days ago)

Revision history for this message
Darian Ryder (lifusion) wrote :
Revision history for this message
Darian Ryder (lifusion) wrote :
Revision history for this message
Darian Ryder (lifusion) wrote :
Revision history for this message
Darian Ryder (lifusion) wrote :
Revision history for this message
Darian Ryder (lifusion) wrote :
Revision history for this message
Darian Ryder (lifusion) wrote :
Revision history for this message
Darian Ryder (lifusion) wrote :
Revision history for this message
Darian Ryder (lifusion) wrote :
Revision history for this message
Darian Ryder (lifusion) wrote :
Revision history for this message
Sami Jaktholm (sjakthol) wrote :

You seem to have some unsupported experimental graphic drivers installed from a third party PPA and those packages are breaking your update.

Judging from the information you provided, you've used ppa:oibaf/graphics-drivers in the past. If that's the case, please open terminal and follow these steps to remove those packages from your machine:
1) Install ppa-purge: sudo apt-get install ppa-purge
2) Add graphics-drivers ppa: sudo add-apt-repository ppa:oibaf/graphics-drivers
3) Update package index: sudo apt-get update
4) Purge the PPA: sudo ppa-purge ppa:oibaf/graphics-drivers

Finally restart your computer and see if the upgrade is still failing.

Changed in update-manager (Ubuntu):
status: New → Incomplete
affects: update-manager (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Revision history for this message
Darian Ryder (lifusion) wrote :
Download full text (60.2 KiB)

Thanks Brian,

It did the trick. seems to have also needed, besides the downgrading of the video drivers, to remove most i386 compatibility libraries.

terminal output follows:
darian@3xc3l717ud3:/repos/work/bgu_ws$ sudo ppa-purge ppa:oibaf/graphics-drivers
Updating packages lists
PPA to be removed: oibaf graphics-drivers
comm: file 2 is not in sorted order
Package revert list generated:
 libdrm2/precise libdrm-dev/precise libdrm-intel1/precise
libdrm-nouveau1a/precise libdrm-radeon1/precise libg3dvl-mesa/precise
libgl1-mesa-dev/precise libgl1-mesa-dri/precise
libgl1-mesa-dri-experimental/precise libgl1-mesa-glx/precise
libglapi-mesa/precise libkms1/precise libtxc-dxtn0/precise libvpx1/precise
libxatracker1/precise mesa-common-dev/precise xserver-xorg-video-ati/precise
xserver-xorg-video-intel/precise xserver-xorg-video-nouveau/precise
xserver-xorg-video-radeon/precise

Disabling oibaf PPA from
/etc/apt/sources.list.d/oibaf-graphics-drivers-precise.list
Disabling oibaf PPA from
/etc/apt/sources.list.d.UpgradeFix/oibaf-graphics-drivers-precise.list
Updating packages lists
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Release 'precise' for 'libg3dvl-mesa' was not found
E: Release 'precise' for 'libtxc-dxtn0' was not found
Unable to find an archive "precise" for the package "libg3dvl-mesa"
Unable to find an archive "precise" for the package "libtxc-dxtn0"
Unable to find an archive "precise" for the package "libg3dvl-mesa"
Unable to find an archive "precise" for the package "libtxc-dxtn0"
The following packages will be DOWNGRADED:
  libdrm-dev libdrm-intel1{b} libdrm-nouveau1a{b} libdrm-radeon1{b} libdrm2{b} libgl1-mesa-dev libgl1-mesa-dri{b}
  libgl1-mesa-dri-experimental libgl1-mesa-glx{b} libglapi-mesa{b} libkms1 libvpx1 libxatracker1 mesa-common-dev xserver-xorg-video-ati
  xserver-xorg-video-intel xserver-xorg-video-nouveau xserver-xorg-video-radeon
The following packages will be REMOVED:
  libdrm-nouveau2{u} libtxc-dxtn0{u}
0 packages upgraded, 0 newly installed, 18 downgraded, 2 to remove and 2 not upgraded.
Need to get 5,197 kB of archives. After unpacking 108 MB will be freed.
The following packages have unmet dependencies:
 libdrm-radeon1 : Breaks: libdrm-radeon1:i386 (!= 2.4.32-1ubuntu1) but 2.4.39-0ubuntu0.1 is installed.
 libdrm-radeon1:i386 : Breaks: libdrm-radeon1 (!= 2.4.39-0ubuntu0.1) but 2.4.32-1ubuntu1 is to be installed.
 libgl1-mesa-dri : Breaks: libgl1-mesa-dri:i386 (!= 8.0.2-0ubuntu3) but 8.1~git1206081121.640409~gd~p is installed.
 libgl1-mesa-dri:i386 : Breaks: libgl1-mesa-dri (!= 8.1~git1206081121.640409~gd~p) but 8.0.2-0ubuntu3 is to be installed.
 libgl1-mesa-glx : Breaks: libgl1-mesa-glx:i386 (!= 8.0.2-0ubuntu3) but 8.1~git1206081121.640409~gd~p is installed.
 libgl1-mesa-glx:i386 : Breaks: libgl1-mesa-glx (!= 8.1~git1206081121.640409~gd~p) but 8.0.2-0ubuntu3 is to be installed.
 libglapi-mesa : Breaks: libglapi-mesa:i386 (!= 8.0.2-0ubuntu3) but 8.1~git1206081121.640409~gd~p is installed.
 libglapi-mesa:i386 : Breaks: libglapi-mesa (!= 8.1~git1206081121.640409~gd~p) but 8.0.2-0ubuntu3 is to be installed.
 libg3dvl-mesa : Depends: libdrm-nouveau1a (>= 2....

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions