upgrade issues 12.04=>12.10

Bug #1100189 reported by mashtikar

This bug report was converted into a question: question #224877: upgrade issues 12.04=>12.10.

10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

I would like to upgrade from 12.04 to 12.10 but there seems to be some issue with the upgrade. Upgrade manager stops giving an error of 'broken packages'. But I cant find any broken packages in synaptic.

Please help.

Thanks

Mukul

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: update-manager 1:0.156.14.11
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
Date: Wed Jan 16 09:54:59 2013
GsettingsChanges:
 com.ubuntu.update-manager first-run false
 com.ubuntu.update-manager launch-time 1358326293
 com.ubuntu.update-manager show-details true
 com.ubuntu.update-manager window-height 694
 com.ubuntu.update-manager window-width 600
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: update-manager
Symptom: ubuntu-release-upgrader-core
UpgradeStatus: Upgraded to precise on 2013-01-16 (0 days ago)
VarLogDistupgradeAptclonesystemstate.tar.gz: Error: [Errno 13] Permission denied: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
VarLogDistupgradeTermlog:

Revision history for this message
mashtikar (mashtikar) wrote :
Revision history for this message
Sami Jaktholm (sjakthol) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

According to the information you provided you have packages from x-updates and xorg-edgers PPAs installed in your system. These packages seem to be the cause of your issues. As stated in the X-Updates PPA description, you must purge the PPA's before attempting to upgrade your distribution. So please use ppa-purge to remove both ppa:xorg-edgers/ppa and ppa:ubuntu-x-swat/x-updates and then restart the upgrade process.

Please report back if the problem persists.

Changed in update-manager (Ubuntu):
status: New → Incomplete
Revision history for this message
mashtikar (mashtikar) wrote :
Download full text (14.9 KiB)

Thanks sampo555 for the reply.

I did try the ppa-purge but it does not work. it ends up with a dependency error. I tried resolving the dependency issues but my tinkering seemed to have to influence. I might be missing something small but I cant figure it out. Let me know if there is a way to get around these dependency issues.

Thanks

Cheers,

Mukul

mukul@cypher:~$ sudo ppa-purge ppa:ubuntu-x-swat/x-updates
Updating packages lists
PPA to be removed: ubuntu-x-swat x-updates
Package revert list generated:
 libdrm2/precise libdrm2:i386/precise libdrm-intel1/precise
libdrm-intel1:i386/precise libdrm-nouveau1a/precise
libdrm-nouveau1a:i386/precise libdrm-nouveau2- libdrm-nouveau2:i386-
libdrm-radeon1/precise libdrm-radeon1:i386/precise libgl1-mesa-dri/precise
libgl1-mesa-dri:i386/precise libgl1-mesa-glx/precise
libgl1-mesa-glx:i386/precise libglapi-mesa/precise libglapi-mesa:i386/precise
libllvm3.1/precise libllvm3.1:i386/precise libxatracker1/precise
nvidia-settings/precise xdiagnose/precise xserver-xorg-video-ati/precise
xserver-xorg-video-intel/precise xserver-xorg-video-nouveau/precise
xserver-xorg-video-radeon/precise

Disabling ubuntu-x-swat PPA from
/etc/apt/sources.list.d/ubuntu-x-swat-x-updates-precise.list
Updating packages lists
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '2.4.32-1ubuntu1' (Ubuntu:12.04/precise [amd64]) for 'libdrm2'
Selected version '2.4.32-1ubuntu1' (Ubuntu:12.04/precise [i386]) for 'libdrm2:i386'
Selected version '2.4.32-1ubuntu1' (Ubuntu:12.04/precise [amd64]) for 'libdrm-intel1'
Selected version '2.4.32-1ubuntu1' (Ubuntu:12.04/precise [i386]) for 'libdrm-intel1:i386'
Selected version '2.4.32-1ubuntu1' (Ubuntu:12.04/precise [amd64]) for 'libdrm-nouveau1a'
Selected version '2.4.32-1ubuntu1' (Ubuntu:12.04/precise [i386]) for 'libdrm-nouveau1a:i386'
Selected version '2.4.32-1ubuntu1' (Ubuntu:12.04/precise [amd64]) for 'libdrm-radeon1'
Selected version '2.4.32-1ubuntu1' (Ubuntu:12.04/precise [i386]) for 'libdrm-radeon1:i386'
Selected version '8.0.4-0ubuntu0.2' (Ubuntu:12.04/precise-updates [amd64]) for 'libgl1-mesa-dri'
Selected version '8.0.4-0ubuntu0.2' (Ubuntu:12.04/precise-updates [i386]) for 'libgl1-mesa-dri:i386'
Selected version '8.0.4-0ubuntu0.2' (Ubuntu:12.04/precise-updates [amd64]) for 'libgl1-mesa-glx'
Selected version '8.0.4-0ubuntu0.2' (Ubuntu:12.04/precise-updates [i386]) for 'libgl1-mesa-glx:i386'
Selected version '8.0.4-0ubuntu0.2' (Ubuntu:12.04/precise-updates [i386]) for 'libglapi-mesa:i386' because of 'libgl1-mesa-glx:i386'
Selected version '8.0.4-0ubuntu0.2' (Ubuntu:12.04/precise-updates [amd64]) for 'libglapi-mesa'
Selected version '8.0.4-0ubuntu0.2' (Ubuntu:12.04/precise-updates [i386]) for 'libglapi-mesa:i386'
Selected version '3.1-2ubuntu1~12.04' (Ubuntu:12.04/precise-updates [amd64]) for 'libllvm3.1'
Selected version '3.1-2ubuntu1~12.04' (Ubuntu:12.04/precise-updates [i386]) for 'libllvm3.1:i386'
Selected version '8.0.4-0ubuntu0.2' (Ubuntu:12.04/precise-updates [amd64]) for 'libxatracker1'
Selected version '295.33-0ubuntu1' (Ubuntu:12.04/precise [amd64]) for 'nvidia-settings'
Selected version '2.5.2ubuntu0.1' ...

Revision history for this message
Sami Jaktholm (sjakthol) wrote :

It seems that the two PPAs are kind of breaking on each other. You could try installing xorg-video-abi-11 package and see if it fixes the issues with PPA-purge.

Other than that, there's not much I can do to help you.

affects: update-manager (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions