Can't use c-n-r-gtk to initiate Quantal -> Raring update

Bug #1094777 reported by Gabor Kelemen
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Fix Released
High
Michael Terry
Quantal
Fix Released
Undecided
Unassigned

Bug Description

[Impact]
After Ubuntu 13.04 is released, users on 12.10 will occasionally be prompted by update-notifier about the new release. If they click on the "Upgrade Now" button in the dialog that appears, nothing will happen.

They can still upgrade via update-manager, but still. That's a pile of fail on something users will expect to work.

This is a regression from 12.04.

[Test Case]
0) Be on Ubuntu 12.10
1) Run /usr/lib/ubuntu-release-upgrader/check-new-release-gtk -d
2) Click the "Upgrade Now" button

Notice how nothing happens.

[Regression Potential]
Very low, since it doesn't work at all now. The changes are small and isolated to this one binary.

[Original Report]
I have submitted an apport report for this already, but I think it is better to submit it manually too.
I have tried to run
/usr/lib/ubuntu-release-upgrader/check-new-release-gtk -d
just to see what happens next. It has found the Raring release, I have pushed the "Yes, Upgrade Now!" button, and got this:

$ /usr/lib/ubuntu-release-upgrader/check-new-release-gtk -d
Traceback (most recent call last):
  File "/usr/lib/ubuntu-release-upgrader/check-new-release-gtk", line 132, in on_button_upgrade_now_clicked
    _("Downloading the release upgrade tool"))
  File "/usr/lib/python3/dist-packages/DistUpgrade/GtkProgress.py", line 35, in __init__
    self.widgets = SimpleGtkbuilderApp(uifile, "ubuntu-release-upgrader")
  File "/usr/lib/python3/dist-packages/DistUpgrade/SimpleGtk3builderApp.py", line 32, in __init__
    self.builder.add_from_file(path)
  File "/usr/lib/python3/dist-packages/gi/types.py", line 47, in function
    return info.invoke(*args, **kwargs)
gi._glib.GError: Nem sikerült megnyitni a(z) „/usr/share/ubuntu-release-upgradergtkbuilder/AcquireProgress.ui” fájlt: Nincs ilyen fájl vagy könyvtár

(gi._glib.GError: Can't open the ...ui file: No such file or directory)

That would be easy to fix, I tried to do the following to DistUpgrade/GtkProgress.py :
- uifile = datadir + "gtkbuilder/AcquireProgress.ui"
+ uifile = datadir + "/gtkbuilder/AcquireProgress.ui"

But now a brand new crash happens, and I'm stuck:

$ /usr/lib/ubuntu-release-upgrader/check-new-release-gtk -d
Traceback (most recent call last):
  File "/usr/lib/ubuntu-release-upgrader/check-new-release-gtk", line 132, in on_button_upgrade_now_clicked
    _("Downloading the release upgrade tool"))
  File "/usr/lib/python3/dist-packages/DistUpgrade/GtkProgress.py", line 48, in __init__
    self.window_fetch.set_transient_for(parent)
  File "/usr/lib/python3/dist-packages/gi/types.py", line 47, in function
    return info.invoke(*args, **kwargs)
TypeError: argument parent: Expected Gtk.Window, but got __main__.CheckNewReleaseGtk

Related branches

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
status: New → Triaged
tags: added: quantal
summary: - Can't use c-n-r-gtk to initate Quantal -> Raring update
+ Can't use c-n-r-gtk to initiate Quantal -> Raring update
Revision history for this message
Brian Murray (brian-murray) wrote :

This is possibly a duplicate of bug 1097907 which is being worked on.

Revision history for this message
Michael Terry (mterry) wrote :

Brian, you are right, but they are actually two separate user experiences, after all. Bug 1097907 is about the upgrade path using update-manager. This bug is not hit in that code path.

Rather, this bug is hit from update-notifier running a check. (or manually of course) I'll take this bug.

Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Michael Terry (mterry)
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:0.192.5

---------------
ubuntu-release-upgrader (1:0.192.5) raring; urgency=low

  * Fix a couple path joins and bugs that prevented check-new-release-gtk
    from working. (LP: #1094777)
 -- Michael Terry <email address hidden> Tue, 22 Jan 2013 09:46:57 -0500

Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Gabor, or anyone else affected,

Accepted ubuntu-release-upgrader into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:0.190.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-release-upgrader (Ubuntu Quantal):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Brian Murray (brian-murray) wrote :

The bug still occurs and uifile did not change in either GtkProgress.py or DistUpgradeFetcher.py with ubuntu-release-upgrader version 1:0.190.6.

tags: added: verification-failed
removed: verification-needed
Revision history for this message
Brian Murray (brian-murray) wrote :

Well, I'm not so sure now as inspecting the package from the archive and in Launchpad it certainly should contain the fix. I'm still trying to sort this out.

Revision history for this message
Brian Murray (brian-murray) wrote :

I tried this on a second virtual machine with ubuntu-release-upgrader version 1:0.190.6 from quantal-proposed and was able to start the upgrade to raring. I believe the first system was misconfigured as the changes definitely exist in the packages available on the archive.

tags: added: verification-done
removed: verification-failed
Revision history for this message
Chris Halse Rogers (raof) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:0.190.6

---------------
ubuntu-release-upgrader (1:0.190.6) quantal-proposed; urgency=low

  * Fix a couple path joins and bugs that prevented check-new-release-gtk
    from working. (LP: #1094777)
 -- Michael Terry <email address hidden> Tue, 22 Jan 2013 10:21:27 -0500

Changed in ubuntu-release-upgrader (Ubuntu Quantal):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote :

This is still occurring regularly for users of Ubuntu 12.10 who likely do not have the -updates pocket enabled, we can still see a large number of incidents of this at errors.ubuntu.com.

https://errors.ubuntu.com/bucket/?id=/usr/lib/ubuntu-release-upgrader/check-new-release-gtk:gi._glib.GError:on_button_upgrade_now_clicked:__init__:__init__:function

Looking at the bucket page we can see large numbers of users experiencing this with version 1:0.190.1 of ubuntu-release-upgrader-core.

Revision history for this message
Michael Terry (mterry) wrote :

Is upgrading without being up-to-date a supported upgrade path?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers