emacsen failed to install on upgrade to Kubuntu 12.10

Bug #1074688 reported by Ryan Lynch
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Invalid
Undecided
Unassigned
xemacs21 (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Upgrading from Kubuntu 12.04 to 12.10. During upgrade emacsen returned exit status 1.

Tags: precise
Revision history for this message
Ryan Lynch (ryan-s-lynch) wrote :

Error message after trying to run dpkg --configure -a:

sudo dpkg --configure -a
Setting up emacsen-common (2.0.3) ...
Install emacsen-common for xemacs21
emacsen-common: Handling install of emacsen flavor xemacs21
/usr/lib/emacsen-common/packages/install/emacsen-common: 29: /usr/lib/emacsen-common/packages/install/emacsen-common: xemacs21: not found
ERROR: install script from emacsen-common package failed
dpkg: error processing emacsen-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of xemacs21-support:
 xemacs21-support depends on emacsen-common; however:
  Package emacsen-common is not configured yet.

dpkg: error processing xemacs21-support (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xemacs21-mule:
 xemacs21-mule depends on xemacs21-support (= 21.4.22-3.2ubuntu2); however:
  Package xemacs21-support is not configured yet.
 xemacs21-mule depends on emacsen-common; however:
  Package emacsen-common is not configured yet.

dpkg: error processing xemacs21-mule (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xemacs21:
 xemacs21 depends on xemacs21-mule (>= 21.4.22-3.2ubuntu2) | xemacs21-mule-canna-wnn (>= 21.4.22-3.2ubuntu2) | xemacs21-nomule (>= 21.4.22-3.2ubuntu2); however:
  Package xemacs21-mule is not configured yet.
  Package xemacs21-mule-canna-wnn is not installed.
  Package xemacs21-nomule is not installed.

dpkg: error processing xemacs21 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xemacs21-bin:
 xemacs21-bin depends on xemacs21-support (= 21.4.22-3.2ubuntu2); however:
  Package xemacs21-support is not configured yet.

dpkg: error processing xemacs21-bin (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 emacsen-common
 xemacs21-support
 xemacs21-mule
 xemacs21
 xemacs21-bin

tags: added: precise
Revision history for this message
Ryan Lynch (ryan-s-lynch) wrote :

This seems to have actually been a problem with xemacs21, which was failing to install for some reason, which prevented emacsen-common from configuring. I was able to fix this by purging xemacs21 and emcasen-common, then reinstalling emacsen-common BEFORE xemacs21. In order:

1) aptitude purge xemacs21
2) aptitude purge emacsen-common
3) aptitude install emacsen-common
4) aptitude install xemacs21

era (era)
affects: emacsen-common (Ubuntu) → xemacs21 (Ubuntu)
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xemacs21 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers