keeps telling me I have broken packages, I did clean, autoclean, autoremove and apt install - f, same result

Bug #1072934 reported by frank mahler
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Invalid
Low
Unassigned

Bug Description

Ubuntu 12.04 upgrading to ubuntu 12.10 (Ubuntu 12.04.1 LTS)

it may be in python 2.7
python2.7:
  Installed: 2.7.3-0ubuntu3.1
  Candidate: 2.7.3-5ubuntu4
  Version table:
     2.7.3-5ubuntu4 0
        500 http://gb.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
 *** 2.7.3-0ubuntu3.1 0
        100 /var/lib/dpkg/status

i recieved the message: ubuntu-bug ubuntu-release-upgrader-core
/usr/lib/python2.7/dist-packages/lazr/restfulclient/__init__.py:19: UserWarning: Module dap was already imported from None, but /usr/lib/python2.7/dist-packages is being added to sys.path
  import pkg_resources
 I expected my upgrade to 12.10 to be flawless as usual
It failed to complete, hardly flawless, FAIL!

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: update-manager 1:0.156.14.11
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
ApportVersion: 2.0.1-0ubuntu14
Architecture: amd64
Date: Tue Oct 30 00:52:59 2012
GsettingsChanges:
 com.ubuntu.update-manager first-run false
 com.ubuntu.update-manager launch-time 1351550815
 com.ubuntu.update-manager window-height 658
 com.ubuntu.update-manager window-width 600
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
PackageArchitecture: all
SourcePackage: update-manager
Symptom: ubuntu-release-upgrader-core
UpgradeStatus: Upgraded to precise on 2012-10-29 (0 days ago)
VarLogDistupgradeAptclonesystemstate.tar.gz: Error: [Errno 13] Permission denied: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
VarLogDistupgradeTermlog:

Revision history for this message
frank mahler (crmhound) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Revision history for this message
Stewart Kluss (stewart-kluss) wrote :

Message 1
Third party sources disabled.
Some third party entries in your sources.list were disabled. You can re-enable them after the upgrade with the 'software-properties' tool or your package manager.

Message 2
Could not calculate the upgrade
An unresolvable problem occurred while calculating the upgrade:
E:Unable to correct problems, you have held broken packages.

 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug using the command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.

I have gone into the Update Manager > Settings > Software Sources > Other software, unchecked everything, and tried again. I get the same messages.

Revision history for this message
David Gardner (bugs-launchpad-net-icmfp) wrote :

I've also had this happen on an Ubuntu 12.04 LTS install with minimal unofficial packages installed (only Dropbox). The python-dap package which contains this is the standard Ubuntu package.

There's a "fix" available in the answer to this stackoverflow question:

 http://stackoverflow.com/questions/13915269/why-do-i-get-userwarning-module-dap-was-already-imported-from-none

..which is to add "dap" as the first line in the /usr/lib/python2.7/dist-packages/dap-2.2.6.7.egg-info/namespace_packages.txt file.

This appears to work, as it doesn't attempt to import the already built-in module "dap". Are there any problems this hack is likely to cause? If this is the correct solution then it would be nice to have in a 12.04 LTS update package if possible.

Revision history for this message
Brian Murray (brian-murray) wrote :

The error in the log files of the original bug reporter actually has to deal with running video drivers from a PPA and being unable to calculate the upgrade.

From main.log we see:

2012-10-30 00:48:07,741 DEBUG examining: 'deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu precise main'
2012-10-30 00:48:07,743 DEBUG entry '# deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu quantal main # disabled on upgrade to quantal' was disabled (unknown mirror)

And from apt.log we have:

Starting 2
Investigating (0) xserver-xorg-video-ati [ amd64 ] < 1:6.99.99+git20120928.e8cb0b72-0ubuntu0sarvatt~precise2 > ( x11 )
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-12 [ amd64 ] < none > ( none )
  Considering xserver-xorg-core:amd64 34 as a solution to xserver-xorg-video-ati:amd64 1
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-12:amd64

affects: update-manager (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Low
tags: added: ppa xorg-edgers-ppa
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers