Dist upgrade from 12.04 LTS to 12.10 fails

Bug #1071724 reported by Thomas M. Galla
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Trying to do a dist upgrade from 12.04 LTS to 12.10 fails with the error "E:Unable to correct problems, you have held broken packages."

Checking for broken packages in 12.04 LTS however shows that there are none.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: update-manager 1:0.156.14.11
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu14
Architecture: i386
Date: Fri Oct 26 12:45:39 2012
GsettingsChanges:
 com.ubuntu.update-manager check-new-release-ignore 'natty'
 com.ubuntu.update-manager first-run false
 com.ubuntu.update-manager launch-time 1351245838
 com.ubuntu.update-manager window-height 518
 com.ubuntu.update-manager window-width 600
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
Symptom: ubuntu-release-upgrader-core
UpgradeStatus: Upgraded to precise on 2012-10-26 (0 days ago)
VarLogDistupgradeAptclonesystemstate.tar.gz: Error: [Errno 13] Permission denied: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'

Revision history for this message
Thomas M. Galla (thomas-galla) wrote :
affects: update-manager (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
Revision history for this message
Brian Murray (brian-murray) wrote :

Broken xserver-xorg-video-all:i386 Depends on xserver-xorg-video-vesa [ i386 ] < 1:2.3.2+git20120912.7aafaf56-0ubuntu0sarvatt~precise > ( x11 )
  Considering xserver-xorg-video-vesa:i386 10005 as a solution to xserver-xorg-video-all:i386 10005
  Considering xserver-xorg-video-vesa:i386 10005 as a solution to xserver-xorg-video-all:i386 10005
Done

The upgrade failure is due to having X packages, not provided by Ubuntu, installed - notice the ubuntu0sarvatt~precise in the xserver-xorg-video-vesa version.

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

Thank you for taking the time to report this bug and trying to help make Ubuntu better. However, it seems that you are not using a software package provided by the official Ubuntu repositories. Because of this the Ubuntu project can not support or fix your particular bug. Please report this bug to the provider of the software package. Thanks!

If you are interested in learning more about software repositories and Ubuntu, check https://help.ubuntu.com/community/Repositories

Changed in ubuntu-release-upgrader (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
Thomas M. Galla (thomas-galla) wrote :

Removing the package xserver-xorg-video-all:i386 Depends on xserver-xorg-video-vesa [ i386 ] < 1:2.3.2+git20120912.7aafaf56-0ubuntu0sarvatt~precise > resolved my problem. - Thanks for the hint and sorry for not figuring that out myself.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers