Can't install 'kubuntu-netbook'

Bug #1070035 reported by Fibonacci on 2012-10-22
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Unassigned

Bug Description

I'm trying to upgrade to Kubuntu 12.10 and I'm getting this error message:

Can't install 'kubuntu-netbook'
It was impossible to install a required package. Please report this as a bug using 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.

Then I'm given the option to either close the window or report the bug. Closing the window results in the following error message:

Could not calculate the upgrade
An unresolvable problem occurred while calculating the upgrade: The package 'kubuntu-desktop' is marked for removal but it is in the removal blacklist. This can be caused by: * Upgrading to a pre-release version of Ubuntu * Running the current pre-release version of Ubuntu * Unofficial software packages not provided by Ubuntu If none of this applies, then please report this bug using the command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.

Running 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal results in the following error:

Package ubuntu-release-upgrader-core does not exist

The upgrade, thus, never goes beyond "Setting new software channels", and I'm stuck on 12.04.

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the log files from '/var/log/dist-upgrade/' to this bug report as separate attachments? Thanks in advance.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
Bart Wise (bart-c-wise+kubuntu) wrote :

I have the same issue. I'll attach my log files.

Bart Wise (bart-c-wise+kubuntu) wrote :
Bart Wise (bart-c-wise+kubuntu) wrote :
Brian Murray (brian-murray) wrote :

From main.log we see:

2012-10-25 04:44:22,615 DEBUG plugins for condition 'PostDistUpgradeCache' are '[]'
2012-10-25 04:44:22,615 DEBUG plugins for condition 'quantalPostDistUpgradeCache' are '[]'
2012-10-25 04:44:22,615 DEBUG plugins for condition 'from_precisePostDistUpgradeCache' are '[]'
2012-10-25 04:44:22,616 DEBUG metapkg 'kubuntu-desktop' installed but marked_delete
2012-10-25 04:44:22,616 DEBUG none of the '['ubuntu-desktop', 'kubuntu-desktop', 'xubuntu-desktop', 'ubuntustudio-desktop', 'ichthux-desktop', 'mythbuntu-desktop', 'ubuntu-netbook', 'kubuntu-netbook', 'lubuntu-desktop']' meta-pkgs installed
2012-10-25 04:44:22,616 DEBUG guessing 'kubuntu-netbook' as missing meta-pkg
2012-10-25 04:44:22,616 ERROR failed to mark 'kubuntu-netbook' for install ("The cache has no package named 'kubuntu-netbook'")
2012-10-25 04:47:00,989 DEBUG blacklist expr 'kubuntu-desktop' matches 'kubuntu-desktop'
2012-10-25 04:47:00,989 DEBUG The package 'kubuntu-desktop' is marked for removal but it's in the removal blacklist
2012-10-25 04:47:05,462 ERROR Dist-upgrade failed: 'The package 'kubuntu-desktop' is marked for removal but it is in the removal blacklist.'

Changed in ubuntu-release-upgrader (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
Michael Vogt (mvo) wrote :

The bug seems to be caused by "universe" not being enabled. The upgrader found kubuntu-netbook-default-settings installed and guessed that the metapackage is kubuntu-netbook but that package is now in universe as is kubuntu-desktop.

It seems like upgrades with kubuntu-desktop will fail in the same way on systems without universe:
kubuntu-netbook | 1.254 | precise | all
kubuntu-netbook | 1.263 | quantal/universe | all

So ideally the release upgrader should either warn or enable universe. In some twisted way its actually correct to fail as the user wants main only and this would bring him to a universe system.

Graeme Nelson (graeme-b) wrote :
Graeme Nelson (graeme-b) wrote :
Graeme Nelson (graeme-b) wrote :

Went to upload term.log, but the file is empty.

sindhu (sindhu-h) on 2013-11-09
Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → Fix Released
Changed in ubuntu-release-upgrader (Ubuntu):
status: Fix Released → Triaged
tags: added: trusty
tags: added: utopic
tags: added: precise quantal
removed: trusty utopic
tags: added: kubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers