[wishlist] Ubuntu could propose to remove old kernels when upgrading

Bug #1070005 reported by YannUbuntu on 2012-10-22
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned

Bug Description

When using Ubuntu a long time (eg Karmic -> Lucid -> Maverick -> Natty -> Oneiric -> Precise -> Quantal..), a system will accumulate several dizains of old kernels.
Each kernel weights >200Mo, so this is not negligible, and may lead to blocked system if root becomes full. (see Bug #610358 )

It would be nice if Ubuntu could propose to remove some of the old kernels when upgrading from one Ubuntu version to another.

Loubrix (david30160) wrote :

I think it would be a good idea to include a feature in update-manager to uninstall old kernel while installing a new one.
for example: I had linux-image-3.2.0-10, and linux-image-3.2.0-11; update-manager install linux-image-3.2.0-12 when updating, and uninstall linux-image-3.2.0-10 at the same time.
by this way, only 2 kernels stay in the system, and the disk space remain stable.

it could be made silently for basic users, but other users could change the behavior in update-manager settings.

it also could be made in the postinstall script of linux-image (and headers) package, but it isn't possible to change settings in that case.

remove kernels only while upgrading to a newer version isn't a good idea; LTS versions can provide 40 or 50 kernels during their life.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

The release upgrade process does remove kernels from the previous release of Ubuntu after the system has been upgraded.

affects: update-manager (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Fix Released
YannUbuntu (yannubuntu) wrote :

thx Brian !

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers