update-manager fatal error while upgrading from precise to quantal due to Ubuntu.mirrors not being available

Bug #1069745 reported by Christian Tellefsen
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Fix Released
High
Brian Murray

Bug Description

Steps to reproduce:
# Add a third-party repository without support for quantal (e.g. a PPA)
# Start update-manager
# Click upgrade button
# Wait
# Observe a fatal error dialogue, and a the following fatal error:

<pre>
Traceback (most recent call last):

  File "/tmp/update-manager-Vwi3Ev/quantal", line 10, in <module>
    sys.exit(main())

  File "/tmp/update-manager-Vwi3Ev/DistUpgrade/DistUpgradeMain.py", line 240, in main
    if app.run():

  File "/tmp/update-manager-Vwi3Ev/DistUpgrade/DistUpgradeController.py", line 1764, in run
    return self.fullUpgrade()

  File "/tmp/update-manager-Vwi3Ev/DistUpgrade/DistUpgradeController.py", line 1663, in fullUpgrade
    if not self.updateSourcesList():

  File "/tmp/update-manager-Vwi3Ev/DistUpgrade/DistUpgradeController.py", line 734, in updateSourcesList
    self.sources = SourcesList(matcherPath=".")

  File "/tmp/update-manager-Vwi3Ev/DistUpgrade/sourceslist.py", line 253, in __init__
    self.matcher = SourceEntryMatcher(matcherPath)

  File "/tmp/update-manager-Vwi3Ev/DistUpgrade/sourceslist.py", line 442, in __init__
    dist = DistInfo(f, base_dir=matcherPath)

  File "/tmp/update-manager-Vwi3Ev/DistUpgrade/distinfo.py", line 239, in __init__
    print("WARNING: Failed to read mirror file")

IOError: [Errno 5] Input/output error
</pre>

When I run do-unattended-upgrade, I am told that I have a PPA without support for quantal ( https://launchpad.net/~pmjdebruijn/+archive/darktable-release-plus ). The PPA is removed, and the upgrade continues without errors

Thus I am assuming this error is caused by the presence of a ppa without support for quantal.

Revision history for this message
Christian Tellefsen (chris-launchpad-net) wrote :
tags: added: dist-upgrade
affects: update-manager (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
tags: added: quantal
Revision history for this message
Brian Murray (brian-murray) wrote :

There was also an issue when trying to report the crash regarding not being able to find apport:

2012-10-22 12:13:08,474 DEBUG running apport_crash()
2012-10-22 12:13:08,848 DEBUG can't find apport

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Revision history for this message
Brian Murray (brian-murray) wrote :

I believe the IOError message is because of the print statement and it having nowhere to write. There are quite a few occurrences of this on errors.ubuntu.com, however they are not grouped together because the tmp folder from which the upgrade is ran is different. Here is one example though:

https://errors.ubuntu.com/oops/23b13516-9e1c-11e2-a76a-e4115b0f8a4a

Revision history for this message
Brian Murray (brian-murray) wrote :

Having said that though I've been unable to recreate this issue although when running the same commands in the terminal I have see the 'Failed to read mirror file' warning.

Revision history for this message
Brian Murray (brian-murray) wrote :

Digging into this further I wondered why the mirror file was failing to be read. The release upgrader tarball includes Ubuntu.info but not Ubuntu.mirrors and the code tries to read from '/tmp/ubuntu-release-upgrader-XYZ/Ubuntu.mirrors'.

Revision history for this message
Brian Murray (brian-murray) wrote :

Its not immediately clear to me how base_dir is getting overwritten. It looks like it should be '/usr/share/python-apt/templates'.

summary: - update-manager fatal error while upgrading from precise to quantal,
- caused by PPA
+ update-manager fatal error while upgrading from precise to quantal due
+ to Ubuntu.mirrors not being available
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Brian Murray (brian-murray)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:0.192.10

---------------
ubuntu-release-upgrader (1:0.192.10) raring; urgency=low

  * Add in Ubuntu.mirrors from python-apt-common for the release upgrader
    (LP: #1069745)
 -- Brian Murray <email address hidden> Fri, 19 Apr 2013 08:18:15 -0700

Changed in ubuntu-release-upgrader (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments