DistUpgradeViewKDE.py launches browser as root

Bug #1069072 reported by skierpage on 2012-10-20
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Unassigned

Bug Description

I'm was running the KDE 12.10 upgrade on 64-bit Ubuntu 12.04.1 LTS. It put up a dialog

  Not enough free space
  The upgrade has aborted... total 2,579M ... an additional 175M of disk space

(I can't select the dialog's text! another, different bug)

When I clicked [Report Bug], chromium complains that it can't run as root, with an alert and:
  [11775:11775:18236679840:ERROR:chrome_browser_main_extra_parts_gtk.cc(50)] Startup refusing to run as root.

I believe Firefox will run as root, but then the next time it tries to upgrade itself, Firefox will fail to upgrade up due to permissions.

Let me report bugs about the ugprade, but don't start the browser as root!

Here are the relevant ps alx -w -w lines:

F UID PID PPID PRI NI VSZ RSS WCHAN STAT TTY TIME COMMAND
4 0 11764 1 25 5 4400 672 wait SN ? 0:00 /bin/sh /usr/bin/xdg-open https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+filebug
4 0 11775 11764 25 5 279672 24176 poll_s SNl ? 0:00 /usr/lib/chromium-browser/chromium-browser https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+filebug

You can see it's trying to run the browser as UID 0 i.e. root.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Brian Murray (brian-murray) wrote :

This is specific to the KDE view:

    def reportBug(self):
        """start konqueror"""
        #need to run this else kdesu can't run Konqueror
        #subprocess.call(['su', 'ubuntu', 'xhost', '+localhost'])
        QDesktopServices.openUrl(QUrl("https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+filebug"))

The gtk views just provide the user with a url and do not open the browser.

summary: - [Report bug] mustn't run browser as root
+ DistUpgradeViewKDE.py launches browser as root
Brian Murray (brian-murray) wrote :

Riddell, Scott indicated you'd be the best person to have a look at this. Thanks!

Jonathan Riddell (jr) on 2013-03-29
Changed in ubuntu-release-upgrader (Ubuntu):
milestone: none → ubuntu-13.04-beta-2
tags: added: kubuntu
sindhu (sindhu-h) on 2013-11-09
Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → Fix Released
Changed in ubuntu-release-upgrader (Ubuntu):
status: Fix Released → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers