Upgrade aborts because of java dependency problems

Bug #1068487 reported by Florian Achleitner
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Triaged
Low
Unassigned
ubuntu-release-upgrader (Ubuntu)
Triaged
Low
Unassigned

Bug Description

Unfortunately the upgrade aborts. I ran apt-get dist-upgrade, which installed the remaining packages without problems.

Revision history for this message
Florian Achleitner (fachleitner) wrote :
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the log files from '/var/log/dist-upgrade/' to this bug report as separate attachments? Thanks in advance.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
Revision history for this message
Brian Murray (brian-murray) wrote :

This looks like the issue:

Setting up libidn11:amd64 (1.25-2) ...^M
dpkg: dependency problems prevent configuration of eclipse-platform:^M
 eclipse-platform depends on libjetty8-java; however:^M
  Package libjetty8-java is not installed.^M
^M
dpkg: error processing eclipse-platform (--configure):^M
 dependency problems - leaving unconfigured^M
...
Setting up gir1.2-atk-1.0 (2.6.0-0ubuntu1) ...^M
dpkg: dependency problems prevent configuration of eclipse-pde:^M
 eclipse-pde depends on eclipse-platform (>= 3.8.0~rc4-1ubuntu1); however:^M
  Package eclipse-platform is not configured yet.^M
^M
dpkg: error processing eclipse-pde (--configure):^M
 dependency problems - leaving unconfigured^M
Setting up libservlet2.4-java (6.0.35-5) ...^M
Setting up python2.7 (2.7.3-5ubuntu4) ...^M
dpkg: dependency problems prevent configuration of eclipse-jdt:^M
 eclipse-jdt depends on eclipse-platform (>= 3.8.0~rc4-1ubuntu1); however:^M
  Package eclipse-platform is not configured yet.^M
^M
dpkg: error processing eclipse-jdt (--configure):^M

Changed in ubuntu-release-upgrader (Ubuntu):
status: Incomplete → New
Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

Could you please add the log files from '/var/log/dist-upgrade/' to this bug report as separate attachments (not pasted into comments or tar/zip-ed)? Thanks in advance.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
summary: - upgrade aborts because of dependency problems
+ Upgrade aborts because of dependency problems
Revision history for this message
Brian Murray (brian-murray) wrote :

The log file already attached is sufficient.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Incomplete → Triaged
summary: - Upgrade aborts because of dependency problems
+ Upgrade aborts because of java dependency problems
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Low
Changed in hundredpapercuts:
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Low
Changed in hundredpapercuts:
assignee: Papercuts Ninjas (papercuts-ninja) → nobody
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers