software updater stops: error calculating the changes - failed on ubuntu-desktop

Bug #1059770 reported by j
124
This bug affects 28 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Expired
Low
Unassigned

Bug Description

software updater is performing a partial upgrade, stops with calculating error message.
asks to run "ubuntu-bug ubuntu-release-upgrader-core".

"sudo apt-get upgrade" is working whitout error message.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubuntu-release-upgrader-core 1:0.181
ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
Uname: Linux 3.5.0-16-generic x86_64
ApportVersion: 2.5.3-0ubuntu1
Architecture: amd64
Date: Mon Oct 1 20:10:46 2012
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to quantal on 2012-09-04 (26 days ago)
VarLogDistupgradeTermlog:

Revision history for this message
j (ozaram) wrote :
Revision history for this message
Sasa Paporovic (melchiaros) wrote :

I dedublicate here, becuase the report

https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1041026

is not very specific and fails represent the informations that are provoded here within the logs.

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

In VarLogDistupgradeApttermlog.txt

is the line

012-09-04 20:22:37,593 ERROR got error from PostInstallScript ./xorg_fix_proprietary.py (Failed to execute child process "./xorg_fix_proprietary.py" (No such file or directory))

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

There are two explanations for:

1.

The failing may be caused, because of

2012-09-04 18:36:46,682 DEBUG check if patch '_usr_bin_pycompile.b17cebfbf18d152702278b15710d5095.97c07a02e5951cf68cb3f86534f6f917' needs to be applied
2012-09-04 18:36:46,682 DEBUG target for '_usr_bin_pycompile.b17cebfbf18d152702278b15710d5095.97c07a02e5951cf68cb3f86534f6f917' is '_usr_bin_pycompile' -> '/usr/bin/pycompile'
2012-09-04 18:36:46,683 WARNING unexpected target md5sum, skipping: '/usr/bin/pycompile'

which shows that pycompile was skipped due to an false MD5 checksum.

May be it is needed to ./xorg_fix_properitary.py

which is an python script.

Only a suggestin, this may be checked by someone with python skills.

Revision history for this message
Sasa Paporovic (melchiaros) wrote :
Revision history for this message
Sasa Paporovic (melchiaros) wrote :

The x-swat ppa is unknown to me.

The bumblebee project has the target to provide hybrid graphics(Nvidia/ATI mixed systems) AFAIK.

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

Aha

in

VarLogDistupgradeAptlog.txt

one can find:

Investigating (4) ubuntu-desktop [ amd64 ] < 1.285 > ( metapackages )
Broken ubuntu-desktop:amd64 Depends on unity [ amd64 ] < 6.6.0-0ubuntu1 > ( gnome )
  Considering unity:amd64 10000 as a solution to ubuntu-desktop:amd64 10000
Done
ERROR:root:failed to mark 'ubuntu-desktop' for install (E:Unable to correct problems, you have held broken packages.)

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

So the package ubuntu-desktop fails to install.

This may be caused by the problmes mentiont in the comments before.

summary: - software updater stops: error calculating the changes
+ software updater stops: error calculating the changes - failed on
+ ubuntu-desktop
Revision history for this message
Brian Murray (brian-murray) wrote :

Given that the reporter was running Ubuntu 12.10 before its final release this may have been due to inconsistencies in the archive at the time the partial upgrade was attempted.

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Low
Revision history for this message
Brian Murray (brian-murray) wrote :

The same dependency issues can be seen in bug 1059664 so this is even more likely to be an inconsistency in the archive.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for ubuntu-release-upgrader (Ubuntu) because there has been no activity for 60 days.]

Changed in ubuntu-release-upgrader (Ubuntu):
status: Incomplete → Expired
Revision history for this message
Tyra Maxine Villanueva Bernabe (tyramaxinebernabe04) wrote :

can't update the latest version

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers