Upgrade from kubuntu 12.04 to 12.10 failed using "sudo do-release-upgrade -d "

Bug #1044144 reported by Epaminondas Karelis
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Running a 12.04 Kubuntu system (which was originally set up as a 11.10 Ubuntu, then switched to KDE, then upgraded to 12.04). Ran "sudo do-release-upgrade -d" since the "update-manager -d" was failing (which is a documented known bug).

The release upgrader downloaded all packages and threw the following error:

Processing triggers for man-db ...
dpkg: error: parsing file '/var/lib/dpkg/status' near line 48205 package 'libibus-1.0-0:i386':
 mixed non-coinstallable and coinstallable package instances present
Error in function:

A fatal error occurred

Please report this as a bug and include the files
/var/log/dist-upgrade/main.log and /var/log/dist-upgrade/apt.log in
your report. The upgrade has aborted.
Your original sources.list was saved in
/etc/apt/sources.list.distUpgrade.

SystemError: E:Sub-process /usr/bin/dpkg returned an error code (2)

Could not install the upgrades

The upgrade has aborted. Your system could be in an unusable state. A
recovery will run now (dpkg --configure -a).

Please report this bug in a browser at
http://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+filebug
and attach the files in /var/log/dist-upgrade/ to the bug report.
installArchives() failed

dpkg: error: parsing file '/var/lib/dpkg/status' near line 48205 package 'libibus-1.0-0:i386':
 mixed non-coinstallable and coinstallable package instances present
dpkg-query: error: parsing file '/var/lib/dpkg/status' near line 48205 package 'libibus-1.0-0:i386':
 mixed non-coinstallable and coinstallable package instances present

Revision history for this message
Epaminondas Karelis (ekarelis) wrote :
Revision history for this message
Epaminondas Karelis (ekarelis) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Revision history for this message
afoglia (afoglia) wrote :

I had a similar error.

update-manager -d failed with a KeyError. Now update manager only offers a partial upgrade and says "An upgrade from 'quantal' to 'precise' is not supported with this tool."

Running apt-get dist-upgrade -f now fails with:

dpkg-query: error: parsing file '/var/lib/dpkg/status' near line 15619 package 'libssl0.9.8:i386':
 mixed non-coinstallable and coinstallable package instances present
exim4-config.postinst: [WARN] Installed debconf version is broken. Aborting preconfigure.
dpkg: error: parsing file '/var/lib/dpkg/status' near line 15619 package 'libssl0.9.8:i386':
 mixed non-coinstallable and coinstallable package instances present
E: Sub-process /usr/bin/dpkg returned an error code (2)

Given that I wanted to upgrade to fix the buggy xserver-xorg version in precise, I'm now downloading Debian testing.

Revision history for this message
Digulla-hepe (digulla-hepe) wrote :

Same error message but different package:

dpkg: error: parsing file '/var/lib/dpkg/status' near line 9758 package 'libreoffice3.5-dict-fr':
 mixed non-coinstallable and coinstallable package instances present

Revision history for this message
Digulla-hepe (digulla-hepe) wrote :

main.log for error in libreoffice3.5-dict-fr

Revision history for this message
Digulla-hepe (digulla-hepe) wrote :

This is a bug in the file /var/lib/dpkg/status

I found that it contains two entries for some packages:

Package: libreoffice3.5-dict-fr
Status: install ok installed
Installed-Size: 6796
Maintainer: Oracle
Architecture: amd64
Version: 3.5.1-102
Depends: libreoffice3.5-ure, libobasis3.5-core01, libobasis3.5-core02, libobasis3.5-core03, libobasis3.5-core04, libobasis3.5-core05, libobasis3.5-core06, libobasis3.5-core07, libreoffice3.5
Description: Fr dictionary for LibreOffice 3.5
 Copyright: 1999-2010 by Oracle
 Fr dictionary for LibreOffice 3.5

Package: libreoffice3.5-dict-fr
Status: deinstall ok config-files
Installed-Size: 6796
Maintainer: Oracle
Architecture: i386
Version: 3.5.1-102
Config-Version: 3.5.1-102
Depends: libreoffice3.5-ure, libobasis3.5-core01, libobasis3.5-core02, libobasis3.5-core03, libobasis3.5-core04, libobasis3.5-core05, libobasis3.5-core06, libobasis3.5-core07, libreoffice3.5
Description: Fr dictionary for LibreOffice 3.5
 Copyright: 1999-2010 by Oracle
 Fr dictionary for LibreOffice 3.5

Most lines are the same but these:

Status: install ok installed
Status: deinstall ok config-files

Architecture: amd64
Architecture: i386

Maybe the upgrade tried to switch from the i386 to amd64?

Revision history for this message
Brian Murray (brian-murray) wrote :

There was a workaround in dpkg in the following changelog:

dpkg (1.16.7ubuntu4) quantal; urgency=low

  * Apply a workaround from mvo to consider RC packages as multiarch,
    during the dpkg consistency checks. (LP: #1015567). Opened bug 1057367
    to upgrade status database.
 -- Dmitrijs Ledkovs <email address hidden> Thu, 27 Sep 2012 09:40:47 +0100

Please ensure that you have that version installed.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers