Push-client should be disabled when no network connection

Bug #1469398 reported by Marek Greško
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Ubuntu Push Notifications
Fix Released
Undecided
Unassigned
ubuntu-push (Ubuntu)
High
Jonas G. Drange

Bug Description

I and few people are observing higher battery drain when Wi-Fi off on BQ Aquaris E4.5 Ubuntu Edition latest OTA-4 update. I have no other active data connection.

There is a theory that ubuntu-push-client checks notifications every 5 minutes, but if you have no data connections it tries more often and lasts longer (because of connection timeout) and it holds the phone in wake state for longer time.

Credits: Richard Somloi.

There is a bug https://bugs.launchpad.net/ubuntu/+source/ubuntu-push/+bug/1437135 which fixes the problem for flight-mode, but should be extended to no data network available.

Credits: Oliver Grawert, Pat McGowan

Related branches

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-push (Ubuntu):
status: New → Confirmed
Marek Greško (mgresko8)
summary: - Push-client should be disabled when in no network connection
+ Push-client should be disabled when no network connection
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

tracking this but not yet sure who can work on it, may not make this update

Changed in canonical-devices-system-image:
assignee: nobody → Pat McGowan (pat-mcgowan)
importance: Undecided → High
milestone: none → ww28-2015
status: New → Confirmed
Changed in canonical-devices-system-image:
milestone: ww28-2015 → ww34-2015
Changed in canonical-devices-system-image:
assignee: Pat McGowan (pat-mcgowan) → Bill Filler (bfiller)
Changed in ubuntu-push (Ubuntu):
importance: Undecided → High
Bill Filler (bfiller)
Changed in canonical-devices-system-image:
milestone: ww34-2015 → ww40-2015
tags: added: push
Bill Filler (bfiller)
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in ubuntu-push (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Jonas G. Drange (jonas-drange)
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in ubuntu-push (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-push:
status: New → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

seems this only just landed

Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
status: Fix Released → Fix Committed
Revision history for this message
Michal Predotka (mpredotka) wrote :

Hmm... I thought it's fixed as my battery no longer loses its charge when I have data connections off. Before it was about 10% overnight. I upgraded yesterday and had no change in battery percentage in the morning compared to yesterday evening.

Revision history for this message
Marek Greško (mgresko8) wrote :

I have same observations after OTA-7. Is not it already in OTA-7? Maybe another battery draining bug fixed?

Revision history for this message
Jonas G. Drange (jonas-drange) wrote : Re: [Bug 1469398] Re: Push-client should be disabled when no network connection

On 20 October 2015 at 23:04, Michal Predotka <email address hidden> wrote:

> Hmm... I thought it's fixed as my battery no longer loses its charge
> when I have data connections off. Before it was about 10% overnight. I
> upgraded yesterday and had no change in battery percentage in the
> morning compared to yesterday evening.
>

Are you saying that you believe this issue has been fixed?

On 25 October 2015 at 09:17, Marek Greško <email address hidden> wrote:

> I have same observations after OTA-7. Is not it already in OTA-7? Maybe
> another battery draining bug fixed?

​Are you seeing a battery drain? Could you attach the accountpolld and
push-client logs? They are in /home/phablet/.cache/upstart

Thank you.

Revision history for this message
Michal Predotka (mpredotka) wrote :

Here's my latest push-client log: http://paste.ubuntu.com/12988567/
And here's accountpolld log: http://paste.ubuntu.com/12988599/

Revision history for this message
Jonas G. Drange (jonas-drange) wrote :

@mpredotka, what did you expect polld/push to do, and what happened instead?

Revision history for this message
Michal Predotka (mpredotka) wrote :

I had no expectations. Everything seems to work fine. Just wanted to show you my log as you asked in previous comment. 😃
As I mentioned before, for me this bug has been fixed in the last OTA unless the huge battery improvement was cosed by something else.

Revision history for this message
Jonas G. Drange (jonas-drange) wrote :

On 28 October 2015 at 15:58, Michal Predotka <email address hidden> wrote:

> I had no expectations. Everything seems to work fine.

​Ah—okay. Thanks for your feedback :)​

tags: added: power-bugs
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Revision history for this message
Marek Greško (mgresko8) wrote :

I confirm the fix works.

Should have been another bug fixed in OTA-7. I had 5 days battery life these days. After OTA-8 which contains this fix I got 9 days battery life with Wi-Fi turned off all the time, two sim card active (one of them 3G, data off) and several calls. Well done. The only drawback since OTA-7 is only very unrealistic battery charge level, which holds the same value for the long time and then drops several tenths of percents in very short time.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers