With screen locked, notifications sometimes don't show up, only sound

Bug #1429276 reported by Omer Akram on 2015-03-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
ubuntu-push (Ubuntu)
High
Jonas G. Drange
ubuntu-push (Ubuntu RTM)
Undecided
Unassigned

Bug Description

There might be other scenarios to reproduce this issue but one that I found is out of a few times, when the screen is locked, gmail notifications don't show up at all, only the blip sound happens on polld refresh.

1. Make sure notifications are being received
2. Lock the screen and create an incoming gmail notify

Out of the few attempts the notifications will stop showing unless the ubuntu-push-client is restarted.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: ubuntu-push-client 0.67+15.04.20150209-0ubuntu1
Uname: Linux 3.4.67 armv7l
ApportVersion: 2.16.2-0ubuntu1
Architecture: armhf
Date: Sat Mar 7 02:35:32 2015
InstallationDate: Installed on 2015-03-06 (0 days ago)
InstallationMedia: Ubuntu Vivid Vervet (development branch) - armhf (20150306-020203)
SourcePackage: ubuntu-push
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.xdg.ubuntu.push.client.config.json: 2015-03-07T02:21:05.979033

Related branches

Omer Akram (om26er) wrote :
Omer Akram (om26er) wrote :
Bill Filler (bfiller) wrote :

I see this daily, phone beeps and light flashes but screen does not wake up

Changed in ubuntu-push (Ubuntu):
assignee: nobody → Jonas G. Drange (jonas-drange)
importance: Undecided → High
Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
milestone: none → ww02-2016
Changed in ubuntu-push (Ubuntu):
status: New → Confirmed
Bill Filler (bfiller) wrote :
Bill Filler (bfiller) wrote :

phablet@ubuntu-phablet:~$ system-image-cli -i
current build number: 204
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2015-12-15 10:02:05
version version: 204
version ubuntu: 20151215
version device: 20151204-2254a36
version custom: 20151111--36-46-vivid

Bill Filler (bfiller) wrote :
Changed in canonical-devices-system-image:
status: New → Confirmed
Bill Filler (bfiller) wrote :

ubuntu-push-client version 0.68+15.04.20151203-0ubuntu1

Bill Filler (bfiller) wrote :

Just got it to happen again, phone beeped but did not wake up. Here are the fresh logs.

Bill Filler (bfiller) wrote :

Just got it to happen again, phone beeped but did not wake up. Here are the fresh logs.

Bill Filler (bfiller) wrote :
Bill Filler (bfiller) wrote :

note, I do not see the new gmail messages in the indicator either, so not only did the phone not turn on but the messages were not added to the indicator. However something caused the phone to beep and blink

Jonas G. Drange (jonas-drange) wrote :

Proposed reproduce:
1) clear the indicators
2) send some messages to your gmail account
3) the phone properly wakes up and displays the messages on screen and in indcator
4) put phone back to sleep and send more messages to gmail
5) now the phone will just beep but not turn on the screen or add messages to indicator

Bill Filler (bfiller) wrote :

I can reproduce reliably in this way:
 1) clear the indicators
2) send some messages to your gmail account
3) the phone properly wakes up and displays the messages on screen and in indcator
4) put phone back to sleep and send more messages to gmail
5) now the phone will just beep but not turn on the screen or add messages to indicator

it stays broken until you clear the indicators

Changed in ubuntu-push (Ubuntu):
status: Confirmed → In Progress
Paty Davila (dizzypaty) wrote :

=== UX Comment ===

As per the design specification for the new notification system: (http://bit.ly/1P70Dkb)

- In general, applications can fire only one notification at a time, but multiple applications can fire their notification simultaneously. All notifications should be treated as if they are in a queue and will be handled sequentially according to their fire time (in a FIFO manner).

- Grouping notifications from the same app in the notification centre and lock screen:

*If a notification of a certain type is already pending in the queue (not fired yet) when an app tries to send a new notification, they will be combined into a summary notification for that app.
*When the phone is locked, if a summary notification is already displayed on the lock screen and when a new notification from the same app arrives, the number displayed on the secondary icon will change to the correct count (detail text will change accordingly).
*Therefore, the notification bubble should be discarded from the queue and never displayed as a single bubble in normal usage. Same behaviour applies to the notification centre.

======

@jonas-drange, you mentioned that when you get 4 gmail notifications without clearing any, the 3rd and 4th notification will only emit a beep. So I understand that this bug is not only related with the screen being locked but also with the number of notifications that are in the queue?

My suggestion is that the grouping of notifications should not be dependant on the number of them but rather on the conditions listed above, otherwise, each notification should be displayed individually.

I'm happy to discuss this further.

Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Timo Jyrinki (timo-jyrinki) wrote :

account-polld (0.1+15.04.20151221-0ubuntu1) vivid; urgency=medium

  [ jonas-drange ]
  * Force parsing of email address even if it violates RFC 5322. Encode
    icon file paths since unity-notifications require it. Summarize
    notification bubbles when > 10 in a batch, but never summarize in
    the indicator. (LP: #1429276)

 -- <email address hidden> (Jonas G. Drange) Mon, 21 Dec 2015 12:18:40 +0000

Changed in ubuntu-push (Ubuntu RTM):
status: New → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in ubuntu-push (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers