Ubuntu

Cannot add to panel

Reported by Jamie Bennett on 2009-10-10
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
ubuntu-netbook-remix-default-settings (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: netbook-launcher

Applets and menus cannot be added to the panel in UNR.

Try:
1) Right click session manager menu (applet?).
2) Click remove from panel.
3) Right click on panel to try to re add it.

Result:
There is no option to add the session manager back to the panel. (Same happens with the date/time menu).

ProblemType: Bug
Architecture: i386
Date: Sat Oct 10 17:11:44 2009
DistroRelease: Ubuntu 9.10
GConfNonDefault:
 /apps/netbook-launcher/disable_single_instance=false
 /apps/netbook-launcher/force_low_graphics=false
MachineType: Dell Inc. Inspiron 1011
NonfreeKernelModules: wl
Package: netbook-launcher 2.1.10-0ubuntu1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=c1fef63a-97b1-4733-b6ba-ed8d6a79380d ro quiet splash
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0-1ubuntu2
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu3
SourcePackage: netbook-launcher
Tags: ubuntu-unr ubuntu-unr
Uname: Linux 2.6.31-11-generic i686
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 07/29/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: CN0Y53
dmi.board.vendor: Dell Inc.
dmi.board.version: A06
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A06
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd07/29/2009:svnDellInc.:pnInspiron1011:pvrA06:rvnDellInc.:rnCN0Y53:rvrA06:cvnDellInc.:ct8:cvrA06:
dmi.product.name: Inspiron 1011
dmi.product.version: A06
dmi.sys.vendor: Dell Inc.
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-11-generic

Jamie Bennett (jamiebennett) wrote :
Paul Larson (pwlars) wrote :

This is actually possible to do, although perhaps not as straightforward as many people would like it to be. I was able to just do this on a UNR install by following these steps:
1. right click on the indicator applet (the icon that looks like an envelope)
2. deselect "Lock to panel"
3. right-click on it again and select 'Move'
4. move it over a bit to the left, thus leaving an open blank area to the right of it
5. right click in the blank area and select 'add to panel'

I'd like to make this a wishlist item for now, but it could perhaps be converted to a question as well if it is decided not to pursue this as something that could be improved

Changed in netbook-launcher (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Jamie Bennett (jamiebennett) wrote :

I'd like to see at least this applet 'locked' to the panel, i.e. no way to remove it, now that the shutdown/reboot options have moved there. There seems no reason why a user would want to remove the ability to shutdown/reboot their machine.

Paul Larson (pwlars) on 2009-10-13
affects: netbook-launcher (Ubuntu) → ubuntu-netbook-remix-default-settings (Ubuntu)
viganiko (aniko-nagyne-vig) wrote :

Even if I remove icons, I don't always have the menupoint "add to panel". It depends what I move.
The movement options are far from perfect too. I can't move back the Ubuntu sign to the left corner. Every opening application jumps before it to its left.

Didier Roche (didrocks) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
We think this bug should be now fixed in lucid in some way (no more possible to remove applet from panel, as we consider this as UNE experience). You can switch then to normal GNOME desktop on the same desktop if you want to personalize your bars.

In the meanwhile, I set the report as Fix Released for easier tracking, do not hesitate to set it as Confirmed again if the bug is still present for you in lucid.

Changed in ubuntu-netbook-remix-default-settings (Ubuntu):
status: Triaged → Fix Released
Bieito Glez-Dans (obieito) wrote :

I am having a similar problem, have been searching but found no similar bug... In my case, with netbook remix lucid (10.4) I have the options to lock applets, remove from panel, etc, but they are all grayed out (blocked).

I have been trying to find a solution but haven't been able. I moved my .gconf and .gconfd folders to try with new configuration (same issue), created a new user, and same issue. For some reason, I can't add or remove anything from the panel.

Shreko (shrekuntu) wrote :

I'm having exactly the same problem like previous post (#6)

Didier Roche (didrocks) wrote :

A default panel is something we decided on purpose and part of the UNE experience. This enables you as well to have a dedicated GNOME session if you logout and choose "GNOME" as a session in GDM, which wasn't possible before lucid.

If you want still to be able to personalize your panel, you should get ride of the GNOME session to transform it into a UNE one. You will find needed info at https://help.ubuntu.com/community/UbuntuNetbookEdition/ConvertGnomeSession

Mihhail Afanasjev (moshanator) wrote :

"A default panel is something we decided on purpose and part of the UNE experience."

This experience can be very frustrating for anyone who, for example, uses more than two keyboard layouts. Right now either a session conversion or a keyboard shortcut setup is required just to be able to type in two different alphabets (e.g. Latin for web addresses/usernames/terminal and Cyrillic for everything else).

Perhaps the default panel could automatically include the layout switcher if more than two layouts are defined in the Keyboard Settings.

Didier Roche (didrocks) wrote :

The keyboard layout is an indicator appearing on the notification area. This is so not a new applet and if you configure in GNOME to have more than layout, you should see both (I have that on my netbook). If you don't, tell me.

Mihhail Afanasjev (moshanator) wrote :

Indeed, it is there. I was expecting it to be as it was in Karmic, e.g. an applet, not a notification icon. Will have to keep my eyes open next time.

I have this same issue with a complication factor: The shutdown/reboot/userchange applet isnt available and when i login into UNR it says a problem with this applet was found, asking-me to remove it from dock or not. So, i cant shutdown without console/power button.

I'm having the same problem like post #6.

I want to change the panel size (to 32px), color and transparency to match my theme!!

"A default panel is something we decided on purpose and part of the UNE experience."
this doesn't make sense, don't allow the user to change this default panel config is just stupid -.-

rizwan (ibnishak) wrote :

hello, well, i upgraded to lucid lynx yesterday. now when i right click on top panel, add to panel option is greyed out, along with move and lock to panel options. had no problem with karmic kaola. any fixes

Didier Roche (didrocks) wrote :

This is not possible with UNE lucid version. As it will be in GNOME Shell soon because you have a GNOME and an UNE session. You can kill your GNOME session manually to get back an editable panel but can't have both for technical reason: https://help.ubuntu.com/community/UbuntuNetbookEdition/ConvertGnomeSession

dunxd (d-drury) wrote :

This is a drag for me too, in . All I want to do is add the widget that show me if caps lock is on or not. I can install the app, but I cannot add it to the panel. So far all I am seeing is excuses for why this isn't possible, or claims it is a design decision. Doesn't stop it being a bug from the vast majority of users point of view. So is anyone going to make an attempt to fix this, or are we stuck with an uncustomisable feature?

Thanks Canonical for your hard thinking on this stupid move.

"A default panel is something we decided on purpose and part of the UNE experience."

based on what? Can I have my FREEDOM back please? a simple lock/unlock option is sufficient.

           Why do we need to stand for this really stupid move?

Didier Roche (didrocks) wrote :

> Why do we need to stand for this really stupid move?

Something, like read comments which explains why there is the technical difficulty about that change? Also follow the link proposed above?
https://help.ubuntu.com/community/UbuntuNetbookEdition/ConvertGnomeSession

dunxd (d-drury) wrote :

How come the BBC iPlayer Desktop application, an Adobe Air application, can install itself to the panel in NBR, but we are repeatedly told it isn't possible to do this?

Or is this using some other mechanism that could be used to put useful icons/tools in the top right hand corner of NBR screen?

http://iplayerhelp.external.bbc.co.uk/help/download_programmes/iplayer_desktop

Didier Roche (didrocks) wrote :

This is either a notification or an application indicator. Both of them are supported in the UNE bar.

> Something, like read comments which explains why there is the technical difficulty about that change?

You have not explained *why* there is a technical difficulty. The URL you give does not explain it either. It just says "this is the way it is" but it does not say *why*.

I would appreciate something that explained *why*. Because being unable to alter the panel applets is *maddening*. Converting the gnome session to look like a UNR session is a bad solution. It involves a lot of work that should not be necessary just to add or remove one applet to the panel.

It should be possible to unlock these settings. Maybe in gconf-editor? Maybe there is a file whose permissions can be changed? I don't care if the UNR settings break the GNOME settings.

It is a bad day when open source software developers force decisions on users. Open source means giving you freedom over your computer and its software. But this is a decision to take freedom away.

Didier Roche (didrocks) wrote :

Oki, let's dive into technical details then…

Gnome panel is setting some gconf key describing the layout of the panel in your local gconf settings at first launch, especially even if you don't change the default.
For being able to switch between session, we change many things in your system, like the XDG path and the gconf ones. Gconf has some notion of mandatory and default settings, but if I put some default settings like "have only one panel", if you start the GNOME session first, you will end up with two, right? This settings will be recorded as "modified by the user" and then, switching back to the UNE session, you will end up with your "custom settings", which means, two panels, not the same applets and such.

The only way to workaround that (gnome panel upstream isn't keen to take a patch and to fix that. It has a lot of historical reason and will be vanished with GNOME3) is to set the gconf key as mandatory as long as we want to support more than one session.

I published the workaround in the previous link in case you don't want to have a GNOME and UNE session. If you are not interested in having both, it's good, but we saw that there were a lot of demands to be able to switch between the two. So no kidding on freedom, we published everything in previous comments and answered to your question…

Of course, if you want to work to fix that and to contribute there, this is a good opportunity. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers