Ubuntu

can't add, move, unlock applets & no clock

Reported by Bryan Moore on 2010-02-10
164
This bug affects 31 people
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Low
Unassigned
ubuntu-netbook-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-panel

Description: Ubuntu lucid (development branch)
Release: 10.04
gnome-panel:
  Installed: 1:2.29.6-0ubuntu2
  Candidate: 1:2.29.6-0ubuntu2
  Version table:
 *** 1:2.29.6-0ubuntu2 0
        500 http://us.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

No matter what I do, I can't add, move, or unlock applets on the gnome panel *and* I just recently lost my clock.

ProblemType: Bug
Architecture: i386
Date: Tue Feb 9 19:45:00 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100207)
Package: gnome-panel 1:2.29.6-0ubuntu2
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
SourcePackage: gnome-panel
Uname: Linux 2.6.32-12-generic i686

Bryan Moore (moore-bryan) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in gnome-panel (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Bryan Moore (moore-bryan) wrote :

Sorry, I thought the answers to those questions were explained in the original bug...
     1. Reproducible because it happens all the time.
     2. It can be recreated by trying to add, move, or unlock any of the applets already on the gnome-panel.

I'm not sure how to mark my clock being missing... I can't reproduce or recreate something that isn't there.

Thanks for the help!

Joshua Szmajda (josh-loki) wrote :

This affects me too. I see the Clock applet in gconf:
josh@coyote:~$ gconftool -R '/apps/panel/applets/applet_7'
 menu_path = applications:/
 launcher_location =
 bonobo_iid = OAFIID:GNOME_ClockApplet

and here:
josh@coyote:~$ gconftool -R '/apps/panel/general'
 profiles_migrated = false
 enable_program_list = true
 applet_id_list = [applet_0,applet_1,applet_2,applet_3,applet_4,clock_screen0,applet_6]

I don't see applet_7 in the list, and I can't edit applet_id_list either.

I'm probably going about this the wrong way, but I am certainly affected by the lack of a clock, and there's no mouse-based UI to add items to the panel.

I've also tried wiping my .gconf folder and the problem persists. I also tried creating a new, blank user, and the problem exists on this user. I've attached this test user's home folder for your perusal. If there's anything else I can provide, please let me know :)

Ryan Waldroop (ryan.waldroop) wrote :

This bug is reproducible for me across multiple machines in both the Alpha 2 and several recent daily-live ISOs I've burned to USB. I've also still got this problem on my Dell Mini 9 with a fully up-to-date installation.

I was able to add the clock by rsyncing my desktop's ~/ folder to my laptop's, but somehow it's stuck on the left hand side and cannot be moved.

I'm marking this as confirmed.

Changed in gnome-panel (Ubuntu):
status: Incomplete → Confirmed
Ryan Waldroop (ryan.waldroop) wrote :

I also want to confirm Joshua's post: this doesn't just affect my user account or the default "ubuntu" live-cd account, but also any new account added to the system.

Ryan Waldroop (ryan.waldroop) wrote :

And one more point I just thought to make:

This bug only affects the gnome-panel when logging into an Ubuntu Netbook Edition session, but not a standard Gnome session on UNE. So to reproduce:

1. Boot computer.
2. When GDM loads, select your user name.
3. Next to "Session" at the bottom of the screen, select Ubuntu Netbook Edition
4. Right click anywhere in the panel, and notice that there is no way to unlock or move existion panel applets and icons, nor is there a way to add any new icons.

*BUT* if in step 3 above you select "GNOME" as the current session to run, all gnome-panel applets behave as expected.

Didier Roche (didrocks) wrote :

Right,

This is by design and due to some technical issues.
If you choose the Ubuntu Netbook Edition session, the panel is locked.
If you choose the GNOME session (which is new in lucid for UNE), you have your traditional GNOME session.

LaserJock will provide a documentation for people really wanting to change their panel, but you will lost your GNOME session then.

Changed in gnome-panel (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-netbook-default-settings (Ubuntu):
status: New → Won't Fix
Didier Roche (didrocks) wrote :

BTW, the "no clock issue" will be fixed before alpha3, it's on my radar.

Joshua Szmajda (josh-loki) wrote :

Thanks, Didier!

Is there a related bug in the gnome project or somewhere to get the technical issues fixed? I really like the UNE interface, but it would be nice to continue customizing my panel.

Didier Roche (didrocks) wrote :

No bug on the gnome project about that AFAIK. Supporting multiple GNOME session with different user configuration isn't available upstream and something we did into ubuntu. However, being able to edit the added session is really tricky in case of GNOME panel and shouldn't land in a LTS.

That's why the workaround will be the documentation LaserJock will write, but unfortunately, you won't be able anymore to have a dedicated GNOME session you can choose in GDM. So, that's some kind of tradeoff.

Milos Ilic (miske84bg) on 2010-02-19
Changed in gnome-panel (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Joshua Szmajda (josh-loki) wrote :

Ah, I understand. Personally I don't mind not being able to have a 'standard' gnome session, but I could see where others would. Is there aims at making the UNE experience work inside a standard gnome session eventually? Maybe that would fix it?

Thanks a lot!

Didier Roche (didrocks) wrote :

It was like that before. But in lucid, you can have two sessions now, the GNOME one and the UNE one.

In fact, UNE is basically a GNOME session with some tweaked.
The doc has been done by LaserJock if you don't need your GNOME session, you can screw it up there: https://help.ubuntu.com/community/UbuntuNetbookEdition/ConvertGnomeSession ;)

Enjoy!

Would this be the reason that I'm unable to change my chat status to "online"? I set up my account and was online during that session, but now that I have logged out and back in again, I can't change my status to any of the other options.

Didier Roche (didrocks) wrote :

No this is not related, you have to launch empathy to get the status back. You can launch it directly in the menu or by the indicator applet (select "Chat").
File a bug against the me men" if you think this is not appropriate

Anxious Nut (anxiousnut) wrote :

My every thing in my panel is locked, i cant add applet, cant move any!!

my installation is ubuntu netbook remix beta 1, i386 on compaq mini 110c

i tried gconf-edit but it didn't allow me to change the checkbox for locked, so i opened it as superuser but got diffferent configuration. It turned out that superuser has another gnome panel

that's all i know, and btw I realized this from the live cd and then on my netbook

Didier Roche (didrocks) wrote :

did you look at the comments?

see https://bugs.edge.launchpad.net/ubuntu/+source/gnome-panel/+bug/519583/comments/13
You have the rational about that.

John Washburn (washburnello) wrote :

I understand the logic used to make this decision but I agree with Joshua Szmajda. I wouldn't miss the Gnome Desktop option one bit. I'm using a Dell mini 9 and love the UNE interface but not being able to configure tha panel causes a real headache on my Vostro A90 (Same a Dell mini 9) as it does not have a caps-lock LED. I've always relied on putting an indicator on the panel to keep track of this. Now I have to type some text to see if caps-lock is on.
Like I said, I understand the reasoning but don't think it's a good idea as a default setting.

John Washburn (washburnello) wrote :

Correction to above post: I meant to say I'm using a Vostro A90, not a Mini 9.
Sentence should read "I'm using a Vostro A90 and love the UNE interface but not being able to configure the panel causes a real headache as it does not have a caps-lock LED. I've always relied on putting an indicator on the panel to keep track of this."
Sorry ;)

Didier Roche (didrocks) wrote :

Right, but the technical issue there strike us (gconf wasn't properly fitted to handle those case). Once again, you can use https://help.ubuntu.com/community/UbuntuNetbookEdition/ConvertGnomeSession if you don't need your GNOME session :)

rot (rot) wrote :

somehow this is nonsense. one cant really use unr like this - there must be a way to set this straight. i was especially troubled because i updated to lucid an suddenly my go-home applet diappeared and i could not edit the panel... ill just uninstall the unr settings now. who needs unr if it only has troubles

Didier Roche (didrocks) wrote :

You still can tweak the session for erasing your GNOME one.

If you have a technical solution to get the GNOME and UNE session without the locked panel (locked panel will happened in GNOME3 BTW with gnome shell), you're welcome. Even GNOME upstream in charge of the panel don't find a technically interesting option after chatting with them.

elect (elect86) wrote :

Hello,

Didier, i followed your guide, but the problem still persist.

I am running Lucid nbr RC on Dell mini9, fully updated in 3D Ubuntu Netbook Edition Session

Any ideas?

elect: After following the directions, reboot and on the gdm login screen,
select GNOME in the bottom right instead of UNE. For further assistance,
please ask in #ubuntu on irc.freenode.net or at ubuntuforums.org.

MT (micdhack) wrote :

There is also Ubuntu Netbook remix 2d that you can choose

StephanBeal (sgbeal) wrote :

This _might_ be a similar/related bug: starting this morning, my Gnome Panel clock is stuck at a specific time. If i remove the clock (or kill its process), the image of the clock stays on the panel but it no longer reacts like a clock (e.g. right-clicking brings up the panel menu, not the clock menu). Re-adding it doesn't solve the problem - it's still stuck at 11:28.

The system clock is not affect: "date" shows the proper time. See attached screenshot.

Using Ubuntu 10.4 clean install (except for my home dir, which was been around at least 4 years) on x86.

i suspect that comvpiz has something to do with it, but that's mere speculation based on similar problems i've had in the past when using compvis.

[3 minutes later...] As a matter of fact... disabling desktop effects (setting them to None via System->Prefs->Appearance) fixed the problem.

StephanBeal (sgbeal) wrote :

Well, i say "fixed" the problem, but now Alt-Tab no longer works to switch windows, and re-enabling effects doesn't fix it.

side (sidex666) wrote :

https://help.ubuntu.com/community/UbuntuNetbookEdition/ConvertGnomeSession : This is not a fix ! Thanks to didrocks to give this trick to people but it won't help me.

Personally I need both of the session for a public area. Netbook Remix is for free use (Web surfing and some other stuff) and gnome is for teaching people how to use computer under GNU/Linux.

I have removed all of applet in netbook-remix using gconf-editor and apt-get removing some indicator-* stuff (and gwibber). I finally only have the sound applet wich I want, and one annoying thing, there is still an applet telling me there is "no notifications". This one I can't remove 'cause It will create a bug at login : OAFIID:GNOME_IndicatorApplet is missing or something like that. That's a pity because it does not change anything to the system but as the applet isn't there anymore the system is complaining about that ... Allright so I let it go ...

Hi,

i have something simmilar on 2 HP laptops. one had brand new 10.04 install. I`ve also noticed that keyboard doeasnt work when this happens. ctrl alt backspace is the only solution [without hard reboot]. any chance to reopen this one?

posted in bad window :) forget the post :) sorry

francescomm (ubuntu-esurfers) wrote :

Hello, and thanks for the great work (Lucid is great, and NBR also).

I understand it is a problem to let users edit the panel on the fly, so I was wondering if there was a way to just add an applet or two once by modifying some prefs or init files and then leave it there forever.

After all, someone has chosen which were the panel applets to include and which were to skip, and that information must be written in files somewhere. So I guess it may be changed to just add an applet or two.

In my case I would really need the processor speed switcher, as the Atom processor really needs to be switched to performance mode some times (skype video..), and opening a terminal to do it isn't great. I also like other items (vnc client) but I can live without.

So I can live well without panel editing, movable panels and the like, and if there was just an ini file to tell NBR to load a panel item at next reboot, I'd consider it a real fix.

Thanks again,

Francesco

spinlock (andrew-d-dixon) wrote :

Someone take this feature out back and kill it. I wanted to try the netbook remix because the standard configuration has too much bloat for my laptop. The "fix" that is proposed gives me back the same bloated system with a slightly different user interface. What I need is a linux distro that doesn't bring my laptop to it's knees when I try to do anything more than surf the web (you know, something more like ubuntu used to be). Call me old fashioned, but I remember when linux was about giving users control of their machines not locking it down. An acceptable fix would be to follow francescomm's suggestion and allow manual editing of the panel so that users could decide if they want the indicator applet (I don't) or the system monitor applet (I do). Anyway, that's the end of my rant. Maybe I'll go back to Debian or try Kbuntu or something else. Ubuntu may have misfired with the 10.4 upgrade (for my needs) but that's the great thing about linux, there are plenty of distros to choose from and one of them is probably right for me :)

Ryan Waldroop (ryan.waldroop) wrote :

@spinlock: and for the millionth time, you *CAN EDIT* the default gnome
session to look just like UNE, with all of the custom applets that you want.
This is a non-issue. Sure it sucks (sort of?) that you can't switch back and
forth between gnome and UNE at will, but the transform button on 9.04 didn't
work half of the time either. Get over yourself.

spinlock (andrew-d-dixon) wrote :

@ryan: sorry for not making my issue clearer (I was frustrated because I thought I'd found a solution). I'm working on an "old" laptop that only has a half a gig of memory. The latest ubuntu distro will run for a couple of hours and then I have to reboot due to a memory leak making my laptop unusable. So, I'm looking for a distro with a smaller footprint. I've followed the steps that you describe but making the gnome session "look" like the netbook session still has the problem of using too much memory.

Ryan Waldroop (ryan.waldroop) wrote :

Ah, well that makes more sense. Give Lubuntu a try. :)

On May 17, 2010 10:56 AM, "spinlock" <email address hidden> wrote:

@ryan: sorry for not making my issue clearer (I was frustrated because I
thought I'd found a solution). I'm working on an "old" laptop that only
has a half a gig of memory. The latest ubuntu distro will run for a
couple of hours and then I have to reboot due to a memory leak making my
laptop unusable. So, I'm looking for a distro with a smaller footprint.
I've followed the steps that you describe but making the gnome session
"look" like the netbook session still has the problem of using too much
memory.

--
can't add, move, unlock applets & no clock
https://bugs.launchpad.net/bugs/519583
You received ...

yshavit (eleusinian) wrote :

If anyone's still having trouble with their clock, I may have found a solution. Although I didn't have the moving / unlocking issue, I couldn't add my clock. I got an unhelpful message about an error with OAFIID:GNOME_ClockApplet. My ~/.xsession-errors log contained:

** (gnome-panel:1521): WARNING **: panel-applet-frame.c:1273: failed to load applet OAFIID:GNOME_ClockApplet:
System exception: IDL:Bonobo/GeneralError:1.0 : Child process did not give an error message, unknown failure occurred

I found this site, which helped: http://www.linuxforums.org/forum/suse-linux-help/57382-oafiid-gnome_clockapplet.html

Specifically, the last post on that page (from Feb 2) showed that I was missing libedataserver-1.2.so.11. I checked in synaptic, and this had been upgraded to libedataserver-1.2.so.12.

The solution was to `cd /usr/lib` and then run `sudo ln -s libedataserver-1.2.so.12 libedataserver-1.2.so.11`. Hope this helps somebody!

frizzle21 (frederik-nnaji) wrote :

for desperate Unity testers:
you can remove gnome-panel altogether from your running session by using the solution from this thread:
http://forum.ubuntuusers.de/topic/gnome-panel-entfernen/
it is in german, so here the distilled info:

CAUTION - THIS CAN BREAK STUFF

# sudo chmod -x /usr/bin/gnome-panel
# killall gnome-panel

to revert this back to normal:
# sudo chmod +x /usr/bin/gnome-panel

Gizmo (simplysoftware) wrote :

My laptop wont handle a full gnome session while gaming, and UNE's panel broke itself and moved the currently running programs and their title bars between the system tray notifications and the clock

I'm rather upset about the issues with this, I would have liked to get the most out of my Ubuntu install and although I like the idea of 10+ hours of battery life, playing Morrowind and other games is out of the question, (btw Morrowind changing the resolution on me is how my panel got screwed up)

Since I can't fix my own problems (and screwing up the gnome session doesn't class as a fix)(and UNE2D and Gnome (full session) does not run on my laptop either) and the then I have no choice but to remove Ubuntu UNE from the list of operating systems I ship with new computers (and I'm lucky this issue came up before I started shipping)

When a REAL fix for this is available, I'll be interested in having another go
Until then I'll keep working on my own custom Gentoo install
(I expect an update of this magnitude would be shown on the Ubuntu homepage)

btw I tried the final version of UNE 10.04 and with bugs to do with resolution changes affecting the panel and end users being unable to fix this, in my opinion make it not production ready and should still be in development

Niall Brosnan (niallb) wrote :

I have the same issue with adding applets.
Of course I can work around it, but for a release titled
"Netbook Remix" to prevent a user from simply adding a CAPS LOCK status applet to the system is shortsighted.

To solve the moving/locked/whatever issue, you must turn off the value of /apps/panel/global/locked in your gconf. Found that out today.

cong06 (cong06) wrote :

Alexander Hausmann: I can't find this. What version of Ubuntu do you have?

On Thu, Jul 15, 2010 at 5:27 PM, Alexander Hausmann
<email address hidden> wrote:
> To solve the moving/locked/whatever issue, you must turn off the value
> of /apps/panel/global/locked in your gconf. Found that out today.
>
> --
> can't add, move, unlock applets & no clock
> https://bugs.launchpad.net/bugs/519583
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Thanks to denham2010's excellent tip at this thread: http://ubuntuforums.org/showthread.php?t=1515732

I managed to edit Ubuntu Netbook Remix 10.04 panel without switching to Gnome.

The file to edit is here:
/var/lib/gconf/une.mandatory/%gconf-tree.xml

Here are my changes which got system monitor in the panel:
neva@neva-aone:/var/lib/gconf/une.mandatory$ diff %gconf-tree.xml gconf-tree.xml.original
58,60d57
< <li type="string">
< <stringvalue>applet_7</stringvalue>
< </li>
151,164d147
< <dir name="applet_7">
< <entry name="object_type" mtime="1272540841" type="string">
< <stringvalue>bonobo-applet</stringvalue>
< </entry>
< <entry name="toplevel_id" mtime="1272540841" type="string">
< <stringvalue>top_panel</stringvalue>
< </entry>
< <entry name="panel_right_stick" mtime="1272540841" type="bool" value="true"/>
< <entry name="position" mtime="1272540841" type="int" value="1"/>
< <entry name="locked" mtime="1272540841" type="bool" value="true"/>
< <entry name="bonobo_iid" mtime="1272540841" type="string">
< <stringvalue>OAFIID:GNOME_MultiLoadApplet</stringvalue>
< </entry>
< </dir>

Screen shot of the new UNR session:
http://arcadia.anime.fi/~n/aspireone/UNR/UNR-sysmon-added.png

Simple way to start with the terminal:
cd /var/lib/gconf/une.mandatory/
sudo cp %gconf-tree.xml gconf-tree.xml.original
sudo wget http://arcadia.anime.fi/~n/aspireone/UNR/%25gconf-tree.xml

Logout and login.
Right click on the new thin line in the top bar, choose preferences and adjust system monitor width to get it to draw correctly.

linas (linasvepstas) wrote :

Arghhh. Logged out, logged back in, and clock applet jumped to center of gnome panel, and was locked there. On a two-screen system, this is really dumb, as half of the applet is on one screen, and half the applet is on the other. I'm miffed that my system was fine for months, and then a simple log-out/log-back-in screws it up.

This is in oneiric.

<rant> Could we do some regression testing before pushing out new ubuntu releases? I'm getting tired of having everything break all the time. It was not like this in the glory days of Ubuntu, when life was awesome. Now, its just random breakage for random reasons: yes, I read above how this supposedly makes things "better" for some imagined someone, but it always makes it worse, for me. </rant>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers