GNOME Control Center category icons only work for Ambiance and Radiance.

Bug #934335 reported by Dylan McCall on 2012-02-17
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Undecided
Unassigned
ubuntu-mono (Ubuntu)
Undecided
Unassigned

Bug Description

gnome-control-center and ubuntu-mono are using some special icons for category headers: preferences-desktop-peripherals-directory, preferences-desktop-personal-directory, and preferences-system-directory.

The -directory suffix was added to work around applications that are wrongly using category icons instead of app icons:
https://code.launchpad.net/~agateau/gnome-menus/directory-suffix/+merge/91663

The problem is these icon names aren't standard: the standard icons are those without the -directory suffix. This means any icon theme which doesn't inherit from ubuntu-mono (perhaps with Adwaita or one of the accessibility themes) causes System Settings to look really broken and ugly. These special icons should be placed in the hicolor theme, and perhaps provided by another package.

summary: - Please move preferences -directory icons to hicolor
+ GNOME Control Center category icons only work for Ambiance and Radiance.
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in ubuntu-mono (Ubuntu):
status: New → Confirmed
Sam_ (and-sam) wrote :
tags: added: precise
Mario (mariodopico) wrote :

Hi Dylan,

I have installed Faenza and I have this problem, you know some workaround?

Thanks

KEIII (cashagent) wrote :

copy icons from /ubuntu-mono-dark/categories to Faenza/Faince folder

This issue should be pushed upstream and any known theme dev should be warned about this behavior (ex: tiheum).

Personally, using Faenza (without reinstalling the mono theme), on UGR 12.10, I was able to link scalables back to the required file names like so:

#!/bin/bash

# Icons #

color= reset=
if [[ -t 1 ]]; then
color=$(tput setaf 6)
reset=$(tput sgr0);
fi

actions_directory="/usr/share/icons/Faenza/actions/scalable"
applications_directory="/usr/share/icons/Faenza/apps/scalable"
categories_direectory="/usr/share/icons/Faenza/categories/scalable"
devices_directory="/usr/share/icons/Faenza/devices/scalable"
emblems_directory="/usr/share/icons/Faenza/emblems/scalable"
mimetypes_directory="/usr/share/icons/Faenza/mimetypes/scalable"
places_directory="/usr/share/icons/Faenza/places/scalable"
status_directory="/usr/share/icons/Faenza/status/scalable"
stock_directory="/usr/share/icons/Faenza/sock/scalable"

echo "${color}Customizing (icons)..."${reset}

# Categories #

cd "$categories_directory" || exit

ln -s "$devices_directory"/computer-symbolic.svg "$categories_direectory"/preferences-desktop-peripherals-directory.svg
ln -s "$status_directory"/avatar-default-symbolic.svg "$categories_direectory"/preferences-desktop-personal-directory.svg
ln -s "$places_directory"/start-here-symbolic.svg "$categories_direectory"/preferences-system-directory.svg

Jeremy Bicha (jbicha) wrote :

This has been fixed with gnome-control-center 3.6.3 which was uploaded to raring for Ubuntu 13.04. Basically we're not using category header icons any more.

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
Adolfo Jayme (fitojb) wrote :

For the record, Tiheum included the category icons in Faenza a while ago. And as Jeremy says, these icons are no longer used.

Changed in ubuntu-mono (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments