add python-rsvg build dependency for verifying scour results

Bug #927606 reported by Paul Sladen on 2012-02-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-mono (Ubuntu)
Medium
Unassigned

Bug Description

  Source: ubuntu-mono
  Build-Depends: python-scour

on build gives:

  cmpsvg: python-rsvg not installed, cannot compare SVG images

Robert Roth (evfool) on 2012-02-06
Changed in scour (Ubuntu):
status: New → Confirmed
tags: added: packaging
tags: added: bitesize
Robert Roth (evfool) wrote :

The issue for me seems to be missing dependencies of the scour package on python-rsvg and python-cairo, as these are required to run cmpsvg,
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Martin Pitt (pitti) wrote :

If you have a project which uses SVGs heavily (such as ubuntu-mono), I'm afraid you need to manually add a python-rsvg build dependency. scour cannot depend on python-rsvg, as this would introduce pretty heavy build dependency loops.

See

scour (0.25+bzr207-2) unstable; urgency=low

  * debian/control: Drop python-rsvg and python-cairo from Depends to
    Suggests, it's a too heavy build dependency, causing dependency loops.
    Point out rationale for the Suggests in the package description.
    (LP: #734471)

affects: scour (Ubuntu) → ubuntu-mono (Ubuntu)
Changed in ubuntu-mono (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
summary: - "Build-dep: python-scour" does not pull in python-rsvg needed by
- 'cmpsvg'
+ add python-rsvg build dependency for resultsverifying scour
summary: - add python-rsvg build dependency for resultsverifying scour
+ add python-rsvg build dependency for verifying scour
summary: - add python-rsvg build dependency for verifying scour
+ add python-rsvg build dependency for verifying scour results
Daniel Holbach (dholbach) wrote :

Thanks a lot for your work on this, I will upload this in a bit, but will change the version number from 0.0.39ubuntu1 to 0.0.40, because that's in line with what the package used before. (It's a native package not used in Debian, therefore it's acceptable to use numbers-only versions). I know this is a bit confusing.

Daniel Holbach (dholbach) wrote :

I just uploaded the package, it's going to sit in the archive admin queue for Beta1 Freeze.

Changed in ubuntu-mono (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mono - 0.0.40

---------------
ubuntu-mono (0.0.40) precise; urgency=low

  * debian/control: added python-rsvg as explicit dep (LP: #927606)
 -- Nathan Williams <email address hidden> Wed, 29 Feb 2012 23:30:09 -0800

Changed in ubuntu-mono (Ubuntu):
status: Fix Committed → Fix Released
Paul Sladen (sladen) wrote :

Seems these never got pushed into revision control.

Paul Sladen (sladen) wrote :

Or rather, got branched from, and merged to lp:ubuntu/ubuntu-mono, not lp:ubuntu-mono

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers